Post by oolongtea » Sat Oct 08, 2011 3:10 am

Hi, I installed 1.5.1.3 opencart on 1and1 shared hosting and don't know how to enable the seo.
1) I went to system settings and selected enable seo
2) I rename .htaccess.text to .htaccess in my folder.

can somebody tell me what I did wrong?
the link is still ugly like http://mydomain.com/index.php?route=account/login

thanks!
Last edited by oolongtea on Sat Oct 08, 2011 5:18 am, edited 1 time in total.

Newbie

Posts

Joined
Thu Dec 09, 2010 6:28 am

Post by JAY6390 » Sat Oct 08, 2011 3:15 am

If .htaccess isn't working, I'd recommend contacting 1and1 support to see if the htaccess file is being parsed by apache

If your product pages are using seo urls correctly, then it is in fact enabled (assuming you've set your SEO urls for them)
links like the one above you gave are never SEO enabled by default, only special ones like products, categories, manufacturers, information pages

Image


User avatar
Guru Member

Posts

Joined
Wed May 26, 2010 11:47 pm
Location - United Kingdom

Post by oolongtea » Sat Oct 08, 2011 3:27 am

If your product pages are using seo urls correctly, then it is in fact enabled (assuming you've set your SEO urls for them)
Thanks for the quick reply, do I need to set my SEO urls? Can you tell me how?

thanks

Newbie

Posts

Joined
Thu Dec 09, 2010 6:28 am

Post by JAY6390 » Sat Oct 08, 2011 3:30 am

find the url alias field in the product editor on the data tab, and set the field

Image


User avatar
Guru Member

Posts

Joined
Wed May 26, 2010 11:47 pm
Location - United Kingdom

Post by uksitebuilder » Sat Oct 08, 2011 3:31 am

For products, categories, information pages and Manufacturers/brands you set the URL in the SEO Keyword field, usually on the General or Data tab when editing.

There are discussions on setting the standard links to use Friendly SEO URLs - so use our search feature.

There are also Auto SEO URL extensions available that will do it all for you.

ImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by oolongtea » Sat Oct 08, 2011 5:17 am

thanks guys!

Newbie

Posts

Joined
Thu Dec 09, 2010 6:28 am
Who is online

Users browsing this forum: No registered users and 45 guests