Post by lozzareeves » Mon Aug 01, 2011 9:29 am

I just changed my currency to pounds under settings and have now found that when you click the $ sign, its still the same amount of money on said item.

For example
item - £20 - click the $ sign up top - item - $20

th € sign works fine, that converts but the others don't.

I have now changed it back to us dollar but im still having the problem.

website is http://reeves-electronics.co.uk
:'(

Any help would be most appreciated!

Thank you.

New member

Posts

Joined
Fri Feb 25, 2011 7:10 am

Post by rph » Mon Aug 01, 2011 12:02 pm

Go to System->Localization->Currencies.
Click Edit for Pound Sterling and set the value to 1.0, Save.
Click Edit for US Dollar. Set value as 1.6446, Save.
Go to System->Settings and click Edit for your store. Under Local tab, set the Currency to Pound Sterling and Save.
Delete your cookies and check storefront.

-Ryan


rph
Expert Member

Posts

Joined
Fri Jan 08, 2010 5:05 am
Location - Lincoln, Nebraska

Post by uksitebuilder » Mon Aug 01, 2011 4:03 pm

You may also want to turn on Auto Currency update in System Settings.

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by rph » Mon Aug 01, 2011 5:25 pm

It can act a bit weird depending on how you update your currencies.

-Ryan


rph
Expert Member

Posts

Joined
Fri Jan 08, 2010 5:05 am
Location - Lincoln, Nebraska

Post by uksitebuilder » Mon Aug 01, 2011 5:48 pm

Seems to work fine for me in 1.5.0.5

and I have checked the code against 1.5.1.x and there is no difference.

I may have a look to see if I can code a fallback to a different currency conversions service as sometimes it can timeout etc.

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by rph » Mon Aug 01, 2011 5:58 pm

Yeah, I looked through the code and the actual issue is updateCurrencies can act stupid on occasion.

-Ryan


rph
Expert Member

Posts

Joined
Fri Jan 08, 2010 5:05 am
Location - Lincoln, Nebraska

User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by rph » Mon Aug 01, 2011 6:51 pm

Ah, could be. Another issue, though, is that auto-update forces a value of 1.0000 on the default currency but only updates alternate currencies based on date_modified. What it really should be doing is something like "if ($default_currency_value != 1) { update everything; } else { update based on age; }".

-Ryan


rph
Expert Member

Posts

Joined
Fri Jan 08, 2010 5:05 am
Location - Lincoln, Nebraska

Post by lozzareeves » Mon Aug 01, 2011 8:05 pm

rph wrote:Go to System->Localization->Currencies.
Click Edit for Pound Sterling and set the value to 1.0, Save.
Click Edit for US Dollar. Set value as 1.6446, Save.
Go to System->Settings and click Edit for your store. Under Local tab, set the Currency to Pound Sterling and Save.
Delete your cookies and check storefront.
Thank you very much! seems it got changed when i put the default to pounds for some reason.

all sorted now :)

New member

Posts

Joined
Fri Feb 25, 2011 7:10 am
Who is online

Users browsing this forum: Google [Bot] and 63 guests