Post by littleme » Tue Jul 05, 2011 2:35 am

Hello everyone,

I've read all posts regarding seo urls but still I can't make it work. I have the following version: 1.4.9.3
and I have followed these steps:
1. set "seo urls" under server settings
2. changed from htaccess.txt to . htaccess
3. added seo keyword to product to test
4. urls appears but gives me 404 pages....

htaccess looks like:

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled.

# 2. In your opencart directory rename htaccess.txt to .htaccess

# For any support issues please visit: http://www.opencart.com

Options +FollowSymlinks

# Prevent Directoy listing
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "\.(tpl|ini)">
Order deny,allow
Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]


### Additional Settings that may need to be enabled for some servers
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling, then restore the # as this means your host doesn't allow that.

# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
# php_flag register_globals off


pleeease help me

im a woman in need :)

Newbie

Posts

Joined
Tue Jul 05, 2011 2:17 am

Post by rph » Tue Jul 05, 2011 4:27 am

Is your shop in a subfolder by chance? If so you need to update RewriteBase to include it. So

Code: Select all

mystore.com/shop
would have

Code: Select all

RewriteBase /shop

-Ryan


rph
Expert Member

Posts

Joined
Fri Jan 08, 2010 5:05 am
Location - Lincoln, Nebraska

Post by littleme » Tue Jul 05, 2011 5:59 am

Hi,
thanks for the reply. no, the shop is on the index page (no sub folder).
As soon as I set the .htaccess the entire site crashes. Should that file include all that text written above?
And should it be in the root folder?

Newbie

Posts

Joined
Tue Jul 05, 2011 2:17 am

Post by rph » Tue Jul 05, 2011 1:47 pm

littleme wrote:As soon as I set the .htaccess the entire site crashes.
No pages load at all? Not even non-SEO?
Should that file include all that text written above?
And should it be in the root folder?
Yes to both.

-Ryan


rph
Expert Member

Posts

Joined
Fri Jan 08, 2010 5:05 am
Location - Lincoln, Nebraska

Post by SXGuy » Tue Jul 05, 2011 4:49 pm

you said you gave the product a seo url, did you give the category its in, a seo keyword also? i didnt see you mention that step.

Active Member

Posts

Joined
Sun Nov 08, 2009 2:07 am

Post by evanmorgan » Sat Jul 16, 2011 5:29 am

I was having the same problem, I read somewhere about 'commenting out' some lines in the .htaccess but couldn't find anywhere which ones these might be.

Well I dont know whether this affects other things on the site but I commented out the lines
#Options -Indexes
#Options +FollowSymlinks
with a preceeding # and it works.

Hopefully someone with more technical experience could explain whether this is a bad idea.

Good luck

Evan

New member

Posts

Joined
Sun Jul 03, 2011 10:42 pm

Post by hbg » Sat Jul 16, 2011 5:00 pm

I am no expert, but I have used an extension called SEO generator, which is free. I t has helped me out often.

Opencart Version 1.5.1.3
https://www.opencart.homebrewinn.com.au/shop/


User avatar
hbg
Active Member

Posts

Joined
Wed Apr 13, 2011 8:52 am
Location - Newcastle NSW Australia

Post by arvind7421 » Thu Feb 16, 2012 6:42 pm

rph wrote:Is your shop in a subfolder by chance? If so you need to update RewriteBase to include it. So

Code: Select all

mystore.com/shop
would have

Code: Select all

RewriteBase /shop

Thanks for this.....my site now working fine with seo via htaccess...

regards
arvind

Newbie

Posts

Joined
Fri Feb 10, 2012 8:17 pm
Who is online

Users browsing this forum: No registered users and 12 guests