Post by megahuman » Wed Jun 15, 2011 11:46 am

Hey guys,

Does anyone know how to send HTML newsletters through Opencart? I try to send mine and images wont show up...

I'm using 1.4.9.5 OC.

Cheers

Web Design and Development at 7 Design


Active Member

Posts

Joined
Tue Dec 14, 2010 4:57 pm

Post by megahuman » Sun Jun 19, 2011 11:38 am

Can anyone please help with this? I'm sure somebody else out there has had this problem and solved it??

Web Design and Development at 7 Design


Active Member

Posts

Joined
Tue Dec 14, 2010 4:57 pm

Post by megahuman » Wed Jun 22, 2011 9:20 am

Why is there no help ANYWHERE for this subject? If anything, sending newsletter can be one of the biggest marketing strategies for any business, it should be essential to have working correctly?

So the images work fine in Hotmail, but don't work in Mail clients like Thunderbird. Any fix>??

Web Design and Development at 7 Design


Active Member

Posts

Joined
Tue Dec 14, 2010 4:57 pm

Post by mcamca » Wed Jun 22, 2011 9:42 pm

megahuman wrote:Why is there no help ANYWHERE for this subject? If anything, sending newsletter can be one of the biggest marketing strategies for any business, it should be essential to have working correctly?

So the images work fine in Hotmail, but don't work in Mail clients like Thunderbird. Any fix>??
Our store is currently using Version 1.4.8b
Had a lot of problems with oc emails which were picked up as suspected spam. Also found that a second logo was also being displayed at the bottom of every email; annoying!

Modified mail.php file located at: /system/library/mail.php to eradicate these problems!
Have sent many emails including newsletters with up to a dozen images and again had no problems using the modified file.
This file also works for us on the later 1.4 versions with no problems.
You can view this modified file in text format at:

http://www.mcasoft.talktalk.net/upload/mail.txt

To try it you can copy the text file and save it as: mail.php
Substitute the existing mail.php with this new one (Keep a copy of the old one first!)
If you have problems then replace the new file with the old!
Let me know if this works for you!

If not there can be problems with some email clients when the text part of an html email does not match the html part.
You can see from mail.php that the text part will always be "This is an HTML email and your email client software does not support HTML email!"
Some also have problems with images which are base 64 encoded as with oc.
We have not looked into these possible problems!

-----------------------------------------------------------

User avatar
Active Member

Posts

Joined
Fri Aug 06, 2010 5:57 pm

Post by megahuman » Wed Jun 22, 2011 10:59 pm

Unfortunately this didn't fix it. I checked Hotmail and it the email looked fine, however in Thunderbird it's imageless, so I'm thinking its probably a thunderbird problem...

Web Design and Development at 7 Design


Active Member

Posts

Joined
Tue Dec 14, 2010 4:57 pm

Post by SXGuy » Thu Jun 23, 2011 1:06 am

thunderbird asks if you wish to display content, when you click the button, images should load. Perhaps your settings are stopping this option happening.

Active Member

Posts

Joined
Sun Nov 08, 2009 2:07 am

Post by megahuman » Thu Jun 23, 2011 5:51 am

Many HTML emails load, just not the opencart ones and a select few... its just bizarre that this is happening...

Web Design and Development at 7 Design


Active Member

Posts

Joined
Tue Dec 14, 2010 4:57 pm

Post by pagecom » Wed Dec 28, 2011 9:40 am

mcamca wrote:
megahuman wrote:Why is there no help ANYWHERE for this subject? If anything, sending newsletter can be one of the biggest marketing strategies for any business, it should be essential to have working correctly?

So the images work fine in Hotmail, but don't work in Mail clients like Thunderbird. Any fix>??
Our store is currently using Version 1.4.8b
Had a lot of problems with oc emails which were picked up as suspected spam. Also found that a second logo was also being displayed at the bottom of every email; annoying!

Modified mail.php file located at: /system/library/mail.php to eradicate these problems!
Have sent many emails including newsletters with up to a dozen images and again had no problems using the modified file.
This file also works for us on the later 1.4 versions with no problems.
You can view this modified file in text format at:

http://www.mcasoft.talktalk.net/upload/mail.txt

To try it you can copy the text file and save it as: mail.php
Substitute the existing mail.php with this new one (Keep a copy of the old one first!)
If you have problems then replace the new file with the old!
Let me know if this works for you!

If not there can be problems with some email clients when the text part of an html email does not match the html part.
You can see from mail.php that the text part will always be "This is an HTML email and your email client software does not support HTML email!"
Some also have problems with images which are base 64 encoded as with oc.
We have not looked into these possible problems!

-----------------------------------------------------------
Thank you so much your modified file solved my problem on 1.4.9.6 Install , all emails including Newsletters are being sent as html and view perfectly .

Thanks again
Joe

Newbie

Posts

Joined
Tue Oct 26, 2010 2:23 am

Post by sopedro » Sat Aug 18, 2012 11:53 pm

Dead Link. Please reupload the file.
I don't understand why i can's send html newsletters...

Please Daniel, solve this...

Newbie

Posts

Joined
Sat Jan 21, 2012 5:38 pm

Post by sopedro » Sun Aug 19, 2012 12:24 am

If possible no payable extension to do that, because this is a feature from the standard opencart script...

Remember...the knowledge belongs the world!!! :P

Newbie

Posts

Joined
Sat Jan 21, 2012 5:38 pm
Who is online

Users browsing this forum: No registered users and 37 guests