Post by Twist » Tue Oct 12, 2010 6:42 pm

Hello all,

I am running the latest version of Opencart. I am trying to use the SEO Keywords. I have changed my htaccess.txt to htaccess.

I started to make a new parent category called Party and I put the SEO keyword as Party I then created a sub category for this called Birthday Party and put into the SEO Keyword Birthdays. Everytime I now go on my website and click to go to these categories for example Party.. I get:

Not Found
The requested URL /party was not found on this server

I have also enabled SEO URLS in the main settings so I really have no idea what I am doing wrong. I hope I have explained this enough for you guys to understand and any help resolving this will be much appreciated.

Thank You

Just too add this is what my htaccess file looks like:

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled.

# 2. In your opencart directory rename htaccess.txt to .htaccess.

# For any support issues please visit: http://www.opencart.com

Options +FollowSymlinks

# Prevent Directoy listing
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "\.(tpl|ini)">
Order deny,allow
Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)\?*$ index.php?_route_=$1 [L,QSA]

New member

Posts

Joined
Wed Sep 09, 2009 7:02 am

Post by jty » Tue Oct 12, 2010 7:52 pm

areas to look at:
1. Is your installation in the root of your domain or in a subfolder
RewriteBase / for if your installation is in the root ie http://www.mystore.com
RewriteBase /shop/ if your installation is in the shop folder ie http://www.mystore.com/shop/

2. try small letters ie party instead of Party

see if that helps

jty
Active Member

Posts

Joined
Sat Aug 30, 2008 8:19 am

Post by Twist » Tue Oct 12, 2010 7:56 pm

Hi jty,

My installation is in the root of my domain and not in a subfolder and I have also tried using just small letters.

New member

Posts

Joined
Wed Sep 09, 2009 7:02 am

Post by Twist » Wed Oct 13, 2010 1:46 am

Just too add my mod_rewrite is also enabled....

New member

Posts

Joined
Wed Sep 09, 2009 7:02 am

Post by gavin m » Wed Oct 13, 2010 5:14 am

well, the htaccess file needs to be .htaccess not htaccess. as you have it in your first post.

Active Member

Posts

Joined
Thu Jun 04, 2009 3:23 pm

Post by Twist » Wed Oct 13, 2010 6:51 am

Hi Gavin,

Very good point and well spotted. I have now changed this to .htaccess. BUT still I am getting the same thing happen. Any other ideas?

New member

Posts

Joined
Wed Sep 09, 2009 7:02 am

Post by Twist » Wed Oct 13, 2010 7:02 pm

I have read all the instructions and gone through this over and over to make sure I am doing everything right but it is still not working. Maybe it would help if I tell you guys what steps I am taking. First of all I contacted my host to make sure mod_rewrite is enabled and they told me it is enabled by default which is great. I have then renamed my htaccess.txt to .htaccess. Then I went into my admin settings and enabled SEO URL. Then I went into my categorys (default ones that come with Opencart) And in categories I selected Laptops & Notebooks. I made sure there is a Meta tag keyword, meta tag description and a description. I have used random words for these keywords. Then I hit the data button and in SEO keywords I have put laptops. I then go into my products and select the Mac Airbook which is under the Laptops & Notebooks Category. I then give this product a meta tag keyword, meta tag description and normal description again I have just used random words like macair and maccy.. I then hit the data button and in my SEO keyword I put: macbookair.

Now if I go onto my website and click on the Laptops and Notebooks I will get a blank page with this:
Not Found
The requested URL /laptops was not found on this server.

This also occurs if I was to click on the mac air product.

Is there anything I am doing wrong here as I really want to get these SEO keywords working.

Thanks in advance.

New member

Posts

Joined
Wed Sep 09, 2009 7:02 am

Post by jty » Wed Oct 13, 2010 7:50 pm

the meta keywords are not important for this exercise, though they won't cause any probs either
It is the seo keyword that is important here

I have read what you have done and it all looks right unless I'm missing some fine point (like the dot in the wrong place)

These are the steps (just to do another re-check)
1. Upload the htaccess.txt and rename it to .htaccess. As your installation is in the root, do not change the htaccess in any other way except to change it to .htaccess.
It needs to live in the root, not a subfolder or anywhere else, but in the root ie http://www.mystore.com/.htaccess

2. Next in Open Cart, create a category and have something in the seo keywords field

3. Turn on SEO URL alias in admin > settings > server

That's it. Except it don't work for you so .............
Google phpinfo and make a phpinfo file. Use this file to make sure Apache mod rewrite is enabled
I know your webhost said it is but see what the machine says.
a phpinfo is really easy except I can't remember the instructions so go googling or search here. There might be info on phpinfo here.

jty
Active Member

Posts

Joined
Sat Aug 30, 2008 8:19 am

Post by Twist » Wed Oct 13, 2010 8:04 pm

Hi jty,

Thank you for taking the time to read through and reply. I have set up a phpinfo file but Do you know if mod_rewrtie is called something else as I did a search ont he page and the closest to rewrtie was this: url_rewriter.tags

New member

Posts

Joined
Wed Sep 09, 2009 7:02 am

Post by Xsecrets » Wed Oct 13, 2010 8:28 pm

from reading through I'm still not certain you have the file name right it should be ".htaccess" there is a dot at the beginning and no dot at the end.

OpenCart commercial mods and development http://spotonsolutions.net
Layered Navigation
Shipment Tracking
Vehicle Year/Make/Model Filter


Guru Member

Posts

Joined
Sun Oct 25, 2009 3:51 am
Location - FL US

Post by Twist » Wed Oct 13, 2010 8:49 pm

Hi X,

In the instructions it states this:

# 2. In your opencart directory rename htaccess.txt to .htaccess.

If I rename my htaccess to .htaccess them I cannot go onto my homepage I get the following error:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

New member

Posts

Joined
Wed Sep 09, 2009 7:02 am

Post by Twist » Wed Oct 13, 2010 9:15 pm

Problem solved!! X your correct it should of just been .htaccess

But also I needed to remove some code from the .htaccess file. I removed the following:

Options +FollowSymlinks

Options -Indexes

And it now works. Being honest my host actually told me to do this and since then it works woo hoo!! Thank you for all your help guys much appreciated!

New member

Posts

Joined
Wed Sep 09, 2009 7:02 am

Post by jty » Wed Oct 13, 2010 9:26 pm

Oh good.
The dot is always at the beginning of htaccess
the reason it is written .htaccess. is that the last dot is because in English, we end a sentence with a dot.
OK for those of us that know but a bit confusing for those that don't

Just for future visitors it is :
.htaccess

And the reason why it is named htaccess.txt in the download is because Windoze demands an extension. That is why we have to rename it, cuz of Windoze

jty
Active Member

Posts

Joined
Sat Aug 30, 2008 8:19 am

Post by JAY6390 » Wed Oct 13, 2010 9:31 pm

It's not strictly true that it requires an extension in windows, you can name a file .htaccess say in notepad just by putting double quotes around it when saving, so saving as ".htaccess" will work just fine. I'm pretty sure the .txt is just so that people can edit it easily should they wish to, and also to prevent it giving an internal server error if it's not supported (ie doesn't have mod_rewrite enabled by apache)

Image


User avatar
Guru Member

Posts

Joined
Wed May 26, 2010 11:47 pm
Location - United Kingdom

Post by Twist » Wed Oct 13, 2010 9:40 pm

jty wrote:Oh good.
The dot is always at the beginning of htaccess
the reason it is written .htaccess. is that the last dot is because in English, we end a sentence with a dot.
OK for those of us that know but a bit confusing for those that don't

Just for future visitors it is :
.htaccess

And the reason why it is named htaccess.txt in the download is because Windoze demands an extension. That is why we have to rename it, cuz of Windoze
Haha I am English so it was just me being stupid :joker: I need a Dunce hat..

New member

Posts

Joined
Wed Sep 09, 2009 7:02 am

Post by jty » Wed Oct 13, 2010 9:53 pm

JAY6390 wrote:It's not strictly true that it requires an extension in windows, you can name a file .htaccess say in notepad just by putting double quotes around it when saving, so saving as ".htaccess" will work just fine.
Oh good. Thanks Jay. I am forever having problems renaming the htaccess file in windows. It just swears at me.
There is another way to rename it in windows but I keep forgetting what it is.
I'm pretty sure the .txt is just so that people can edit it easily should they wish to, and also to prevent it giving an internal server error if it's not supported (ie doesn't have mod_rewrite enabled by apache)
Actually, this sounds right. If it wasn't .txt then others would have probs.

jty
Active Member

Posts

Joined
Sat Aug 30, 2008 8:19 am
Who is online

Users browsing this forum: No registered users and 61 guests