Page 1 of 1

After install SSL - problem with mixed content http / https

Posted: Tue Jun 25, 2019 5:14 am
by bogdangergov1
after install SSL - problem with mixed content http / https
/only from fronted page, admin page is OK/
how can i fix the problem

all images - https
menu category - http

see link

sorry for bad English

my opencart ver. 1.5.6

my .htacces

Code: Select all

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]



# 1.To use URL Alias you need to be running apache with mod_rewrite enabled. 

# 2. In your opencart directory rename htaccess.txt to .htaccess.

# For any support issues please visit: http://www.opencart.com

Options +FollowSymlinks

# Prevent Directoy listing 
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "\.(tpl|ini|log)">
 Order deny,allow
 Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/ 

RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
RewriteRule ^download/(.*) /index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

Re: After install SSL - problem with mixed content http / https

Posted: Tue Jun 25, 2019 9:31 am
by EvolveWebHosting
Take a look at this link and test any URL on their site that you need to: https://www.whynopadlock.com/results/84 ... b1e08cda4a