Post by world-of-satellite » Sat Feb 02, 2019 10:11 pm

Running OC 1.5.3.1/

Tried upgrading dedicated server to easyapache4 and php5.4.

Got the error below:
Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /home/XXXXX/public_html/system/database/mysql.php on line 6

Tried theres to fixes:
https://www.opencart.com/index.php?rout ... _license=0

Also this:
https://www.opencart.com/index.php?rout ... _license=0

Fixes clear the error, but I'm no longer able to access admin panel.

Any ideas anyone? Or is it time to upgrade? Could do without the hassle of upgrading as have a custom theme and an number of changes.

Active Member

Posts

Joined
Sun Jun 27, 2010 1:40 pm

Post by IP_CAM » Sun Feb 03, 2019 8:35 am

One more would exist, to try, but you have to make sure, to have Mysqli
configured in both config.php files.
And if you plan to update, better only up to the latest 1.5 Version, or you
will loose every Mod, and have to get the DB reworked, to still function.
Check my Github Repository for the latest OC v.1.5.6.5_rc Version.
Ernie

Code: Select all

// DB
define('DB_DRIVER', 'mysqli');
https://www.opencart.com/index.php?rout ... n_id=24413

I'm rarely active at the OC Forum lately. To reach me, contact: jti@jacob.ch
A Demoversion of my free OpenCart LIGHT v.1.5.6.5 Software Edition
can be seen in real Action here: http://www.jti.li/shop/
---
1'200+ FREE OC Extension-Repositories - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
---
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland
Who is online

Users browsing this forum: Google [Bot] and 62 guests