Post by desen » Mon Sep 27, 2010 11:25 pm

Greetings, i have searched for an appropiate answer, but couldn't find anything to help me with this problem:

I have a SSL certificate,
- i have installed it successfully on my site via CPanel,
- i have successfully edited the config.php file with proper code (https instead of http)
- i have enabled USE SSL from the Admin Panel.

But still, i cannot see images while i'm trying to login/checkout/register neither when i login into the Admin page.

1. How can i fix this problem ?
2. How can i force SSL on entire website ?

Newbie

Posts

Joined
Wed Aug 18, 2010 3:48 pm

Post by SteveSherry » Tue Sep 28, 2010 4:26 am

Can you please post a link to the site?

SSL is only for the checkout pages, not for the entire site.

My Website ¦ Summer Madness Special Offer ¦


Active Member

Posts

Joined
Thu Apr 08, 2010 7:47 am
Location - Wirral, UK

Post by desen » Tue Sep 28, 2010 7:33 am

Link, as you requested: https://orgonit.ro/index.php?route=checkout/cart
If you simply modify "https" to "http" from the link above, it will work like a charm.

Code for /admin/config.php:

Code: Select all

// HTTP
define('HTTP_SERVER', 'http://orgonit.ro/admin/');
define('HTTP_CATALOG', 'http://orgonit.ro/');
define('HTTP_IMAGE', 'http://orgonit.ro/image/');

// HTTPS
define('HTTPS_SERVER', 'https://orgonit.ro/admin/');
define('HTTPS_IMAGE', 'https://orgonit.ro/image/');
define('HTTPS_CATALOG', 'https://orgonit.ro/'); ------ > this is what i have added later, with no effect

// DIR
define('DIR_APPLICATION', '/home/orgonit/public_html/admin/');
define('DIR_SYSTEM', '/home/orgonit/public_html/system/');
define('DIR_DATABASE', '/home/orgonit/public_html/system/database/');
define('DIR_LANGUAGE', '/home/orgonit/public_html/admin/language/');
define('DIR_TEMPLATE', '/home/orgonit/public_html/admin/view/template/');
define('DIR_CONFIG', '/home/orgonit/public_html/system/config/');
define('DIR_IMAGE', '/home/orgonit/public_html/image/');
define('DIR_CACHE', '/home/orgonit/public_html/system/cache/');
define('DIR_DOWNLOAD', '/home/orgonit/public_html/download/');
define('DIR_LOGS', '/home/orgonit/public_html/system/logs/');
define('DIR_CATALOG', '/home/orgonit/public_html/catalog/');

Newbie

Posts

Joined
Wed Aug 18, 2010 3:48 pm

Post by SteveSherry » Tue Sep 28, 2010 8:17 am

I think the problem lies in both root/config.php & admin/config.php
If I were you i'd change the following lines (and their root equivalents) back to HTTP://

Code: Select all

// HTTPS
define('HTTPS_SERVER', 'https://orgonit.ro/admin/');
define('HTTPS_IMAGE', 'https://orgonit.ro/image/');
The store will be in HTTP:// and only once you go into making a purchase then it'll change to HTTPS://

My Website ¦ Summer Madness Special Offer ¦


Active Member

Posts

Joined
Thu Apr 08, 2010 7:47 am
Location - Wirral, UK

Post by desen » Tue Sep 28, 2010 8:23 am

So you're basically saying that i have to buy a SSL certificate and that it will not work with the free solution i have ?

Newbie

Posts

Joined
Wed Aug 18, 2010 3:48 pm

Post by SteveSherry » Tue Sep 28, 2010 8:25 am

no, i'm saying that SSL doesn't encrypt the whole of your website.
It only needs to cover the transaction pages, not whilst browsing your products

My Website ¦ Summer Madness Special Offer ¦


Active Member

Posts

Joined
Thu Apr 08, 2010 7:47 am
Location - Wirral, UK

Post by desen » Tue Sep 28, 2010 8:30 am

Sorry, but i still cannot understand why the images are not displayed properly while the USE SSL option is ON... and i still don't have an answer/solution to this problem that i'm facing.

What i'm running is a free SSL solution but i haven't encountered any problems with it till now (Opera/Chrome/Firefox).

PS: let me get this clear and short, forgetting about encrypting the whole website: the images are not displayed properly while using SSL in the /admin/ and /login/register/ pages.

Newbie

Posts

Joined
Wed Aug 18, 2010 3:48 pm

Post by Qphoria » Tue Sep 28, 2010 10:25 am

SteveSherry wrote:I think the problem lies in both root/config.php & admin/config.php
If I were you i'd change the following lines (and their root equivalents) back to HTTP://

Code: Select all

// HTTPS
define('HTTPS_SERVER', 'https://orgonit.ro/admin/');
define('HTTPS_IMAGE', 'https://orgonit.ro/image/');
The store will be in HTTP:// and only once you go into making a purchase then it'll change to HTTPS://
This is just for the admin/config.php
the main config.php doesn't have these lines

What do you have set for your url in the main settings area in the admin?

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am
Who is online

Users browsing this forum: Baidu [Spider] and 54 guests