Post by thomash2 » Sat Jun 16, 2018 8:52 am

With OC 1.5.x I was able to get ssl://smtp.gmail.com to work with port 465. But I wasn't able to get port 587 to work.

With ssl://smtp.gmail.com
I get error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol

With tls://smtp.gmail.com
I get error:1408F10B:SSL routines:SSL3_GET_RECORD:wrong version number

I normally have my settings email different from the SMTP email. I tried making both the same, but that did not help either.

There is a post in another thread that says replacing parts of mail.php may fix this, but does it really work?
$this->from
to
$this->smtp_username

viewtopic.php?f=202&p=703749

Another post says something similar:
https://github.com/opencart/opencart/is ... t-97519284

However "SSL3_GET_RECORD:wrong version number" sounds like a problem with the SSL/TLS version?
Anything I can change in cPanel?

New member

Posts

Joined
Tue Jul 30, 2013 12:44 am

Post by synapseindia » Mon Jun 18, 2018 7:41 pm

I am using outlook for SMTP integration and getting same error. Any fixes ?

User avatar
Active Member

Posts

Joined
Thu Apr 05, 2018 2:27 pm

Post by thomash2 » Mon Jun 18, 2018 10:44 pm

I previously mentioned that I got port 465 to work with gmail, however today I get an error that the password is rejected. I use an App password since I have 2-factor authentication in Gmail. However every new App password that I generated and tried is rejected. The security email from Google says an insecure app has been blocked and to turn on "less secure Apps", however "less secure Apps" option is not available when 2-factor authentication is on and the help page says to use App password. So I'm not sure how to get this to work again.

New member

Posts

Joined
Tue Jul 30, 2013 12:44 am

Post by thomash2 » Tue Jun 19, 2018 7:26 am

I was able to get SMTP working again by using the unlock function (still with port 465 with SSL protocol):
https://accounts.google.com/DisplayUnlockCaptcha

However, I had to log out of all Google accounts from my browser and then log in with the account that needed unlocking. Then click the button, and then try sending a notification email through the backend of Opencart.

When I had several accounts logged in at the same time, the URL seems to apply to the primary account that was logged into first, and the unlock function didn't work for the secondary account that needed unlocking.

Still don't know how to get 587 to work.

New member

Posts

Joined
Tue Jul 30, 2013 12:44 am

Post by Nyrk0 » Wed May 29, 2019 1:32 pm

1. OpenCart System Configuration Mail Protocol: SMTP
host tls://smtp.gmail.com, then your gmail account username and password, port 587, and timeout 100 or so.

2. Enable IMAP for that gmail account
https://mail.google.com/mail/u/3/#settings/fwdandpop

3. Change account access for less secure apps
https://support.google.com/accounts/ans ... 0255?hl=en

4. Allow Access
https://accounts.google.com/b/0/DisplayUnlockCaptcha

5. Login to your store and make a test order for yourself
Login to your admin and add some order history with Notify Customer enabled.

This has worked for me at https://www.globalmac.cl with OC 2.3.0.2

New member

Posts

Joined
Tue Sep 18, 2012 4:46 am
Who is online

Users browsing this forum: No registered users and 33 guests