Post by draysniro » Sat Mar 31, 2018 11:50 pm

Hi All,

It's been a while since I've visited as I haven't worked on an OpenCart site in a few years. However, the client I built the OC site for is having issues with affiliate signups. He contacted me the other day saying that he was getting dozens of new customers and they were all marked as affiliates. He doesn't use the affiliate system, so I disabled it. Still had the problem. I went in yesterday and added the reCAPTCHA to the signup forms and completely uninstalled the affiliate system. The reCAPTCHA seems to have stopped the customer signups, but he's still getting affiliates somehow. Today, he had 38 more affiliates. I can't figure out how this is happening. I just went in and changed his db password and updated it in the config files, but I don't know if that will be the fix. Has anyone seen this? I only found one other thread similar to this and the reCAPTCHA seems to have fixed it for them. I'm at a loss as to what to do at this point.

Newbie

Posts

Joined
Fri Oct 26, 2012 7:03 am

Post by straightlight » Sun Apr 01, 2018 12:02 am

No OC version posted. Although, it has been mentioned in multiple topics on the forum to also use the CSRF Protection form extension along with the reCAPTCHA extension: https://www.opencart.com/index.php?rout ... on_id=4773 . If having any issues with it, please submit a request through PM or to the official CSRF Support forum topic mentioned on the Marketplace page.

Note: In case you haven't tried Johathan's reCAPTCHA module: viewtopic.php?f=190&t=203222&p=718991#p718991 in case you might be using another version.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com contractor officials representative


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by IP_CAM » Sun Apr 01, 2018 12:25 am

Well, I just tested this VqMod yeaterday, and it seems to do it's Job well
in my latest v.1.5.6.5_rc Version. And it works, for those, beeing
familiar with 1.5.x, in all 1.5.6.x Version as well. :D
But that Fix linked would not work in any v.1.5.x Version anyway, as it looks. :(

Code: Select all

https://www.opencart.com/index.php?route=marketplace/extension/info&extension_id=4773
Good Luck
Ernie
---
Disable Affiliate v2.2 free, OC v.1.5.0 - 1.5.6.5_rc:
This is simple vQMod to remove the affiliate link from your store, and redirect to
homepage if visitor types in your affiliate link manually or picked up from Google.
This vQMod does not remove any affiliate functions. It just remove affiliate link and
redirect the affiliate page the your homepage. You can just simply remove this vQMod
if you do need the affiliate program again.
https://www.opencart.com/index.php?rout ... on_id=7300
---
Last edited by IP_CAM on Sun Apr 01, 2018 12:37 am, edited 2 times in total.

I'm no longer quite active at the Forum, to reach me, better contact: jti@jacob.ch
My free Opencart LIGHT 1.5.6.5 Code is available on GitHub soon,
a Demoversion of it can be seen in Action here: http://www.bigmax.ch
930+ FREE OC Extension-Repositories - from OC v.1.5.x up, on the
world's largest OC-related Github Site: https://github.com/IP-CAM
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by straightlight » Sun Apr 01, 2018 12:33 am

Since the mentioned extension from the reply above only mentions to remove the affiliate links, it does not represent any challenge to the CSRF attackers.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com contractor officials representative


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by draysniro » Sun Apr 01, 2018 1:27 am

Apologies. It’s V1.5.5.1. I had it, but must’ve deleted it when revising the post.

Newbie

Posts

Joined
Fri Oct 26, 2012 7:03 am
Who is online

Users browsing this forum: Bing [Bot] and 17 guests