Post by takayuki » Wed Mar 29, 2017 12:39 pm

Hi,

I'm creating a custom add item page for OC 1.5.2.x.

It's just a simple php mysqli script that exists outside of the opencart backend that generates a mysql insert query.

Right now, I've got data going into the database.

But the problem is that the item does not show up on the main page. (The item does show up on the opencart backend and if I simply click the edit link then save it, the item will suddenly show up on the main page.)

I think it might be a cache issue, anyone have any ideas about how to make this work?



Here's a sample query:
INSERT INTO product (model, upc, quantity, stock_status_id, image, manufacturer_id, shipping, price, date_available, weight, weight_class_id, length, width, height, length_class_id, measurement_class_id, sort_order, status, date_added, date_modified, viewed, cost, minimum, maximum, subtract) VALUES ('#1234testproduct', '', '1', '7', 'image/2017/big/picture.jpg', '22', '1', '23', '2017-01-01', '', '2', '12', '', '', '1', '', '0', '1', '2017-03-29 12:36:09', '', '', '', '1', '', '1');

INSERT INTO product_description (product_id, language_id, name, meta_description, description, meta_keyword) VALUES ('18837','1', 'Test product','heres the meta tag desc for test product','This is a great test product.','test, product, keywords');INSERT INTO product_to_store (product_id, store_id) VALUES ('18837','0');INSERT INTO product_reward (product_id, customer_group_id, points) VALUES ('18837','6','0'),('18837','8','0'),('18837','9','0'),('18837','10','0'),('18837','11','0');

thanks,

takayuki

New member

Posts

Joined
Thu Aug 13, 2009 10:16 pm
Who is online

Users browsing this forum: No registered users and 65 guests