Post by Maansy » Mon Jul 12, 2010 7:28 am

i cant stay logged in the admin page. here is my php.ini:

magic_quotes_gpc = Off;
register_globals = Off;
default_charset = UTF-8;
memory_limit = 64M; max_execution_time = 18000;
max_upload_filesize = 100M;
safe_mode = Off;
mysql.connect_timeout = 20;
session.use_cookies = On; session.use_trans_sid = Off;
session.gc_maxlifetime = 12000000;
Last edited by i2Paq on Mon Jul 12, 2010 10:59 pm, edited 2 times in total.
Reason: Topic moved

ALL Templates :: 1.5.1+ Templates :: 50%-75% PRICE DROP ONLY at OpencartStuff.com


User avatar
Active Member

Posts

Joined
Thu Jun 24, 2010 6:04 am


Post by SteveSherry » Mon Jul 12, 2010 7:29 am

which version number are you on?
Have you upgraded recently?

My Website ¦ Summer Madness Special Offer ¦


Active Member

Posts

Joined
Thu Apr 08, 2010 7:47 am
Location - Wirral, UK

Post by Maansy » Mon Jul 12, 2010 7:31 am

SteveSherry wrote:which version number are you on?
Have you upgraded recently?
latest version 1.4.8B
no upgrade yet
this is happening since day 1
and yes i clean out browser cache and cookies

most of the time it says:
Invalid token session. Please login again.
ans sometimes just loads the username/password fields without warning error

ALL Templates :: 1.5.1+ Templates :: 50%-75% PRICE DROP ONLY at OpencartStuff.com


User avatar
Active Member

Posts

Joined
Thu Jun 24, 2010 6:04 am


Post by SteveSherry » Mon Jul 12, 2010 8:13 am

I had this problem when I'd installed an "old" module.

I fixed this by upgrading my modules to include the new token feature.

My Website ¦ Summer Madness Special Offer ¦


Active Member

Posts

Joined
Thu Apr 08, 2010 7:47 am
Location - Wirral, UK

Post by Maansy » Mon Jul 12, 2010 9:54 am

any help here?
am I the only one with this problem??

ALL Templates :: 1.5.1+ Templates :: 50%-75% PRICE DROP ONLY at OpencartStuff.com


User avatar
Active Member

Posts

Joined
Thu Jun 24, 2010 6:04 am


Post by SteveSherry » Mon Jul 12, 2010 10:10 am

did my suggestion not help?

My Website ¦ Summer Madness Special Offer ¦


Active Member

Posts

Joined
Thu Apr 08, 2010 7:47 am
Location - Wirral, UK

Post by Maansy » Mon Jul 12, 2010 10:27 am

SteveSherry wrote:did my suggestion not help?
Steve, thanks for taking the time to answer me, but as i stated before i had this issue since day 1 (on a fresh 1.48B install).
i was hoping i could solve this issue soon.
i am planing to add 35 - 50 products, so my guess is 156 log in attempts . this is crazy :crazy: believe me.

you can even try the front-end, its happening there too.
username:test@test123.com
password:test

ALL Templates :: 1.5.1+ Templates :: 50%-75% PRICE DROP ONLY at OpencartStuff.com


User avatar
Active Member

Posts

Joined
Thu Jun 24, 2010 6:04 am


Post by Xsecrets » Mon Jul 12, 2010 11:28 am

if it's not the problem of a rouge module then your php session lifetime is set very short. Not all shared hosting looks for settings in a php.ini in your folders. Some require you to use .htaccess to set php settings. some require php.ini in a different folder like etc and some simply don't allow you to make any changes to php you'll need to check with your host to see how to make changes to php settings.

OpenCart commercial mods and development http://spotonsolutions.net
Layered Navigation
Shipment Tracking
Vehicle Year/Make/Model Filter


Guru Member

Posts

Joined
Sun Oct 25, 2009 3:51 am
Location - FL US

Post by Maansy » Mon Jul 12, 2010 4:09 pm

i strongly believe any module has anything to do with this issue, as it was there on a fresh installed copy of 1.48B.
so i am forced to lean towards the other possible reason.
but 1st, do you think the session time is set too low? even php.ini shows this?:
session.gc_maxlifetime = 12000000;
if yes, then would you tell me what exactly i should ask the host company reagarding php.ini?
thanks

ALL Templates :: 1.5.1+ Templates :: 50%-75% PRICE DROP ONLY at OpencartStuff.com


User avatar
Active Member

Posts

Joined
Thu Jun 24, 2010 6:04 am


Post by Xsecrets » Mon Jul 12, 2010 7:42 pm

create a file somewhere and put in it this code

Code: Select all

<?php phpinfo(); ?>
then use your browser to goto that file and find the session timeout. That will tell you what your installation of php is actually using. If it does not match the php.ini file you keep referencing then you need to contact your host and ask them how to change it.

OpenCart commercial mods and development http://spotonsolutions.net
Layered Navigation
Shipment Tracking
Vehicle Year/Make/Model Filter


Guru Member

Posts

Joined
Sun Oct 25, 2009 3:51 am
Location - FL US

Post by Maansy » Mon Jul 12, 2010 8:03 pm

Xsecrets wrote:create a file somewhere and put in it this code

Code: Select all

<?php phpinfo(); ?>
then use your browser to goto that file and find the session timeout. That will tell you what your installation of php is actually using. If it does not match the php.ini file you keep referencing then you need to contact your host and ask them how to change it.
PM sent

ALL Templates :: 1.5.1+ Templates :: 50%-75% PRICE DROP ONLY at OpencartStuff.com


User avatar
Active Member

Posts

Joined
Thu Jun 24, 2010 6:04 am


Post by InfiniteDezigns » Sun Aug 29, 2010 10:41 am

I did this and my server matches everything in the custom PHP.ini file and I'm still getting kicked out as well. Now what?

New member

Posts

Joined
Mon Jun 21, 2010 5:18 am

Post by Maansy » Sun Aug 29, 2010 10:52 am

i was using a free host to test oc thats why. since i used hostgator it doesnt log me out anymore :)

ALL Templates :: 1.5.1+ Templates :: 50%-75% PRICE DROP ONLY at OpencartStuff.com


User avatar
Active Member

Posts

Joined
Thu Jun 24, 2010 6:04 am

Who is online

Users browsing this forum: Google [Bot] and 71 guests