Post by rocketfoot » Sat May 28, 2016 6:47 pm

I had to upgrade PHP on my server from 5.4 to 5.6 but now my OpenCart Admin Panel is inaccessible! I get this error:

Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /home/bigmackt/public_html/wattsmack/store/system/database/mysql.php on line 6

The error also shows on every store page.

I have already uploaded the latest vQmod and tried changing config.php to mysqli but it does not work!

I can't find my current OC build but I think it is 1.5.6

I need some quick help please! I have a busy store and it is not working now!
Last edited by rocketfoot on Tue May 31, 2016 11:28 pm, edited 1 time in total.

OpenCart 1.5.6
www.wattstruckcenter.com/store


User avatar
New member

Posts

Joined
Fri Nov 15, 2013 10:47 pm

Post by artcore » Sat May 28, 2016 7:00 pm

Done this before for 1.5.6
Shoot me a pm with ftp and I'll sort it in a few minutes.

Attn: I no longer provide OpenCart extensions, nor future support - this includes forum posts.
Reason: OpenCart version 3+ ;D

Thanks!


User avatar
Active Member

Posts

Joined
Tue Jul 09, 2013 4:13 am
Location - The Netherlands

Post by rocketfoot » Sat May 28, 2016 7:23 pm

PM Sent...I think I have bigger problems now! I figured that I would upgrade to the latest version but now I cant even get the install script to run! I hope you can help!

OpenCart 1.5.6
www.wattstruckcenter.com/store


User avatar
New member

Posts

Joined
Fri Nov 15, 2013 10:47 pm

Post by rocketfoot » Tue May 31, 2016 11:29 pm

SOLVED...artcore was able to fix my errors and get me back in business! Thanks!!

OpenCart 1.5.6
www.wattstruckcenter.com/store


User avatar
New member

Posts

Joined
Fri Nov 15, 2013 10:47 pm

Post by timplum » Fri Jun 10, 2016 9:33 pm

Also SOLVED...artcore fixed the issue lickety split and I'm back in business. Many thanks.

Newbie

Posts

Joined
Tue Feb 12, 2013 11:54 am

Post by artcore » Fri Jun 10, 2016 9:36 pm

You're welcome guys :)

Attn: I no longer provide OpenCart extensions, nor future support - this includes forum posts.
Reason: OpenCart version 3+ ;D

Thanks!


User avatar
Active Member

Posts

Joined
Tue Jul 09, 2013 4:13 am
Location - The Netherlands

Post by artcore » Tue Sep 27, 2016 6:46 pm

See attached!

Use a decent file editor like SublimeText or Notepad++ when changing server side files!

0. Make a backup of files to be overwritten/changed!
1. Upload the contents of the upload folder to your shop using FTP.
2. Change config.php in both admin and root

Code: Select all

define('DB_DRIVER', 'mysql');
to

Code: Select all

define('DB_DRIVER', 'mysqli');

Attn: I no longer provide OpenCart extensions, nor future support - this includes forum posts.
Reason: OpenCart version 3+ ;D

Thanks!


User avatar
Active Member

Posts

Joined
Tue Jul 09, 2013 4:13 am
Location - The Netherlands
Who is online

Users browsing this forum: Google [Bot] and 42 guests