Post by BeerinaBottle » Mon Aug 18, 2014 4:49 pm

Hi all

My website was working fine using version 1.5.6.1, then all of a sudden it started generating these internal server errors:

Cannot allocate memory: couldn't create child process: /opt/suphp/sbin/suphp (at various URLs)

The errors are occurring both in admin and the catalog side and happen indiscriminately throughout the site. I thought at first it may be a problem with my web host but they have migrated me to a new server and still the problems continue.

Does anyone have any idea what could be causing this?

Thanks.

Real Ales from an Online Beer Shop


New member

Posts

Joined
Wed Feb 12, 2014 11:35 pm
Location - Hull, East Yorkshire

Post by labeshops » Mon Aug 18, 2014 7:17 pm

Sounds like the disk is full. Do you have error logging turned on? It can fill up a drive fast. Turn it off and delete the error file from your system/logs folder. Clear all your caches and see if that solves it.

Running Opencart v2.2 with multi-stores from https://www.labeshops.com which has links to all my stores.

Image


User avatar
Expert Member

Posts

Joined
Thu Aug 04, 2011 4:41 am
Location - Florida, USA

Post by BeerinaBottle » Wed Aug 20, 2014 1:39 am

Thanks for the suggestion but this didn't help. I thought the problem may have been the server I was using so I set up a brand new site on a different server, version 1.5.6.4 with no mods, and while entering details to register as a new customer this popped up:

Internal Server Error

Internal Server Error

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>500 Internal Server Error</title>
</head><body>
<h1>Internal Server Error</h1>
<p>The server encountered an internal error or
misconfiguration and was unable to complete
your request.</p>
<p>Please contact the server administrator,
webmaster@beerinabottle.co.uk and inform them of the time the error occurred,
and anything you might have done that may have
caused the error.</p>
<p>More information about this error may be available
in the server error log.</p>
<p>Additionally, a 500 Internal Server Error
error was encountered while trying to use an ErrorDocument to handle the request.</p>
</body></html>

Does anyone know what the problem is? Is it time to ditch Opencart?

Real Ales from an Online Beer Shop


New member

Posts

Joined
Wed Feb 12, 2014 11:35 pm
Location - Hull, East Yorkshire

Post by BeerinaBottle » Fri Aug 22, 2014 1:04 am

Is there anyone who can help with this please? My web host is blaming Opencart software for taking up too much server memory, so... is the problem Opencart or do I need to find another web host?

Real Ales from an Online Beer Shop


New member

Posts

Joined
Wed Feb 12, 2014 11:35 pm
Location - Hull, East Yorkshire

Post by ElliotHC » Fri Jan 27, 2017 8:03 pm

Did you solve this problem?

I have the same issue.

Thanks

Newbie

Posts

Joined
Sun Jan 08, 2017 8:28 pm

Post by EvolveWebHosting » Sat Jan 28, 2017 10:15 am

BeerinaBottle wrote:Is there anyone who can help with this please? My web host is blaming Opencart software for taking up too much server memory, so... is the problem Opencart or do I need to find another web host?
It's hard to know for sure without doing a bit more investigation. Are you using shared hosting? Do you have other extensions installed that may be poorly written? Answers to these questions will help determine what's really going on.

If you're using v1.5.6.1, I would suggest upgrading to 1.5.6.4 atleast. 1.5.6.4 was a really stable version.

Image
https://www.evolvewebhost.com
$10.49 .com Registration and $9.99 .com Transfers in now
Guaranteed top level opencart performance and support. Risk free 30 day money back guarantee & free transfers.
Image


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA
Who is online

Users browsing this forum: No registered users and 37 guests