Post by maccadon » Sat Aug 09, 2014 2:50 pm

I have a website running on Opencart 1.5.4.1. with a Comodo SSL Certificate

When i'm on the cart page and i want to change the product quantity i get the following error

Code: Select all

opencart Although this page is encrypted, the information you have entered is to be sent over an unencrypted connection and could easily be read by a third party.
You then have to choose continue or cancel.
I checked the page on http://www.whynopadlock.com/check.php and there it says that everything is secure.
I also get the secure padlock on Firefox so it should work

When i check the page with the firefox Element inspector i see the following error

Code: Select all

Use of getPreventDefault() is deprecated.  Use defaultPrevented instead.
This error links to jquery.min.js and is a jquery version v.1.7.1
i searched for this error and i read to i need to update to a new jquery.

so my questions.

1. Is the popup error related to the jqeury warning?
2. How can i find out what the problem is because i only get the error when i update the quantity?
Last edited by maccadon on Thu Dec 18, 2014 4:22 am, edited 1 time in total.

Active Member

Posts

Joined
Thu Aug 05, 2010 9:57 pm

Post by SXGuy » Sat Aug 09, 2014 3:52 pm

Why don't you just upgrade your jquery library?

Active Member

Posts

Joined
Sun Nov 08, 2009 2:07 am

Post by maccadon » Sat Aug 09, 2014 3:54 pm

I was afraid there would be compatibility problems. But it should be no issue?

Active Member

Posts

Joined
Thu Aug 05, 2010 9:57 pm

Post by maccadon » Sat Aug 09, 2014 7:36 pm

I tried updating de jqeury by changing the header.tpl from

Code: Select all

        <script type="text/javascript" src="catalog/view/javascript/jquery/jquery-1.7.1.min.js"></script>
to

Code: Select all

    <script type="text/javascript" src="//ajax.googleapis.com/ajax/libs/jquery/1.11.1/jquery.min.js"></script>
but that messed up the checkout progress. (the steps didn't fold out).

Could the firefox error come from something different?

Active Member

Posts

Joined
Thu Aug 05, 2010 9:57 pm

Post by Tcalp » Sun Aug 10, 2014 1:22 am

From the little research I've done, the JS function in question looks to be related to auto-printing (or equally possibly a html to pdf conversion / pdf invoice). If you have such an extension installed, I would maybe look at disabling it and seeing it the problem goes away.

Increase Page Speed (#1 rated commercial extension on OpenCart Marketplace)
15in1 Essential Extensions Value Pack Premium Customer Testimonials Reward Points Extended Admin Security Lockdown Suite

Image
irc.freenode.net #opencart


User avatar
Active Member

Posts

Joined
Wed Jul 06, 2011 1:49 pm

Post by maccadon » Sun Aug 10, 2014 5:40 am

thanks for the reply and thinking this through. I use a module called PDF Invoice Pro and i disabled it but i still get the error when i change the quantity on firefox.

IE, Chrome and Safari don't have this problem

Active Member

Posts

Joined
Thu Aug 05, 2010 9:57 pm
Who is online

Users browsing this forum: No registered users and 41 guests