Page 1 of 1

SOLVED - Problem with update from 1.5.4.1 to 1.5.6.1

Posted: Sat Aug 02, 2014 12:09 am
by duben
I have an issue with updating OpenCart from 1.5.4.1 to 1.5.6.1, i walk through this forum and search in Google, but I cannot find any workable solution.

When I open <mydomain>/install it opens me upgdare screen -> click to Update ... and after about 1 minute I get "500 - Internal Server Error".

Eshop is working, .htaccess works fine, but when I tried update I get this error.

What's worst, I cannot find what is the issue. There is no error in log, no error on page (except 500 internal error), I turned on all possible error showing flags:

I tried:
php_flag error_reporting 6143
php_flag display_startup_errors on
php_flag display_errors on
php_flag html_errors on

setup error print on PHP.ini, in index.php nothing. Just this error without any clue.

new installation server works, all requirements are green.

Does anyone idea , what else I should try, or where can by problem?

Re: Problem with update from 1.5.4.1 to 1.5.6.1

Posted: Mon Aug 04, 2014 7:37 pm
by andrei.bogdan
Did you have any previously custom work done on your store?

Re: Problem with update from 1.5.4.1 to 1.5.6.1

Posted: Fri Aug 22, 2014 10:07 pm
by duben
Finally it was because of longer runing time script, cutom setting in php.ini wasn't working because of problematic old library on server. We had max limit 40s for script and update takes 80s. When we run it manually directly on server all was upgraded properly.