Post by lpotts » Fri May 30, 2014 10:07 pm

Hi all,

Just looking for a little assistance with our site. For some unknown reason our forgotten password link is not working. The initial link works, and takes to a page for the user to input their email address. But when sending that it takes them to a blank page.

Can anyone help with this issue?

Our site is www . designer - man . co . uk (without the spaces obviously)

Thank you all for your time,

Regards,

New member

Posts

Joined
Wed Jan 09, 2013 2:06 am

User avatar
Guru Member

Posts

Joined
Wed Nov 16, 2011 11:53 am
Location - Singapore

Post by lpotts » Fri Jun 06, 2014 9:01 pm

Thanks for the reply MarketInSG, were using version 1.5.5.1?

New member

Posts

Joined
Wed Jan 09, 2013 2:06 am

Post by MarketInSG » Fri Jun 06, 2014 9:29 pm

just realised you were talking about a blank page, not failing to reset the password. The blank page should be related to your site specifically. Have a look into your error logs. You might be able to find hints on the php errors, then post it here and we can assist you


User avatar
Guru Member

Posts

Joined
Wed Nov 16, 2011 11:53 am
Location - Singapore

Post by lpotts » Fri Jun 06, 2014 11:55 pm

Hi MarketInSG, I am going to PM you my error code, just I am unsure if there is any data in the error log that should not be shown publicly. If there isn't i'm more than happy to pop it all up on here afterwards to help others.
Thank you for your time,
Regards,

New member

Posts

Joined
Wed Jan 09, 2013 2:06 am

Post by lpotts » Sat Jun 07, 2014 12:02 am

For some reason I cannot seem to PM you.

Thank you for your time with this. My error log shows this when I get the blank page on forgotten password link:

2014-06-06 15:53:36 - PHP Notice: Error: Unknown column 'cg.name' in 'field list'<br />Error No: 1054<br />SELECT *, CONCAT(c.firstname, ' ', c.lastname) AS name, cg.name AS customer_group FROM oc_customer c LEFT JOIN oc_customer_group cg ON (c.customer_group_id = cg.customer_group_id) WHERE LCASE(c.email) = 'my-email-address-removed' ORDER BY name ASC in /home/designer/public_html/system/database/mysql.php on line 50

Have you any idea on how I can resolve this?

Regards,

Luke

New member

Posts

Joined
Wed Jan 09, 2013 2:06 am

Post by MarketInSG » Sat Jun 07, 2014 9:51 am

head over to your database and create the column 'name' varchar 255 into your customer_group table. That should solve the issue


User avatar
Guru Member

Posts

Joined
Wed Nov 16, 2011 11:53 am
Location - Singapore
Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 33 guests