Post by petersteele111 » Thu Apr 24, 2014 1:08 am

So my Site http://www.docsmagicshop.com had SEO URL's enabled. My htaccess was properly renamed and everything works great through all the browsers except one. Internet Explorer 11 for some reason one it hits the second level of the domain EX: docsmagicshop.com/magic/whatever it crashes with out loading any styles for the page. It will just stay white and then boom all this text and stuff just falls down the page completely unstyled. Why is it that when I enable SEO Friendly URL's this happens in Internet Explorer? This is the only browser that has this issue and I am stumped as to why it would be doing this. My htaccess file looks as follows :

Code: Select all

# Begin Redirect 301
RewriteEngine On
RewriteCond %{HTTP_HOST} !^docsmagicshop\.com [NC]
RewriteRule (.*) http://docsmagicshop.com/$1 [R=301,L]


# 1.To use URL Alias you need to be running apache with mod_rewrite enabled.

# 2. In your opencart directory rename htaccess.txt to .htaccess.

# For any support issues please visit: http://www.opencart.com

Options +FollowSymlinks

# Prevent Directoy listing
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "(?i)((\.tpl|\.ini|\.log|(?<!robots)\.txt))">
 Order deny,allow
 Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
RewriteRule ^download/(.*) /index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

### Additional Settings that may need to be enabled for some servers
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.

# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
# php_flag register_globals off

# 2. If your cart has magic quotes enabled, This may work to disable it:
# php_flag magic_quotes_gpc Off

# 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
# php_value upload_max_filesize 999M

# 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value post_max_size 999M

# 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_execution_time 200

# 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_input_time 200

# 7. disable open_basedir limitations
# php_admin_value open_basedir none
Only other thing that I have noticed is that the file product.tpl has a syntax error on line 421 but for the life of me i can't figure out where and what. It looks like this:

Code: Select all

<script type="text/javascript"><!--
new AjaxUpload('#button-option-<?php echo $option['product_option_id']; ?>', {
	action: 'index.php?route=product/product/upload',
	name: 'file',
	autoSubmit: true,
	responseType: 'json',
	onSubmit: function(file, extension) {
		$('#button-option-<?php echo $option['product_option_id']; ?>').after('<img src="catalog/view/theme/default/image/loading.gif" class="loading" style="padding-left: 5px;" />');
		$('#button-option-<?php echo $option['product_option_id']; ?>').attr('disabled', true);
	},
	onComplete: function(file, json) {
		$('#button-option-<?php echo $option['product_option_id']; ?>').attr('disabled', false);
		
		$('.error').remove();
		
		if (json['success']) {
			alert(json['success']);
			
			$('input[name=\'option[<?php echo $option['product_option_id']; ?>]\']').attr('value', json['file']);
		}
		
		if (json['error']) {
			$('#option-<?php echo $option['product_option_id']; ?>').after('<span class="error">' + json['error'] + '</span>');
		}
		
		$('.loading').remove();	
	}
});
//--></script>
If anyone has any insight as to why this might be breaking internet explorer let me know please. I know that I i remove the main category name such as magic from the url and have it just http://www.docsmagicshop.com/whatever it will load just fine in internet explorer. i'm running version 1.5.6.1 of opencart not multi-store.


Posts

Joined
Thu Apr 24, 2014 12:53 am

Post by nardus » Wed Apr 30, 2014 4:44 pm

PROBLEM SOLVED
------------------------
I had a wrong charset in one of the language-files
------------------------

I'm having the excact same problem. Running 1.5.5.1.

Any idea how to solve it?

New member

Posts

Joined
Wed Dec 05, 2012 2:54 am

Post by sanpaca » Sun Aug 31, 2014 4:20 pm

Hi Peter,

I have the same problem with subcategories OC 1.5.5.1- seo URL active - IE11- second language.
CSs doesn't work!
Can you solved? Can you explain?

Thank you so much

Newbie

Posts

Joined
Sun Aug 31, 2014 4:08 pm

Post by arthena1000 » Sun Oct 19, 2014 2:58 pm

Has a fix been sorted for this issue?

I have also been playing with Opencart as a replacement for Zencart but when I use SEO friendly pages on the second level causes the same problems No Style. All other browsers work fine just Internet Explorer.

Kind regards

Arthena1000

Newbie

Posts

Joined
Mon Sep 15, 2014 3:42 am

Post by arthena1000 » Sun Jan 25, 2015 4:53 am

I take it this issue has not been resolved due to the lack of response?

Newbie

Posts

Joined
Mon Sep 15, 2014 3:42 am

Post by soundzgood-nz » Sun Jan 25, 2015 3:52 pm

Which version of oc and what circumstances?
If you look through the above thread it's all over the road ...

My 1.5.6.4 on IE11 with this example url works fine using the default template / sample data:
http://www.mydomain.com/ocart/components/mice-trackball

Simon

User avatar
Active Member

Posts

Joined
Sat Oct 25, 2014 5:15 pm
Location - New Zealand

Post by arthena1000 » Mon Jan 26, 2015 1:28 pm

Hi Simon, Thanks for the reply.

I am running 1.5.6.4 and IE 11.

URL's work fine at product and Category level, but when I click on sub category I loose the template and everything is displayed without formatting. I have found if I remove the Friendly URL's from the Main Product Tittles then all works well.

Is this a common fault with an easy answer?

Kind regards

Arthena

Newbie

Posts

Joined
Mon Sep 15, 2014 3:42 am

Post by soundzgood-nz » Mon Jan 26, 2015 5:21 pm

No not a common fault to me as I don't get the fault using subcategories on a default install of oc v1564 on ie11.
So something specifc to your installation I'd say and in this case specific to subcategories (which actually means seo urls are working, but you've got an issue with certain level 2 categories.)

So do your subcategories have seo keywords? Do any contain unusual symbols (eg forward slashes, quote marks, % signs) that might cause an issue?

Simon

User avatar
Active Member

Posts

Joined
Sat Oct 25, 2014 5:15 pm
Location - New Zealand

Post by arthena1000 » Tue Jan 27, 2015 5:12 am

Hi thanks again for the reply.

I cannot see anything wrong that stands out. All SEO URLS are auto created and have only dashes between words. All works fine if I remove the SEO URLS from the main category's.

Am well perplexed with the error. I do know a bit about coding and page layouts / templates. I think it might be something to do with the .htacess file but not sure what. will have a play and see what I can figure out.

Kind regards

Arthena

Newbie

Posts

Joined
Mon Sep 15, 2014 3:42 am

Post by soundzgood-nz » Wed Jan 28, 2015 4:13 pm

Yes of course the htaccess file ... you need to shift the 301 domain redirect to lower down as below :

Code: Select all

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled.

# 2. In your opencart directory rename htaccess.txt to .htaccess.

# For any support issues please visit: http://www.opencart.com

Options +FollowSymlinks

# Prevent Directoy listing
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "(?i)((\.tpl|\.ini|\.log|(?<!robots)\.txt))">
 Order deny,allow
 Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/
# Begin Redirect 301
RewriteCond %{HTTP_HOST} !^docsmagicshop\.com [NC]
RewriteRule (.*) http://docsmagicshop.com/$1 [R=301,L]
RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
RewriteRule ^download/(.*) /index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

### Additional Settings that may need to be enabled for some servers
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.

# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
# php_flag register_globals off

# 2. If your cart has magic quotes enabled, This may work to disable it:
# php_flag magic_quotes_gpc Off

# 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
# php_value upload_max_filesize 999M

# 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value post_max_size 999M

# 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_execution_time 200

# 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_input_time 200

# 7. disable open_basedir limitations
# php_admin_value open_basedir none
Simon

User avatar
Active Member

Posts

Joined
Sat Oct 25, 2014 5:15 pm
Location - New Zealand
Who is online

Users browsing this forum: Bing [Bot] and 16 guests