Post by digifreaks » Fri Apr 04, 2014 1:50 pm

Hi,

So my opencart has been working fine for 4 months now. But recently it's having some kinda weird error.
When customers checkout items, they can only do it successfully through Guest Checkout.
Once they logged in as a Returning Customer, the server will return a Internal Server Error popup (not blank page) and doesn't allow the customer to continue with the checkout.
(Have SSL and SEO URL on, if that helps troubleshoot the problem.)

Did a search here and tried changing .htaccess and php.ini as suggested by several threads, but the issue still persists. Can anyone help? Would really appreciate it. Thanks! :)

Newbie

Posts

Joined
Thu Sep 05, 2013 3:06 pm

Post by James » Sat Apr 05, 2014 10:44 pm

You need to ask your host to look at the servers Apache error log (if you are on cPanel as most hosts don't set up the logging correctly to log to the account error log file). If you are on Plesk your error logs will show you the info though, through your admin area.

500 server is a generic "there is a problem" error, it could mean a lot of things but usually it is a code error, or something like a php.ini setting is invalid. Your host should be able to find the error in the log and help though.

If you have enabled/added a module or done some changes recently try removing them first.

Hope this helps.

User avatar
Active Member

Posts

Joined
Wed May 27, 2009 6:07 am
Location - Leeds, UK

Post by ptelang » Mon Apr 07, 2014 2:49 pm

Please check you config file
// HTTP
define('HTTP_SERVER', 'http://www.yourdomain.com/');

// HTTPS
define('HTTPS_SERVER', 'https://www.yourdomain.com/');


please check that in //https url has https (and not http)

TransPacific Software
OpenCart Developers
http://www.transpacific-software.com/opencart.php


New member

Posts

Joined
Wed Sep 12, 2012 7:35 pm
Who is online

Users browsing this forum: No registered users and 72 guests