Post by pgrowth » Wed Jan 29, 2014 2:39 pm

Hi everyone,

I'm all of the sudden getting this error message whenever I go to the url the Google Base extension gives when you install and enable the module.

Notice: getimagesize() [function.getimagesize]: Read error! in /home/ddd/public_html/catalog/model/tool/image.php on line 39Notice: getimagesize() [function.getimagesize]: Read error! in /home/ddd/public_html/vqmod/vqcache/vq2-system_library_image.php on line 11

I have no idea what is going on. My permissions on those folders are 755. Does anyone have any idea on what I can do to fix this so that I can get to my googe_base.xml file?

Newbie

Posts

Joined
Thu Jan 16, 2014 12:11 pm

Post by nvedia » Wed Jan 29, 2014 9:41 pm

If permissions are ok, make sure that images folder has data in it (those are the only two ways this error can appear)

Donate here to show support if you think I have helped you today!

Opencart Documentation


User avatar
Active Member

Posts

Joined
Sun May 22, 2011 12:54 pm

Post by pgrowth » Thu Jan 30, 2014 5:40 am

Hi nvedia, yes, I am just not sure. My image folder cache, category, data, etc... BUT the only image in that folder is named "no_image.jpg" and it is set to 644. Could that be causing it?

My cache folder has images in it as well. I am just at a lost.

Newbie

Posts

Joined
Thu Jan 16, 2014 12:11 pm

Post by pgrowth » Fri Jan 31, 2014 5:29 am

Hi, could anyone please help with this issue? I don't know where else to look to troubleshoot it.

Newbie

Posts

Joined
Thu Jan 16, 2014 12:11 pm

Post by randy4 » Wed Feb 12, 2014 2:28 am

Also getting this error but only on google feed. Which folders need to be set to to read and write permissions? Also is it 755 or 777

Newbie

Posts

Joined
Mon Jan 27, 2014 4:29 am

Post by randy4 » Tue Feb 25, 2014 5:45 pm

Bump anyone?

Newbie

Posts

Joined
Mon Jan 27, 2014 4:29 am

Post by pgrowth » Sat Mar 08, 2014 3:16 am

Hey Randy, I didn't really find a solution to this either. It went away after updating some images in our data feed. But it does look like it's because of a corrupt or "empty" image. If the error you're getting is EXACTLY like mine, you might try looking at the filesize of your images and see if any has "0" (zero) for filesize. Google Merch is trying to fetch that image and since it can't, it will throw that error.

You might also try deleting files in your cache folder(s).

Have a look here regarding permission settings - http://forum.opencart.com/viewtopic.php?f=20&t=104905

Newbie

Posts

Joined
Thu Jan 16, 2014 12:11 pm

Post by Tom-Burness » Fri Jun 19, 2015 7:59 pm

Hi,
Although this post is a bit old now, I came across the same issue and I wanted to share my fix. Quite simply there were a couple of corrupted images in the image/data directory. Remove those and it worked fine, hope this helps anyone else in the future :)

Newbie

Posts

Joined
Fri Jun 19, 2015 7:28 pm

Post by IP_CAM » Thu Oct 01, 2015 7:53 am

@Tom-Burness: THANKS A LOT, You probably saved me from getting NUTS on this ! :D
New virgin Opencart v.2.1 Install:
Notice: getimagesize() [function.getimagesize]: Read error! in /home/

After a brandnew Test INSTALL of the Opencart v.2.1.x Developper Edition, I expecienced exactly the same ERROR.
And this just, because I left a few WORKING IMAGES on the OC Image/Catalog/Demo Subdirectory, waiting
to be used later. !!! ??? :-\ :crazy:

After I removed them, the ERROR was GONE!
What the hell is this supposed to be ?!

Ernie
hitline.info/shop/

I'm no longer active at the OC Forum. To reach me, contact: jti@jacob.ch
A Demoversion of my free Opencart LIGHT v.1.5.6.5_rc Software
can be seen in Action here: http://www.bigmax.ch
---
930+ FREE OC Extension-Repositories - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
---
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by shannddy » Tue May 02, 2017 11:33 pm

@Tom-Burness you saved the day. Thanks loads

Newbie

Posts

Joined
Wed Jun 08, 2016 11:53 pm
Who is online

Users browsing this forum: No registered users and 86 guests