Post by damteq » Tue Nov 12, 2013 8:42 pm

Hello,

Our new site http://maser-online.co.uk/shop/ is having problems processing through the checkout from the first step.

It comes up with an error:

Here is the error log:

2013-11-12 12:30:19 - PHP Notice: Undefined index: email in /home/sites/maser-online.co.uk/public_html/shop/catalog/controller/checkout/guest.php on line 193
2013-11-12 12:30:19 - PHP Notice: Undefined index: email in /home/sites/maser-online.co.uk/public_html/shop/catalog/controller/checkout/guest.php on line 193
2013-11-12 12:30:19 - PHP Notice: Undefined index: telephone in /home/sites/maser-online.co.uk/public_html/shop/catalog/controller/checkout/guest.php on line 197
2013-11-12 12:36:59 - PHP Notice: Undefined index: email in /home/sites/maser-online.co.uk/public_html/shop/catalog/controller/checkout/register.php on line 142
2013-11-12 12:36:59 - PHP Notice: Undefined index: email in /home/sites/maser-online.co.uk/public_html/shop/catalog/controller/checkout/register.php on line 142
2013-11-12 12:36:59 - PHP Notice: Undefined index: email in /home/sites/maser-online.co.uk/public_html/shop/catalog/controller/checkout/register.php on line 146
2013-11-12 12:36:59 - PHP Notice: Undefined index: telephone in /home/sites/maser-online.co.uk/public_html/shop/catalog/controller/checkout/register.php on line 150

It is a standard install with no changes to the template, VQ Mod is installed

Newbie

Posts

Joined
Tue Nov 12, 2013 8:39 pm

Post by MarketInSG » Tue Nov 12, 2013 11:11 pm

did you modify your template? with vqmod or anything? It seems like those fields were removed or not sent into your controller for processing


User avatar
Guru Member

Posts

Joined
Wed Nov 16, 2011 11:53 am
Location - Singapore

Post by butte » Tue Nov 12, 2013 11:14 pm

Which version and theme? if theme, what compatibility? Those matter, the script by have tripped or the fileset may be incompatible.

You have 1.5.5.1 and default theme.

Nice logo. Amazing, there are now at least two of us who remember masers. Shucks, I see that masers aren't there; let alone for half a Crown.

Well, test ordering one and then 100 precipitated "Minimum order amount for BELDEN RG-8/U 50 OHM TRANSMISSION COAX PVC BLACK 305M is 305!" so up to 400 brought 21,200 kg and 2,272 Pounds, and then onward into . . . 5 Pounds for flat rate shipping of 21,200 kg all the way to southwestern North America. Ah, good, saved on shipping, worth the bargain to get 400 of them. Registration mandatory for Checkout. You'll need to remove Sir Winston's registration but as you'll see he had to give two addresses upon not being sure where 10 Downing falls out in the drop-down. Well, maybe not, it dinna like his telephone.

SyntaxError: JSON.parse: unexpected character

OK

<b>Notice</b>: Undefined index: email in <b>/home/sites/maser-online.co.uk/public_html/shop/catalog/controller/checkout/register.php</b> on line <b>142</b><b>Notice</b>: Undefined index: email in <b>/home/sites/maser-online.co.uk/public_html/shop/catalog/controller/checkout/register.php</b> on line <b>142</b><b>Notice</b>: Undefined index: email in <b>/home/sites/maser-online.co.uk/public_html/shop/catalog/controller/checkout/register.php</b> on line <b>146</b><b>Notice</b>: Undefined index: telephone in <b>/home/sites/maser-online.co.uk/public_html/shop/catalog/controller/checkout/register.php</b> on line <b>150</b>{"error":{"email":"E-Mail Address does not appear to be valid!","telephone":"Telephone must be between 3 and 32 characters!","password":"Password must be between 3 and 20 characters!"}}

So that is popping up rather than the asterisked red text saying fill it in right. Sir Winston is pleased, it forgot his stuff and let him erase his 400 items. Damn, fresh cigar and no fire.

Suggest looking at
http://forum.opencart.com/viewtopic.php ... 82#p444959
and practicalities (for both) at
http://forum.opencart.com/viewtopic.php ... 20#p445975
http://forum.opencart.com/viewtopic.php ... 40#p450692

If you do it, then first back up your fileset and database (both ways, OC admin Export and phpMyAdmin Export). You should first see backup_improved.xml (rph, http://forum.opencart.com/viewtopic.php ... 62#p401314, download at http://forum.opencart.com/download/file.php?id=16761).

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by damteq » Tue Nov 12, 2013 11:31 pm

Hello,

Thank you for your replies.

We are working with Maser, logo is nothing to do with us :) The weight is being sorted by the client! :)

We haven't edited the template other than CSS. Its the default template. Running OC 1.5.5.1 and VQMod 2.4.1. Just tried the checkout today and realised it doesn't work.

We've installed:

Ember Monkey Responsive
KA_Import as plugins.

Nothing else special.

Any help would be great.

Newbie

Posts

Joined
Tue Nov 12, 2013 8:39 pm

Post by butte » Tue Nov 12, 2013 11:53 pm

An "unexpected token" as you called it is not what appeared live, it fussed instead,
SyntaxError: JSON.parse: unexpected character
and whatever it tried to specify seems to have been a space or gone blank.

You could add a subdirectory /vqmod/xml/setaside/and slip the .xml into that in order to see whether singly or together they interfere somehow. You could refresh all default files for registration, just in case there was any file corruption in ftp.

Then read the last eight lines above.

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by damteq » Wed Nov 13, 2013 12:01 am

Hello Butte,

Thank you so much!

Moving the .xml from the VQ mod to the setaside works!

How can I do it now though to leave it there? will that stop any of the plugins working that were installed with VQ?

Newbie

Posts

Joined
Tue Nov 12, 2013 8:39 pm

Post by damteq » Wed Nov 13, 2013 12:05 am

By leaving it in /setaside it stops all the other vqmod plugins working.

Any ideas :)

Newbie

Posts

Joined
Tue Nov 12, 2013 8:39 pm

Post by butte » Wed Nov 13, 2013 12:06 am

When they are in setaside/ they won't fire. They must be in /vqmod/xml/ to fire. You can try them one at a time and then leave the culprit in setaside/ while you ask its author about the problem. An extension that blocks registration is not doing anything important enough to warrant using it.

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by damteq » Wed Nov 13, 2013 12:11 am

Hey

It works fine when the: vqmod_opencart.xml gets moved.

Newbie

Posts

Joined
Tue Nov 12, 2013 8:39 pm

Post by butte » Wed Nov 13, 2013 1:10 am

Good. That pinpointed the problem, one of whatever the extensions were. However, that particular one needs to be present for any vqmod .xml files to work. Put that one back. Then see if it still works.

It's not inconceivable that vqmod itself was not installed correctly, although you do seem to have the version FOR OC itself. IF it is not the most recent version, then reinstall vqmod itself (and give it fresh index.php files to rewrite).

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by MarketInSG » Wed Nov 13, 2013 11:50 am

damteq wrote:Hey

It works fine when the: vqmod_opencart.xml gets moved.
that is the default vqmod file for your vqmod to work. removing it stops your vqmod from working. I would recommend you to look into other vqmod scripts that are causing the issue


User avatar
Guru Member

Posts

Joined
Wed Nov 16, 2011 11:53 am
Location - Singapore

Post by butte » Wed Nov 13, 2013 11:04 pm

damteq, If you have

/vqmod/xml/vqmod_opencart.xml

then vqmod itself will work ("that particular one needs to be present for any vqmod .xml files to work. Put that one back." and his "that is the default vqmod file for your vqmod to work. removing it stops your vqmod from working").
If you have parked harmlessly out of the way

/vqmod/xml/setaside/whatevera.xml
/vqmod/xml/setaside/whateverb.xml
/vqmod/xml/setaside/whateverc.xml

then while vqmod itself works, those will be sidelined. One of those is causing the problem. You can slip those back into place one by one, as

/vqmod/xml/whatever_a.xml
/vqmod/xml/whatever_b.xml
/vqmod/xml/whatever_c.xml

until you pinpoint the problem file ("pinpointed the problem, one of whatever the extensions were" and his "other vqmod scripts that are causing").
When you find that one, set it aside, again, as

/vqmod/xml/setaside/theisolatedproblem.xml

and there may be more than one that causes the problem if they happen to interfere with OC or with each other or both. You could very well wind up with

/vqmod/xml/setaside/culprit_a.xml
/vqmod/xml/setaside/culprit_b.xml

and if so, then you will need to find one or more alternate extension(s).

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by jgates » Thu Nov 21, 2013 9:54 pm

Embermonkey responsive vqmod is responsible.
After enabling/disabling vqmod xml files, it came down to this one on two different sites - 1.5.6 and 1.5.4

It only seems to affect the checkout pages and instead of highlighting missing fields in red you get the popup JSON parse error instead.

Will submit to ember monkey and hopefully get a fix :)

Newbie

Posts

Joined
Thu Apr 01, 2010 8:14 am

Post by loroverde » Sun Feb 09, 2014 7:54 pm

Thank you for your messages.

I had almost the same problem and with your method I succeded in issolating the culprit.

Also embermonkey responsive theme was the problem, and as there are no changes since their previous version, I have had to unistall it.

At least my checkout is working again!

Many thanks for that!!

Newbie

Posts

Joined
Tue Sep 03, 2013 10:49 pm
Who is online

Users browsing this forum: Bing [Bot] and 66 guests