Post by guyazouri » Tue Nov 12, 2013 5:18 pm

Hi there

I use OpenCart 1.5.6

I have seen a post on this before, however none of the suggested solutions are working. I have spoken with my host support in eukhost and they have tried to increase all limits but nothing works, they still think it is related to the code

This happens to a clean installation of my opencart, with an additional theme I have purchased. The theme use few extensions to run.

Whenever I try to save a product with over 1oo~ product options the system returns this error;

Notice: Undefined index: points in /public_html/admin/model/catalog/product.php on line 128Notice: Undefined index: points in /public_html/admin/model/catalog/product.php on line 176Notice: Undefined index: weight in /public_html/admin/model/catalog/product.php on line 176Notice: Undefined index: weight_prefix in /public_html/admin/model/catalog/product.php on line 176Warning: Cannot modify header information - headers already sent by (output started at /public_html/admin/index.php:85) in /public_html/vqmod/vqcache/vq2-system_engine_controller.php on line 28Warning: Cannot modify header information - headers already sent by (output started at /public_html/admin/index.php:85) in /public_html/vqmod/vqcache/vq2-system_engine_controller.php on line 29

So it's not related to increasing the memory options in php.ini - I have tried that already and it didnt help.

Any ideas?

Thanks in advance!
Last edited by guyazouri on Tue Nov 19, 2013 7:39 pm, edited 1 time in total.

Newbie

Posts

Joined
Tue Nov 12, 2013 5:12 pm

Post by butte » Wed Nov 13, 2013 12:32 am

Correct, it is not fussing about php settings. It is fussing about points and weight, apparently two among your 100 options, and those evidently relate to the options extension(s),so you can try asking the author(s). Then it already sang its song (the headers), but that is in cache memory, you can perhaps drop that by flushing /vqmod/ at both mods.cache and vqcache/*.* files.

Ya know, 100 options would probably exhaust my patience if I were a prospective customer. I would rather walk into a store and pick one. Have you considered customer burnout?

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by guyazouri » Mon Nov 18, 2013 4:35 pm

Hi butte,

Thanks for your reply. The customer will need the options as the product is a personalised jewellery with ability to add your initials, so yes they would need the 106 options (which are 4 times 26 of listing all the alphabet 4 times)

It does seem as a server issue rather than opencart. from what I understand (correct me if I am wrong) opencart will send into POST all the information available on a product when you save it, so it tries to save all at once and there is too much information for the header.

I tried to correct every php limit setting but nothing, it just won't save as many.

A clean install on a shared server worked perfectly, I managed to add more options. It must be a setting required by OpenCart, which I don't know what it is.

The server people in EUKHOST are trying to help me as well, senior admins is working on this for the last two days without lack... I think I would end up developing a module just for the options!

Newbie

Posts

Joined
Tue Nov 12, 2013 5:12 pm

Post by guyazouri » Mon Nov 18, 2013 11:03 pm

SOLVED! I am glad to say that the Admin team of EUKHOST (George S) found a solution to my problem - the max_input_vars was set to 1000 so he increased it to 25000 which solved the issue!

So anyone is running with such problem make sure to set the correct settings in php.ini as it is nothing to do with Open Cart 1.5.6

Good luck!
Last edited by guyazouri on Tue Nov 19, 2013 7:38 pm, edited 1 time in total.

Newbie

Posts

Joined
Tue Nov 12, 2013 5:12 pm

Post by butte » Tue Nov 19, 2013 12:21 am

Congratulations, go ahead and edit your opening title Solved, for others benefit. You were fortunate to see your ticket escalated to system administrators.

Elevating that value for that sake is well to see tried and succeed, many hosts do not allow the particular change. And the change is to no avail in php.ini on servers that routinely do ignore the files.

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by guyazouri » Tue Nov 19, 2013 7:40 pm

Well it's a dedicated server so I am able to do as I pleased, the support of EUKHOST is one of the best out there I must say!

Newbie

Posts

Joined
Tue Nov 12, 2013 5:12 pm

Post by Mescolito » Sun Jul 27, 2014 3:47 am

Guyazouri, can you (or anyone for that matter) expand on what you mean by "A clean install on a shared server worked perfectly,"

My question is, a clean install of what? OpenCart? VQMod? Theme?

Sorry if my question seems amateur or dumb, but I'm not a programmer, and I'm a bit slow when it comes to resolving issues. My issue is caused by adding many options for a particular product. I wish I didn't need so many options, but it is a very specialized item that requires customization. I did try adding the line max_input_vars = 30000 in the php.ini thing, but that didn't work. I chose that number simply because I saw that someone else used it in a different forum thread, should I increase it to 50k?

I suppose the easiest way to get around this would be to list all options in the description, and require an email from the customer to list everything they want, but 1. If I was ordering this, I would not want the hassle of sending an email and hoping they get right, and 2. This is not a fix to this issue, the option is there for a reason, seems to me it should work whether it is 2 or 200 options.

Thanks in advance for any help you can provide!

TC

Newbie

Posts

Joined
Thu Jun 27, 2013 9:40 am

rph
Expert Member

Posts

Joined
Fri Jan 08, 2010 5:05 am
Location - Lincoln, Nebraska

Post by paynechia » Thu Oct 02, 2014 10:17 am

Hi All,

I have requested my host provider to change the values for me. The problem still exists. I noticed that the Local value is greater than the values in Master in the phpinfo();

magic_quotes_gpc
Local: Off ; Master: On

max_execution_time
Local: 300 ; Master: 30

max_input_vars
Local: 2000 ; Master: 1000

Do we need to set same value for both Local and Master for items above?

Highly appreciate for your advise.

Newbie

Posts

Joined
Mon Mar 24, 2014 2:49 pm
Who is online

Users browsing this forum: No registered users and 59 guests