Post by adamgatt » Mon Nov 11, 2013 5:55 am

Hi guys,

I have a problem wherein the captcha image in the review area for a product isn't being found with SEO URLs turned on if you navigate to a product via a category. For instance http://www.rvsparesonline.com.au/sizzle ... -steel-bbq shows the captcha fine, however http://www.rvsparesonline.com.au/applia ... -steel-bbq doesn't because it is looking for the image in http://www.rvsparesonline.com.au/appliances/cooking/index.php?route=product/product/captcha

Any idea what file I can edit to make it always look for the image at the root?

Thanks.

Newbie

Posts

Joined
Fri May 25, 2012 7:55 am

Post by butte » Mon Nov 11, 2013 7:42 am

The Captcha image can be replicated into places where the thing is looking for it, but you shouldn't need to second-guess everywhere it imagines that might be. You might try defining CAPTCHA in parallel with how you already define IMAGE, in the config.php files, BUT Captcha has not conspicuously proliferated instances of what you're encountering, with or without the SEO checkmark. You might try hard coding the image location in the review file(s) calling it to fire, or do so in the Captcha fileset itself, so that an absolute path (given either the http address or a basedir floor) governs where the image is supposed to be found. How particular Captcha packages work varies.

Another way out would be to use Captcha without the image (it would display text rather than the image).

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by MarketInSG » Mon Nov 11, 2013 11:59 pm

adamgatt wrote:Hi guys,

I have a problem wherein the captcha image in the review area for a product isn't being found with SEO URLs turned on if you navigate to a product via a category. For instance http://www.rvsparesonline.com.au/sizzle ... -steel-bbq shows the captcha fine, however http://www.rvsparesonline.com.au/applia ... -steel-bbq doesn't because it is looking for the image in http://www.rvsparesonline.com.au/appliances/cooking/index.php?route=product/product/captcha

Any idea what file I can edit to make it always look for the image at the root?

Thanks.
I would say the issue might be in your custom theme. The <base href tag might be removed


User avatar
Guru Member

Posts

Joined
Wed Nov 16, 2011 11:53 am
Location - Singapore

Post by adamgatt » Fri Nov 15, 2013 9:55 am

Thanks a lot for the help guys.

MarketInSG was correct!!! I added the base href tag to the header.tpl and it has solved the issue!

Much appreciated.

Newbie

Posts

Joined
Fri May 25, 2012 7:55 am

User avatar
Guru Member

Posts

Joined
Wed Nov 16, 2011 11:53 am
Location - Singapore

Post by wafflemeister » Sun Apr 29, 2018 10:28 pm

I would greatly appreciate it if you could elaborate on how to fix this specific issue. I have opencart 1.5.6.4 and am having the same issue. Thank you.

New member

Posts

Joined
Fri Jun 21, 2013 11:10 pm

Post by IP_CAM » Mon Apr 30, 2018 1:45 am

Ever tried one of the free Extensions ?
Ernie
https://www.opencart.com/index.php?rout ... _license=0

Please don't send me OC Forum Personal Messages, just contact: jti@jacob.ch
---
OC 1.5.6.5 LIGHT Test Site: http://www.bigmax.ch/shop/
OC 1.5.6.5 V-PRO Test Site: http://www.openshop.li/shop/
My Github OC Site: https://github.com/IP-CAM
2'600+ FREE OC Extensions on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by wafflemeister » Mon Apr 30, 2018 3:50 am

I have an extension that can disable review captchas but I have a couple other extensions that are dependent on the product review captcha, which is why I can't just disable it. I need to actually fix the problem.

New member

Posts

Joined
Fri Jun 21, 2013 11:10 pm

Post by IP_CAM » Mon Apr 30, 2018 6:04 am

Well, I have no idea, what could be dependent on the review captcha, exept for it's 'location', to
serve as 'anchor' for other VqMod's. But you probably better get some Dev-assistance, since someone
needs to have a look into your Setup, to be able to really find out, what you have, and what you need.
Good Luck!
Ernie

Please don't send me OC Forum Personal Messages, just contact: jti@jacob.ch
---
OC 1.5.6.5 LIGHT Test Site: http://www.bigmax.ch/shop/
OC 1.5.6.5 V-PRO Test Site: http://www.openshop.li/shop/
My Github OC Site: https://github.com/IP-CAM
2'600+ FREE OC Extensions on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland
Who is online

Users browsing this forum: No registered users and 62 guests