Post by russb123 » Sun Oct 06, 2013 7:37 am

I am getting errors when I place a product in my shopping cart. I am using the default opencart(1.5.6) theme, opentshirt(1.2.3), and only vqmod(2.4.1) installed so far. I looked at the code and all instances point to if ($product['recurring']).

These appear when I view my shopping cart

Notice: Undefined index: recurring in /home/****/public_html/catalog/controller/checkout/cart.php on line 248
Notice: Undefined index: recurring in /home/****/public_html/catalog/controller/checkout/cart.php on line 284
Notice: Undefined index: profile_name in /home/****/public_html/catalog/controller/checkout/cart.php on line 285
Notice: Undefined index: recurring in /home/****/public_html/catalog/controller/module/cart.php on line 113
Notice: Undefined index: profile_name in /home/****/public_html/catalog/controller/module/cart.php on line 114

During checkout at the Payment Method section i get this error:
/home/****/public_html/vqmod/vqcache/vq2-system_library_cart.php on line 589

Any help would be appreciate, Thanks.

Newbie

Posts

Joined
Sun Oct 06, 2013 7:35 am

Post by Avvici » Tue Oct 08, 2013 2:09 am

Those aren't errors that will necessarily affect the store performance, just annoyances. However they should be taken care of. Whenever you have an undefined index you need to make an if(isset( check to send it away if returns false.

User avatar
Expert Member

Posts

Joined
Tue Apr 05, 2011 12:09 pm
Location - Asheville, NC

Post by colinkho » Thu Oct 10, 2013 4:52 pm

I have this problem too. What was the appropriate fix for this ? Thank you!

Newbie

Posts

Joined
Thu Oct 10, 2013 4:50 pm

Post by paulbothma » Tue Feb 18, 2014 4:10 pm

hi - i have the exact same errors and neither opencart or opentshirts can really sort it out.

i see no posts that helped to resolve it -- how did you guys sort it out??

i can for the life of me not figure it out.

strangely enough, i have 2 print methods, when you go via "transfer" -- no problems, when you choose "screenprint" method, then on the checkout process i get those exact same errors.

Newbie

Posts

Joined
Mon Nov 18, 2013 10:20 pm

Post by cprints » Mon Oct 27, 2014 11:37 am

Having same problem with silk screen items in cart. I think it has something to do with pricing.

Newbie

Posts

Joined
Sun Oct 26, 2014 9:26 pm

Post by rumitej » Sat Nov 08, 2014 4:48 pm

Are there any results on how to fix this?

Newbie

Posts

Joined
Sat Nov 08, 2014 4:47 pm
Who is online

Users browsing this forum: Google [Bot] and 49 guests