Post by BellaBella » Tue Oct 01, 2013 2:29 pm

I've tried, I really have, but as of late my site has been down more than it's been up. Due to DDOS attacks and now some crazy random issue whilst in the middle I my work...sigh, I'm glad we haven't officially launched our business yet as I'm mentally calculating lost profits had we been open. But all these issues are weakening my faith in Arvixe as being reliable. It took 3 days to get the DDOS thing under control, which I can sort of understand, but now my site is dead altogether. I get this error:

Warning: mysql_connect() [function.mysql-connect]: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) in /home/kbella77/public_html/system/database/mysql.php on line 6

Notice: Error: Could not make a database link using kbella77_ocar954@localhost in /home/kbella77/public_html/system/database/mysql.php on line 7

Warning: mysql_select_db() expects parameter 2 to be resource, boolean given in /home/kbella77/public_html/system/database/mysql.php on line 10

Notice: Error: Could not connect to database kbella77_ocar954 in /home/kbella77/public_html/system/database/mysql.php on line 11

Warning: mysql_query() expects parameter 2 to be resource, boolean given in /home/kbella77/public_html/system/database/mysql.php on line 14

Warning: mysql_query() expects parameter 2 to be resource, boolean given in /home/kbella77/public_html/system/database/mysql.php on line 15

Warning: mysql_query() expects parameter 2 to be resource, boolean given in /home/kbella77/public_html/system/database/mysql.php on line 16

Warning: mysql_query() expects parameter 2 to be resource, boolean given in /home/kbella77/public_html/system/database/mysql.php on line 17

Notice: Trying to get property of non-object in /home/kbella77/public_html/index.php on line 56

Notice: Trying to get property of non-object in /home/kbella77/public_html/index.php on line 65

Warning: Invalid argument supplied for foreach() in /home/kbella77/public_html/index.php on line 65

Notice: Trying to get property of non-object in /home/kbella77/public_html/index.php on line 73

Problem is this issue began around 8:30ish. I chatted online with an Arvixe rep for a total of 45+ minutes after which he told me he sent the issue to the server team and they'd have me back up within 30-45 minutes. Well it's about 4+ hours later and my site is still gone to bits. I'm going to bed now, but if this isn't fixed come morning, I'm considering moving on. I have a lot of work to do before we launch and this has really been holding me up.

Anyway, could some of you experienced webbies offer any suggestions? I liked Arvixe a lot up until this past week. Now I'm just annoyed.

Thanks!

Change Star Ratings to Hearts


User avatar
Newbie

Posts

Joined
Fri Mar 22, 2013 9:11 am
Location - Racine, WI

Post by QA-Arvixe » Tue Oct 01, 2013 10:46 pm

Hello,

I'm sorry for the issue you are encountering, it's certainly not our intention.

I can see your shopping cart it working correctly now, but wanted to give you my email address should you encounter any further issues. -- adam@arvixe.com

I'd be happy to do whatever we need to in order to get this resolved. Any issues moving forward, feel free to reach out to me directly. Thank you for your patience!

Newbie

Posts

Joined
Mon May 20, 2013 11:23 pm

Post by butte » Wed Oct 02, 2013 12:58 am

BellaBella, that host has a banner topside for good reason, it has experience with OC. You seem to have generated problems that are unusual enough that they're taking time to look at it, partly in relation to attack. You have, for example, "expects parameter 2 to be resource, boolean given," and "Invalid argument supplied for foreach()," and "Trying to get property of non-object," which seem not to derive (certainly not entirely) from the server itself. Your database seems to be screwy unless your files are corrupted in uploading them -- or by hacking. You did not tell us your version of OC, or whether you have an upgrade, from what, to what, or a clean install, of what.

One to three full days for a server network to recover (or be recovered) from a significant attack is scarcely unusual. ALL hosts are vulnerable to occasional attack of unusual magnitude. They'll be looking at your OC, your account, other accounts, and the server network itself, and they will not be likely to say anything that might divulge whatever vulnerabilities were secured. At least you'll now be security conscious from the outset.

Just for example, if any account holder has a certain blog running with a certain file, whereami.cgi, then there was an entryway that any even budding hacker could find and exploit, and with malice that can lead to one or another sort of brute force attack. A brute force attack looking for those or doing other mischief would tend to interrupt a server network.

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by BellaBella » Sat Oct 12, 2013 12:48 am

Thank you for the replies. Everything is working fine now. My site was down for like 3 days. I understand they are a wonderful company, the customer service is excellent. I've had no problems getting assistance when I've reached out. As a precaution, I've created a blog offsite where customers or potential customers can go to be updated of any server issues if they are unable to process their orders or login to my site. This is a new experience for me and it made me very afraid for the future sales on my site. I hope that creating a blog that would offer at least some explanation for my potential customers would help to save potential sales as well. But I appreciate all of the hard work these guys have been doing and appreciate Adam replying to me. I'm sticking around. I'm staying. Gonna give it another chance. Arvixe is really a great host and has been kind to me! Thanks again!

Change Star Ratings to Hearts


User avatar
Newbie

Posts

Joined
Fri Mar 22, 2013 9:11 am
Location - Racine, WI
Who is online

Users browsing this forum: No registered users and 42 guests