Post by shepscrook » Thu Sep 26, 2013 12:02 am

So I'm enabling SSL for www.vernonscope.com and I've run into some snags. I'm hosted by hostgator and they have applied SSL to this domain, including vernonscope.com.

I get the green padlock for SSL in the Admin section.

I don't get SSL at all for Checkout

if I manually go to https: I get a broken padlock saying I have insecure content.

When I checked with whynopadlock.com, it's saying that I have an image called sky.jpg that is insecure. I've removed the image out of the file system as it's just a header image that has been replaced. I've also gone into the SQL to replace the call for sky.jpg with the new image skyshot2.jpg. But whynopadlock.com still sees sky.jpg as the issue. (I'm still picking through pages of code to find sky.jpg called for anywhere else.

I have SSL enabled in the System page for Opencart. I have modified the config.php files in both the site directory, and the admin directory to call to https.

What am I missing?

Newbie

Posts

Joined
Wed Aug 07, 2013 11:38 pm

Post by grgr » Thu Sep 26, 2013 1:38 am

Because it's in your stylesheet:

#header-wrapper {
background-image:url(http://vernonscope.com/image/data/Company/sky.jpg);
background-repeat:no-repeat;
background-position:left top;
}

Image Image Image Image Image Image Image Image


User avatar
Active Member

Posts

Joined
Mon Mar 28, 2011 4:08 pm
Location - UK

Post by shepscrook » Thu Sep 26, 2013 2:48 am

I checked the stylesheet but don't see it.

Do you know what file that could be in?

Also, I think I have another problem. We had the site originally set up on vernonscope.us but once we got the vernonscope.com domain name under our control, we transfered the database and site to vernonscope.com. However, now all of the site's theme controls point to vernonscope.us. It's a big mess.

Newbie

Posts

Joined
Wed Aug 07, 2013 11:38 pm
Who is online

Users browsing this forum: No registered users and 35 guests