Post by imverypoor » Tue Jul 30, 2013 9:25 pm

hi all,
is anyone having issues with the latest opencart 1.5.6 at the install stage when you put your domain name/install?
i'm hosting with 123 reg and they said the problem is within the opencart as they have checked everything and all seems fine.
after clicking the 'continue' button, i get this message below:

Notice: Error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AFTER `price`' at line 1
Error No: 1064
ALTER TABLE `oc_profile` CHANGE `frequency` `frequency` ENUM AFTER `price` in /websites/123reg/LinuxPackage23/ ..........................

do i have to start all over again?

Newbie

Posts

Joined
Wed Jul 17, 2013 3:54 pm

Post by imverypoor » Tue Jul 30, 2013 9:35 pm

i dont know what to do anymore. any help would be appreciated

Newbie

Posts

Joined
Wed Jul 17, 2013 3:54 pm

Post by pedro1993 » Tue Jul 30, 2013 9:47 pm

This could be a possible bug.

I would post it here.

For now, I would also suggest using a more stable release. 1.5.5.1 is a very good release and will be a lot less buggy.

Peter

For professional OpenCart, HTML/CSS & PHP/MySQL support feel free to PM me :)
Click here for my extentions
Did I help you? Donate here to show support
Follow me on Twitter!
Catch me on Facebook!
Watch YouTube OpenCart Tutorials and Extension Demos

Image


User avatar
Active Member

Posts

Joined
Tue Oct 18, 2011 4:31 am
Location - Glasgow, Scotland

Post by imverypoor » Tue Jul 30, 2013 11:14 pm

hi Pedro
thanks for the reply, i also thought the same at 1st but because i havent seen many people reporting this issue (only 1 so far) i then thought it had to do with something i did. i looked at the config so many times i got a headache.
do i have to start all over again or just get rid of the 1.5.6 file and upload the 1.5.5.1?
sorry mods for posting my topic in the wrong place. please move it if needed.
thx again pedro

Newbie

Posts

Joined
Wed Jul 17, 2013 3:54 pm

Post by pedro1993 » Tue Jul 30, 2013 11:37 pm

No problem :) The forum is here for help, the other post will be better for you cause then other people might see the same problem.
Yeah, simply upload 1.5.5.1 on to your server. It can be found here. :)

For professional OpenCart, HTML/CSS & PHP/MySQL support feel free to PM me :)
Click here for my extentions
Did I help you? Donate here to show support
Follow me on Twitter!
Catch me on Facebook!
Watch YouTube OpenCart Tutorials and Extension Demos

Image


User avatar
Active Member

Posts

Joined
Tue Oct 18, 2011 4:31 am
Location - Glasgow, Scotland

Post by rph » Wed Jul 31, 2013 12:21 am

Looks like another lovely problem from the OpenBay integration.

-Ryan


rph
Expert Member

Posts

Joined
Fri Jan 08, 2010 5:05 am
Location - Lincoln, Nebraska

Post by butte » Thu Sep 05, 2013 6:21 am

One thread offers a practical solution:
http://forum.opencart.com/viewtopic.php?f=19&t=106677

to this problem:
Notice: Error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AFTER `price`' at line 1
Error No: 1064
ALTER TABLE `oc_profile` CHANGE `frequency` `frequency` ENUM AFTER `price` in

Plural threads and isolated posts accordingly bear cross-linkage, at least for the sake of noting its prevalence:
http://forum.opencart.com/viewtopic.php ... 21#p424887 (with a user's editorial comment below it)
http://forum.opencart.com/viewtopic.php?f=20&t=106706 (with perspectives)
http://forum.opencart.com/viewtopic.php?f=20&t=106973

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am
Who is online

Users browsing this forum: No registered users and 35 guests