Page 1 of 1

can't get to checkout from cart - intermittently!!

Posted: Fri Jul 26, 2013 11:49 pm
by jackie
Hello and hope someone can help with this -

We just launched our store after much, much testing - and have discovered this error.

A totally intermittent and inconsistent error: from the cart, pressing CHECKOUT just redisplays the cart. Doesn't go to checkout. Sometimes. I've tried on 2 computers, 2 browsers, only happens some of the time. The link is to the checkout is - and it usually works.
I just manually typed for the checkout into the browser and it does go there! But going back to the cart page and pressing CHECKOUT, it doesn't move on, just redisplays the cart. Pressing CHECKOUT from the menu doesn't work either.

I found someone had this on the forum and mentioned checking permissions of the javascript - it looks ok (755 for folder, 644 for files altho I changed a couple files to 755 to make sure its exec.) -

We are using SSL, I'm noticing some of the pages come up with the https and some don't - I don't know if it is a case of that. The products are getting into the cart fine. I can't tell a difference between being logged in or not with it, and I'm not getting any errors in the system log.

I don't know where else to look for errors on this...
ALSO - I just manually put in the url for the checkout and it does go there!

I had my host support person check it, and CHECKOUT came up fine for them.

(I don't think this has anything to do with it, especially since 95% of the time on various computers this works fine, but we 'went live' by pointing our nameservers to an install of OC in a subdirectory. All the config, etc., works fine. Don't know if a rewrite issue would cause intermittent issue like this or not. I feel like even mentioning this I could be leading someone down the wrong track, but just want to explain all.)

THANK YOU for any help and insight,


Re: can't get to checkout from cart - intermittently!!

Posted: Wed Jul 31, 2013 11:32 pm
by jackie
Update on this - after days of testing all configs and conditions, my hosting server solved this by renaming both the php.ini files to .txt so they wouldn't be used..... apparently php.ini doesn't work on their servers.
Seems to be solved - I don't know the specifics of exactly why.