Post by SelfMan » Fri Jun 21, 2013 7:54 am

I have an issue where when an order is edited and totals updated, that a value previously added by "Multi Payment Fee" module to order_totals table gets deleted.

WaaBay (the module developer) said its by design for the store front and has at the moment no intention to make it work with the backend what I need, because if this is not working I can't use the order editing feature at all.

I am not sure to consider this to be a bug or not. The module works on the front end without problems.

EDIT:
I am not sure, but it looks like the problem must be somewhere in admin\view\template\sale\order_form.tpl

New member

Posts

Joined
Thu Dec 01, 2011 8:01 am

Post by ADD Creative » Tue Jul 09, 2013 5:09 pm

As a test do the Low Order Fee or Handling Fee modules work correctly? If so it likely to be a limitation of the module you are using.

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by SelfMan » Fri Jul 12, 2013 6:04 am

The low order fee seems to be working. So you are probably right. Now its only the question how to fix this, coz the author has so far no intention to do it. Anyway, thanks for the response.

New member

Posts

Joined
Thu Dec 01, 2011 8:01 am

Post by SelfMan » Fri Jul 12, 2013 10:57 am

I found out the cause...
The multi_payment_fee module expects data located in $this->session->data, but in case of catalog\controller\checkout\manual.php this information is not available like in normal conditions.
So I have to improvize somehow, because MPFrequires the information which payment method is used to calculate the fee. (i.e. paypal or COD)

New member

Posts

Joined
Thu Dec 01, 2011 8:01 am
Who is online

Users browsing this forum: No registered users and 27 guests