Post by IT_MAN » Fri May 31, 2013 9:17 am

Hi. I have this weird problem in my cart. When a customer orders and uses 2checkout payment, It successfully does the process, but after the successful payment, the page is redirected to the callback page but the page looks a mess, like css is not applied, etc. Can someone help?

New member

Posts

Joined
Tue Apr 23, 2013 11:18 am

Post by butte » Sun Jun 02, 2013 11:07 pm

Double-check exactly where it thinks it is supposed to land when it returns. You may need to specify path/index.php itself in the payment .php for that portal. Hard to tell unseen. What is the URL?

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by IT_MAN » Wed Jun 05, 2013 8:46 am

Here's my store www.philcakes.com please do help me. I don't know what causes it. Thanks again.

New member

Posts

Joined
Tue Apr 23, 2013 11:18 am

Post by butte » Wed Jun 05, 2013 9:58 am

It gets worse. I cannot add Sunflower Chocolate Florentine or Double Dutch Cake to the Cart. For any chocolativore, that is more than just a wee bit of a total disaster. You're using Version 1.5.4, so that should be pretty stable. Perhaps your, "Welcome visitor you can login or create an account," means that without first doing that I cannot even choose goodies. As-is, it won't let me go as far as the payment portal to see where Cancel or Resume Shopping lands me.

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by IT_MAN » Wed Jun 05, 2013 2:29 pm

What do you mean? The store is working fine as far as I have tested. I just want to know why it is being redirected to a page that has no css applied after 2checkout payment.

New member

Posts

Joined
Tue Apr 23, 2013 11:18 am

Post by butte » Wed Jun 05, 2013 11:21 pm

I mean that I cannot see where it lands upon return, because I cannot even get to the payment portal, because without first registering I cannot even put anything into the cart in the first place. The chocolate part is in jest.

How is landing back in your domain with inexplicably no css support "working fine"?

Probably either (1) something in your 2checkout payment account is mis-set or incompletely set, or instead (2) there's a subtlety to the syntax that 2checkout's server is expecting and that you can find in detailed instructions via your 2checkout payment account.

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by IT_MAN » Thu Jun 06, 2013 10:12 am

Maybe it's in the 2co payment code. I just changed the code a bit. I'll try sooner if it works fine. Thanks.

New member

Posts

Joined
Tue Apr 23, 2013 11:18 am
Who is online

Users browsing this forum: No registered users and 35 guests