Post by WilliamBD » Wed May 15, 2013 7:58 pm

Installation went smoothly I added my new site under settings 'www.example.com\', no issues but when I go on to the new domain site it is blank. I set the theme to store settings to 'Default' for everything that mentioned layout's.

On my main site it is working fine but any new site it has the core links (home/account/basket etc...) but it is nothing like the default site I have.

Do I need to add these layouts manually again for my new second site that I set to all default?

*Disclaimer: I hope I have been as clear as possible and helpful. If you are unsure of anything please ask I will be happy to help - I do frequently watch the posts I have posted in previously.

How to change prices across a whole multi-store, with a baseline price for each product:
http://forum.opencart.com/viewtopic.php ... 24#p406793


Active Member

Posts

Joined
Fri Feb 08, 2013 9:33 pm

Post by labeshops » Wed May 15, 2013 8:33 pm

First off, do you want both stores to look identical? If not, you need to add layouts for the second store (I have home, category, and product layouts set up for each of my multistores so I can customize which modules show where on each store). If you do want them to be identical, then yes, you need to add the new store to each of the layouts you have already.

Modules are assigned to layouts and layouts are assigned to stores if that helps :)

I'm also assuming here by "blank" you mean blank except for the header and footer. If not, there is another issue.

Running Opencart v2.2 with multi-stores from https://www.labeshops.com which has links to all my stores.

Image


User avatar
Expert Member

Posts

Joined
Thu Aug 04, 2011 4:41 am
Location - Florida, USA

Post by WilliamBD » Wed May 15, 2013 8:44 pm

Thanks for your reply,

I do want them to look the same just have different products and categories. But I would of thought setting everything to 'default' like the default store would of meant I had achieved this. Seems a bit overkill having to create a whole new store from scratch to get exactly the same look.

Unless by having no products or images for my second store means those areas are not displaying.

*Disclaimer: I hope I have been as clear as possible and helpful. If you are unsure of anything please ask I will be happy to help - I do frequently watch the posts I have posted in previously.

How to change prices across a whole multi-store, with a baseline price for each product:
http://forum.opencart.com/viewtopic.php ... 24#p406793


Active Member

Posts

Joined
Fri Feb 08, 2013 9:33 pm

Post by WilliamBD » Wed May 15, 2013 8:50 pm

labeshops wrote:Modules are assigned to layouts and layouts are assigned to stores if that helps :)
That does help thanks. But thats the weird thing all the Modules and layouts are working.

I shall pm you the link to see

EDIT: The one thing that has me muffled is I can not see where to allocate the default 'Banner' module images for different sites.

*Disclaimer: I hope I have been as clear as possible and helpful. If you are unsure of anything please ask I will be happy to help - I do frequently watch the posts I have posted in previously.

How to change prices across a whole multi-store, with a baseline price for each product:
http://forum.opencart.com/viewtopic.php ... 24#p406793


Active Member

Posts

Joined
Fri Feb 08, 2013 9:33 pm

Post by redoctober83 » Sun May 26, 2013 7:59 am

I am running into the same issues as you are. I only have 2 stores. One is a retail site, the other is our wholesale site. I want to have different modules on the wholesale site as well as different messages. I am not having any luck and could use some advice.

What I want on our wholesale site is a message to show up when they log into there account where I could list specials or put information that I only want those who have approved accounts for the wholesale site to see.

Newbie

Posts

Joined
Tue Mar 26, 2013 3:15 am
Location - Houston, TX USA

Post by labeshops » Sun May 26, 2013 8:13 am

As I said above, you need to create different layouts for each store. Then assign the modules (including banners) to the layout only for the store you want it to appear on.

Running Opencart v2.2 with multi-stores from https://www.labeshops.com which has links to all my stores.

Image


User avatar
Expert Member

Posts

Joined
Thu Aug 04, 2011 4:41 am
Location - Florida, USA

Post by redoctober83 » Sun May 26, 2013 8:17 am

labeshops wrote:As I said above, you need to create different layouts for each store. Then assign the modules (including banners) to the layout only for the store you want it to appear on.
Thank you for the reply!

Being somewhat new to this, how do I create a new layout and assign it to the correct store? I have been searching the forums for this answer as well. If you know of any topics that have this answer, please let me know.

Thanks!

Newbie

Posts

Joined
Tue Mar 26, 2013 3:15 am
Location - Houston, TX USA

Post by Cleo » Sun May 26, 2013 8:29 am


Opencart v1.5.4.1 fr/en
Theme: Custom
vqmod-2.6.0


User avatar
Active Member

Posts

Joined
Wed Mar 09, 2011 5:19 am

Post by redoctober83 » Sun May 26, 2013 8:33 am

Thank you so much! that is exactly what I was looking for!

Newbie

Posts

Joined
Tue Mar 26, 2013 3:15 am
Location - Houston, TX USA

Post by Cleo » Sun May 26, 2013 8:37 am

Your welcome!

Once you understand the layout system it's very easy to do

Cleo

Opencart v1.5.4.1 fr/en
Theme: Custom
vqmod-2.6.0


User avatar
Active Member

Posts

Joined
Wed Mar 09, 2011 5:19 am

Post by redoctober83 » Sun May 26, 2013 9:08 am

Cleo wrote:Your welcome!

Once you understand the layout system it's very easy to do

Cleo

Ya, I feel completely like a nuewb with how simple layouts are in this system.

I do have another question, do you know how to make the welcome message appear on the account page once they are logged in? I want to be able to show information the customers that have been approved for that site and not make it public info.

Thanks

Newbie

Posts

Joined
Tue Mar 26, 2013 3:15 am
Location - Houston, TX USA

Post by Cleo » Sun May 26, 2013 9:18 am

Humm... not sure about that one but maybe you can try to assign the Welcome module to = account (layout) when you edit the welcome module!

If that doesn't work try to search for "welcome message on account page" or something similar!

Sorry but I'm not a coder just a nuewb just like you but I'm trying :)

Cleo

Opencart v1.5.4.1 fr/en
Theme: Custom
vqmod-2.6.0


User avatar
Active Member

Posts

Joined
Wed Mar 09, 2011 5:19 am

Post by Cleo » Sun May 26, 2013 9:22 am

Ok I just tried it on my test site and it's working :)

Cleo

Opencart v1.5.4.1 fr/en
Theme: Custom
vqmod-2.6.0


User avatar
Active Member

Posts

Joined
Wed Mar 09, 2011 5:19 am

Post by redoctober83 » Sun May 26, 2013 9:25 am

Cleo wrote:Ok I just tried it on my test site and it's working :)

Cleo
I can get the welcome message to show up all the time on the account page. What I want is the welcome message to only show up if they are logged in.

Thanks

Newbie

Posts

Joined
Tue Mar 26, 2013 3:15 am
Location - Houston, TX USA

Post by Cleo » Sun May 26, 2013 9:30 am

Ooops.. sorry then you will need some coding for that :(

Probably a "if value" of something but like I previously said I know nothing about coding :(

Make another topic for this question and someone will be able to help you with that

Goog luck

Cleo

Opencart v1.5.4.1 fr/en
Theme: Custom
vqmod-2.6.0


User avatar
Active Member

Posts

Joined
Wed Mar 09, 2011 5:19 am

Post by redoctober83 » Sun May 26, 2013 9:31 am

Cleo wrote:Ooops.. sorry then you will need some coding for that :(

Probably a "if value" of something but like I previously said I know nothing about coding :(

Make another topic for this question and someone will be able to help you with that

Goog luck

Cleo
I am not a coder either.

Thank you for all your hope!

Newbie

Posts

Joined
Tue Mar 26, 2013 3:15 am
Location - Houston, TX USA

Post by Cleo » Sun May 26, 2013 9:36 am

You're welcome :)

Good luck

Cleo

Opencart v1.5.4.1 fr/en
Theme: Custom
vqmod-2.6.0


User avatar
Active Member

Posts

Joined
Wed Mar 09, 2011 5:19 am
Who is online

Users browsing this forum: No registered users and 47 guests