Page 1 of 1

Contact form dont work (1.5.5.1)

Posted: Sun May 05, 2013 9:04 pm
by craft37
Hello, folks!
Please help me with mail contact form ( http://gmbox.by/contact ), script even don't show success page.
1) hoster says that php mail () work correctly
2) mail mode in settings, e-mail set properly
3) i modifyed only contact.tpl only with map, system/mail.php is original from ver. 1.5.5.1

i just don't know what to do, i googled for few weeks and not fix problem.
what it can be, please help me!

Re: Contact form dont work (1.5.5.1)

Posted: Mon May 06, 2013 1:47 am
by butte
What happens if you undo your 3)? Did it work before that? There are several concurrent recent threads on contact mailing.

Re: Contact form dont work (1.5.5.1)

Posted: Wed May 08, 2013 10:00 pm
by nestones
I have the same issue. Isn't working contact form! I tried several things and all not working! Just don't know what to do now.

Anyone could assist? Would be appreciated.

Re: Contact form dont work (1.5.5.1)

Posted: Wed May 08, 2013 10:19 pm
by straightlight
Switch to default template and see if you can reproduce the problem.

Re: Contact form dont work (1.5.5.1)

Posted: Tue May 14, 2013 5:45 pm
by craft37
What happens if you undo your 3)? Did it work before that? There are several concurrent recent threads on contact mailing.
tryed to restore original contact.tpl, seems the problem not in it

i found, that contact form don't work with this lines in index.php after

Code: Select all

// SEO URL's 
//$controller->addPreAction(new Action('common/seo_url'));

if (!$seo_type = $config->get('config_seo_url_type')) { 
$seo_type = 'seo_url'; 
} 
$controller->addPreAction(new Action('common/' . $seo_type));
Without this storke mail work with smtp, but it ruins seo url on my custom pages (contacts, latest, etc)
Any ideas?

Re: Contact form dont work (1.5.5.1)

Posted: Tue May 14, 2013 11:44 pm
by straightlight
What does it report on your web error logs when you do have the SEO Url class loaded ?

Re: Contact form dont work (1.5.5.1)

Posted: Wed May 15, 2013 4:28 pm
by craft37
straightlight wrote:What does it report on your web error logs when you do have the SEO Url class loaded ?
system/logs show no error, with or without this SEO URL's strokes (seo pro plugin)

Re: Contact form dont work (1.5.5.1)

Posted: Wed May 15, 2013 10:18 pm
by straightlight
From your cPanel error log, what does it display for that event particularly ?

Re: Contact form dont work (1.5.5.1)

Posted: Thu May 16, 2013 5:31 am
by craft37
straightlight wrote:From your cPanel error log, what does it display for that event particularly ?
my hosting use ISP manager (ispmgr) and this log empty too

Re: Contact form dont work (1.5.5.1)

Posted: Mon Jul 15, 2013 10:49 pm
by craft37
The problem was connected with seo_pro russian mafia extension
It's not works properly with the latest OC 1.5.5.1
At least, at this moment

Re: Contact form dont work (1.5.5.1)

Posted: Fri Jul 19, 2013 4:26 am
by butte
The safest way, overall, to test seo extensions and modules for pproblems, solutions, and workarounds is to set up a browsable mirror OC (identical but separate, in an adjoining directory, in its own subdomain, or whatever) and tinker with that.