Post by kuleszko » Sun Apr 28, 2013 12:29 am

Hi, i have problem with edition products, when i click product from menu this information is appear:

Fatal error: Cannot redeclare ControllerCatalogProduct::dbCheck() in /home4/ecotherm/public_html/ledbulb/vqmod/vqcache/vq2-admin_controller_catalog_product.php on line 15

will somebody help me with this?
Thanks
Cris

Surprise your partner in the bedroom!! visit Sexy Lingerie.


New member

Posts

Joined
Fri Mar 23, 2012 10:10 pm
Location - Aberdeen, UK

Post by butte » Sun Apr 28, 2013 1:42 am

You might try making a backup of the vqmod/vqcache/ and then emptying it, then retrying. That's prevalent enough that you might want to search "empty vqmod cache" . . .

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by rph » Sun Apr 28, 2013 2:20 am

You either have two vqmod scripts which have both created a dbCheck() method or the same vqmod script has been duplicated on your site.

-Ryan


rph
Expert Member

Posts

Joined
Fri Jan 08, 2010 5:05 am
Location - Lincoln, Nebraska

Post by kuleszko » Sun Apr 28, 2013 11:31 pm

Thanks

Surprise your partner in the bedroom!! visit Sexy Lingerie.


New member

Posts

Joined
Fri Mar 23, 2012 10:10 pm
Location - Aberdeen, UK

Post by kuleszko » Mon Apr 29, 2013 3:27 am

Hi, is here someone who can help , i have make some mistake and my site look like this http://www.ledmarket.ie, how can i repair this.? Thanks

Surprise your partner in the bedroom!! visit Sexy Lingerie.


New member

Posts

Joined
Fri Mar 23, 2012 10:10 pm
Location - Aberdeen, UK

Post by butte » Mon Apr 29, 2013 3:35 am

Undo whatever you just did. Either restore a backup file into place or edit while what you did is still fresh in your mind. There is no style, so you may have aborted a call to your .css file(s). Look for that for starters, and then proofread carefully.

. . . Viewing generated source is showing me that In the head, six of your seven link entries end in [" />] and the other one ends in [">], while all of the script entries end in the latter [">]. Try changing the six [" />] to match the others' [">]. In that particular place it should not be necessary to "escape" the tag carat as [/>] rather than customary [>]. (Of the links, five are placed normally, and the two for IE appear below those.)

A few days ago (accessed from another thread) it appeared as it should. Your browser might still have a cached copy of that, if you are completely desperate for a backup.

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by kuleszko » Mon Apr 29, 2013 4:11 am

Thank butte where can i find it? Maybe this is funny for you but i dont know nothing about HTML

Surprise your partner in the bedroom!! visit Sexy Lingerie.


New member

Posts

Joined
Fri Mar 23, 2012 10:10 pm
Location - Aberdeen, UK

Post by butte » Mon Apr 29, 2013 4:39 am

[There is nothing funny about it; you're learning and went where you shouldn't have, where I had readily assumed from both of your two linked OC installations that editing to undo what you did would be nothing new to you. I just noticed your edit to respell to funny.]

If you have a recent backup of header.tpl, just put that back into place. Maybe you're just using one or another of those infernal programs that pretend to write clean code but never will write it. However you did whatever you did, between a few days ago when appearances were normal and now when there is no style, is what I meant to undo -- undo what you did, the way you did it (by hand or by software, doesn't matter). A backup file would probably be quicker.

The simplest first thing to check is your theme. If it is not catalog/view/theme/default/, that needs to be changed to the appropriate catalog/view/theme/whatever/. If you're using the default theme, I haven't yet noticed what the problem actually is (where it's coming from). What I first suggested is NOT the problem. I looked at some other files to refresh memory, and the escaped /> (rather than common >) is springing from header.tpl the normal way.

Quick overview. Your header.tpl (category/view/theme/default/template/common/header.tpl) inserts your head section near the top of the page, above the body section, and the majority of your head section reads:

[code]
<head>
<title>Led Market, Led bulbs, Led lights , online shop.</title>
<base href="http://ledbulb.ie/" />
<meta name="description" content="Best offer for Led lights. Replace your old bulbs to new LED lamps , LED bulbs are efficient and last for long." />
<link href="http://ledbulb.ie/image/data/favicon ledbulb.jpg" rel="icon" />
<link rel="stylesheet" type="text/css" href="catalog/view/theme/default/stylesheet/stylesheet.css" />
<link rel="stylesheet" type="text/css" href="catalog/view/theme/default/stylesheet/slideshow.css" media="screen" />
<script type="text/javascript" src="catalog/view/javascript/jquery/jquery-1.7.1.min.js"></script>
<script type="text/javascript" src="catalog/view/javascript/jquery/ui/jquery-ui-1.8.16.custom.min.js"></script>
<link rel="stylesheet" type="text/css" href="catalog/view/javascript/jquery/ui/themes/ui-lightness/jquery-ui-1.8.16.custom.css" />
<script type="text/javascript" src="catalog/view/javascript/jquery/ui/external/jquery.cookie.js"></script>
<script type="text/javascript" src="catalog/view/javascript/jquery/colorbox/jquery.colorbox.js"></script>
<link rel="stylesheet" type="text/css" href="catalog/view/javascript/jquery/colorbox/colorbox.css" media="screen" />
<script type="text/javascript" src="catalog/view/javascript/jquery/tabs.js"></script>
<script type="text/javascript" src="catalog/view/javascript/common.js"></script>
<script type="text/javascript" src="catalog/view/javascript/jquery/jquery.cycle.js"></script>
<script type="text/javascript" src="catalog/view/javascript/jquery/nivo-slider/jquery.nivo.slider.pack.js"></script>
<!--[if IE 7]>
<link rel="stylesheet" type="text/css" href="catalog/view/theme/default/stylesheet/ie7.css" />
<![endif]-->
<!--[if lt IE 7]>
<link rel="stylesheet" type="text/css" href="catalog/view/theme/default/stylesheet/ie6.css" />
<script type="text/javascript" src="catalog/view/javascript/DD_belatedPNG_0.0.8a-min.js"></script>
<script type="text/javascript">
DD_belatedPNG.fix('#logo img');
</script>
<![endif]-->
<script type="text/javascript">
[/code]

Substantially the same interspersed with php appears in header.tpl and changing the latter will change the former. If you changed the theme from the default, catalog/view/theme/default/, change the latter to fit with what the new theme is.

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by kuleszko » Thu May 02, 2013 2:01 am

butte thank You very much, is any option to hire your attention for hour ? Not for free, the situation is that I made the mess in Sunday and in Monday my shop was in highest position in google since i began seo for shop . Is almost year job to be in top 3 for my most important phrases. I didnt make any money on the shop yet but now I am sure that i will not make any :(

Surprise your partner in the bedroom!! visit Sexy Lingerie.


New member

Posts

Joined
Fri Mar 23, 2012 10:10 pm
Location - Aberdeen, UK

Post by butte » Thu May 02, 2013 2:09 am

See PM . . .

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by kuleszko » Thu May 02, 2013 3:26 am

have you got my email?

Surprise your partner in the bedroom!! visit Sexy Lingerie.


New member

Posts

Joined
Fri Mar 23, 2012 10:10 pm
Location - Aberdeen, UK

Post by butte » Thu May 02, 2013 4:07 am

Even replied. None of mine comes and goes in batches, but yours might. While we're sorting that out, I'm stuffing it copy-paste in a moment into PM.

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by kuleszko » Thu May 09, 2013 2:36 am

buttie thanks for Your help, ill reinstall my store . You was very helpfull Thanks again.

Surprise your partner in the bedroom!! visit Sexy Lingerie.


New member

Posts

Joined
Fri Mar 23, 2012 10:10 pm
Location - Aberdeen, UK

Post by butte » Thu May 09, 2013 10:48 am

Go ahead and send PM if need be. The existing in/out are all accounted for.

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am
Who is online

Users browsing this forum: No registered users and 51 guests