Post by betchay » Thu Mar 08, 2012 4:57 pm

I am looking for the same solution.

My default currency is Korean Won (KRW). I enter product price in the admin using that currency, but I want to sell using the USD.

I want my store to show the prices only in USD so I disabled the KRW (but it's still my default).

The problem is the prices still show in KRW instead of USD.

I was able to do this before in my old store with 1.4xxx but I forgot how now.

Newbie

Posts

Joined
Thu Mar 04, 2010 9:49 am

Post by betchay » Thu Mar 08, 2012 7:03 pm

I think I got it...

I changed the settings > local currency > default - US dollars and AUTO UPDATE currency is set to NO

In localisation > currencies > KRW is set to 1 and USD is set to .001

I still enter the price at the back end in Korean won - for example 11,000 and on the store it's shown as USD 11.00

everything is working perfectly... opencart is the best!

Newbie

Posts

Joined
Thu Mar 04, 2010 9:49 am

Post by Qphoria » Thu Mar 08, 2012 11:42 pm

betchay wrote:I think I got it...

I changed the settings > local currency > default - US dollars and AUTO UPDATE currency is set to NO

In localisation > currencies > KRW is set to 1 and USD is set to .001

I still enter the price at the back end in Korean won - for example 11,000 and on the store it's shown as USD 11.00

everything is working perfectly... opencart is the best!
You may be using a cached value. Clear all your cookies and refresh the page.. see if it still works.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by picobo » Fri Mar 09, 2012 2:18 am

I believe uksitebuilder provided the best solution for this:

http://forum.opencart.com/viewtopic.php ... 48#p182248
In your admin, system -> localisation -> currencies
You have your default currency set as USD and also set it to Disabled
You have an additional currency set as GBP leave it set as Enabled
This takes care of the currency switcher

Now to make the prices on the front end GBP by default.
open: system/library/currency.php
Find:

Code: Select all

            $this->set($this->config->get('config_currency'));
Replace With:

Code: Select all

            //$this->set($this->config->get('config_currency'));
            $this->set('GBP');
I left the old line in there (commented out) just in case you want to switch back to normal use later.
In my case i still wanted users to be able to choose their currency, so I didn't remove the switcher, only did the second part of setting my second currency as default in the front end, yet still leaving the USD as the default and Enabled in the back end.

Hope it helps!

Newbie

Posts

Joined
Sat Feb 11, 2012 6:59 am

Post by usa63w » Wed Aug 29, 2012 5:44 pm

I opted for opencart because it supported electronically distributed products. Then, I had to take an older version to get it to work with the template I wanted to us. Thus, Version 1.4.9.4

Default currency MUST be USD. and it must exist. I don't know how the others got it to be something else, but for me it must be USD and I need it to be AUD. I've read all of the other posts, and all to no avail.

* deleting all other currencies, does not resolve problem
* changing USD to AUD does not resolve problem
* setting AUD to 1.00 and USD to 1.2345 and USD is still the default.
* clearing the cookies and clearing the cache does not resolve the problem
* changing computers does not resolve the problem
* changing browsers does not resolve the problem

However, there may be a resolution available... use a different product! If it cannot be resolved in the next couple of days, I'll have no choice but to do exactly that.

Newbie

Posts

Joined
Wed Aug 29, 2012 5:37 pm

Post by rah82 » Wed Sep 05, 2012 5:11 pm

Hi

I think I can help you...

Use the USD currency, change it to the currency you want BUT let the code USD remain. Dont think i will matter..

Newbie

Posts

Joined
Tue Sep 04, 2012 3:57 pm

Post by tanbeen » Sun Feb 10, 2013 12:20 pm

I am facing local currency settings problem. When i set my local currency BDT as default, it does not work. Even my currency sign ৳ don't show. My site show only $ sign. I have cleared all my cookies. But it didn't work then too. Even all my new visitor of my site see just the $ Sign. please help me if any one can, How can i solve this problem?

Newbie

Posts

Joined
Wed Feb 06, 2013 5:24 pm

Post by tanbeen » Sun Feb 10, 2013 12:26 pm

usa63w wrote:
* deleting all other currencies, does not resolve problem
* changing USD to AUD does not resolve problem
* setting AUD to 1.00 and USD to 1.2345 and USD is still the default.
* clearing the cookies and clearing the cache does not resolve the problem
* changing computers does not resolve the problem
* changing browsers does not resolve the problem
Same problem as me. can anyone help use please?

Newbie

Posts

Joined
Wed Feb 06, 2013 5:24 pm

Post by peterkbm » Tue Feb 26, 2013 2:48 am

set default currency:
-----------------------------------------------
1) add currency: system > localism > currensy
2) set default: system > setting > local >
3) go back add currency page, to correct currency rate

Newbie

Posts

Joined
Tue Feb 26, 2013 2:44 am

Post by nuyul » Sun Mar 24, 2013 8:52 pm

yay i just found a solution for this issue just now!!!

1) Go to system > localisation > currency : edit USD and disable it.
2) create your country currency and enable it. set Value : 1.
3) GO to Settings>local and set Currency: your country currency.
4) Go to system > localisation > currency and Delete USD. then insert back USD currency and just leave blank for value: . and enable it. once u save the setting and USD value will be automated.

thats it! hope i can help somebody with this post.. good luck :)

Newbie

Posts

Joined
Tue Mar 19, 2013 11:21 pm

Post by nuyul » Sun Mar 24, 2013 8:55 pm

my issue earlier is when i set my shop default to MYR and set value to 1, later the USD value will also set to 1...so i decided to delete the USD currency and did according to step in my previous post...

Newbie

Posts

Joined
Tue Mar 19, 2013 11:21 pm

Post by daritehnologies » Fri Jan 16, 2015 5:37 am

Hi,
You can change the default currency (USD) to other currencies in OpenCart 2.0.1.1 following these easy steps:

1. Add your local currency in System -- Localisation -- Currencies (eg. RON, HUF, CHF, EUR, RSD, RUB or anything else)
2. Go to System -- Settings -- your shop name -- edit -- Local -- Currency, and there change to your current currency
3. Click SAVE in the right up corner
4. Go back to System -- Localisation -- Currency -- edit your local currency -- set values to 1.00000000 -- SAVE
5. Edit USD -- leave the USD ”value” empty or fill it with 0.00000000 -- then SAVE
6. Click the Refresh button from the right-up corner

If everything goes well, YOUR local currency will be followed by the ”Default” message.
And the Exchange rates will be the right ones.

You may use as many as currencies you want, but dont forget, always you may have just one by Deafult.

Have a nice day!


Posts

Joined
Fri Jan 16, 2015 5:16 am

Post by tusharrai2 » Mon Apr 27, 2015 9:24 pm

i am unable to change my default currency from usd to inr,i have tried by creating new currency but disabled usd and enabled inr but still not fixed, kindly please help me out

Newbie

Posts

Joined
Mon Apr 27, 2015 9:18 pm

Post by drmrider » Sat Jul 23, 2016 5:11 am

Go To Settings --> Click on Edit Store --> Go to Local Tab --> Select Currency

Newbie

Posts

Joined
Sat Jul 23, 2016 5:09 am

Post by SkyD » Sat Dec 24, 2016 4:22 am

Hi,
I have a weird situation, my vendors are anal about the MAP pricing (Manufactured advertised pricing) which is in USD.
My store is Canadian and i display prices in Canadian. so the price is constantly changing and i am constantly going out of MAP price because of it.
I want to list the store in CAD but have USD as the default currency (I am ok with customers being able to switch between the two currencies i just want the front end default to be CAD and the back end default to be USD)

Any suggestions on how to do this?
2.3.0.2

Thank You

New member

Posts

Joined
Tue Dec 20, 2016 2:31 am

Post by ShaunMcA1 » Wed Nov 24, 2021 6:36 pm

A lot of dialog here. Don't think it addresses the issue. There are two different locations in the admin panel to update currency:
1. System/Settings/ Edit Store/ Local/ Currency; and
2. System/ Localization/ Currencies
I've noticed that the solution to the Subject: How to change Default Currency from USD to other currency, is as follows:
  • Add the new currency (if a new one is required) at, "2" above. Make the "value" of the currency 1.0000 and save the setting
  • Set it as the default currency by selecting it from the available currency selector at "1." above and save the setting
  • Now you are able to then delete (or disable) the unwanted currency at, "2" above.
  • You can add and enable any other currencies you need at, "2" above and make them proportional to your desired "default" currency you created at "1."
  • Finally, do not "edit" the currency.php file as suggested earlier for this subject, as you will only break the code.
So it just depends on the order you do the above, but there is nothing to fix here, I've just proven it.

Newbie

Posts

Joined
Wed Nov 24, 2021 6:01 pm
Who is online

Users browsing this forum: Bing [Bot] and 30 guests