Post by AlGeorge » Fri Apr 17, 2015 7:08 am

Hi when I login as Top Administrator, and select System/System Information
reponse:
You do not have permission to access this page, please refer to your system administrator.

The same admin user has all permissions checked.

Everything I find for this problem advises to check your permissions which are OK.
I have not installed EchoThemes System Information module; is this required?
Thanks kindly,
Alistair.

New member

Posts

Joined
Sun May 19, 2013 11:28 am

Post by IP_CAM » Sat Apr 18, 2015 1:46 am

>>I have not installed EchoThemes System Information module; is this required?<<
How do expect it to work, then? ???
Ernie

Please don't send me OC Forum Personal Messages, just contact: jti@jacob.ch
---
OC 1.5.6.5 LIGHT Test Site: http://www.bigmax.ch/shop/
OC 1.5.6.5 V-PRO Test Site: http://www.openshop.li/shop/
My Github OC Site: https://github.com/IP-CAM
2'800+ FREE OC Extensions on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by AlGeorge » Sat Apr 18, 2015 4:11 am

There is a menu option System Information. If it is a null function, thats very unusual in programming. Hence I asked the question since the Echothemese SI is the only other free option, in the unlikely event that was required, thats why I asked.

Anyway, you answered my question that its required, therefore if it doesnt exist the menu function SI should not be available.
Thank you.
Alistair.

New member

Posts

Joined
Sun May 19, 2013 11:28 am

Post by IP_CAM » Sat Apr 18, 2015 4:23 am

Code: Select all

<a href="<?php echo $this->url->link('tool/system_info', 'token=' . $this->session->data['token'],......
is NOT a null-function, it's an XML-Function, part of the Add-On, actually just a Link, XML-placed in Admin, to go to the System Info Page. if it has been installed before, and exists! :D
Ernie

Please don't send me OC Forum Personal Messages, just contact: jti@jacob.ch
---
OC 1.5.6.5 LIGHT Test Site: http://www.bigmax.ch/shop/
OC 1.5.6.5 V-PRO Test Site: http://www.openshop.li/shop/
My Github OC Site: https://github.com/IP-CAM
2'800+ FREE OC Extensions on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by IP_CAM » Tue Nov 24, 2020 10:22 am

Echothemes does no longer exist, as it looks. But you can download the System Information
Software for OC Versions 1.5.6.x - 2.0.x - 2.1.x - 2.2.x - 2.3.x here:
viewtopic.php?f=19&t=219551&p=796625#p796806

Please don't send me OC Forum Personal Messages, just contact: jti@jacob.ch
---
OC 1.5.6.5 LIGHT Test Site: http://www.bigmax.ch/shop/
OC 1.5.6.5 V-PRO Test Site: http://www.openshop.li/shop/
My Github OC Site: https://github.com/IP-CAM
2'800+ FREE OC Extensions on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by straightlight » Tue Nov 24, 2020 8:18 pm

Everything I find for this problem advises to check your permissions which are OK.
Contact the extension developer to resolve the issue. You may have already tried to installed it once or twice and might be stuck on this permission issue. It could also be lead between an event index and a standard index method in the module lookup from the OC admin.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 36 guests