Post by ocon » Sat Nov 14, 2009 2:32 pm

I translated OpenCart 1.3.2 in my language.
Now I have to re-translate OpenCart 1.3.4 because there are
some additional strings to language.

My question is:
What is the best , easy and simple file comparison software
to help me translating OpenCart.

Thanks.

Newbie

Posts

Joined
Wed Aug 12, 2009 4:11 am

Post by i2Paq » Sat Nov 14, 2009 5:42 pm

ocon wrote:I translated OpenCart 1.3.2 in my language.
Now I have to re-translate OpenCart 1.3.4 because there are
some additional strings to language.

My question is:
What is the best , easy and simple file comparison software
to help me translating OpenCart.

Thanks.
I had the same problem with Dutch.

I just uploaded the 1.3.2 version and checked everywhere and where translations where missing a manualy added them.
File-comparison only works if the line are on the same spot, in my case the where not.

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by fido-x » Sat Nov 14, 2009 5:53 pm

What operating system are you using? If you're using Linux, use diff or sdiff to compare files (sdiff will give you a side-by-side comparison).

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by ocon » Sat Nov 14, 2009 5:57 pm

fido-x wrote:What operating system are you using? If you're using Linux, use diff or sdiff to compare files (sdiff will give you a side-by-side comparison).
My OS is Windows XP.

Thanks

Newbie

Posts

Joined
Wed Aug 12, 2009 4:11 am

Post by fido-x » Sat Nov 14, 2009 6:04 pm

You could try WinMerge from http://sourceforge.net/projects/winmerge/

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by Qphoria » Sat Nov 14, 2009 9:55 pm

ocon wrote:I translated OpenCart 1.3.2 in my language.
Now I have to re-translate OpenCart 1.3.4 because there are
some additional strings to language.

My question is:
What is the best , easy and simple file comparison software
to help me translating OpenCart.

Thanks.
There are fill diff programs like WinMerge that can help... But you can use a less damaging approach by using my Improved Language Library. This way you don't get errors on your site when using older language packs. The new fields will just show up in english (assuming you don't delete the default english). Then you know exactly which tags/pages are not translated

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by ocon » Sat Nov 14, 2009 10:28 pm

Qphoria, thanks for the tips.
I will try it.

Newbie

Posts

Joined
Wed Aug 12, 2009 4:11 am

Post by Sheldon.Kirk » Mon Nov 16, 2009 5:52 pm

Great Work, loving the JS features. :) :)

Image

Sparx Web Solutions - Affordable Web Design & Internet Marketing

New Zealand Web Design


User avatar
Active Member

Posts

Joined
Fri Jul 03, 2009 5:58 am
Location - Tauranga, New Zealand

Post by digiartvn » Mon Nov 16, 2009 9:45 pm

Can't change currency value in v1.3.4!
I set my currency (VN Dong) as default, value=1 and US Dollar's value = 0.00005405.
next time I enter the adminCP the value of US Dollar alway turn back 0.00010000
How come Daniel? Please help me.

Newbie

Posts

Joined
Fri Nov 13, 2009 3:44 pm

Post by lucyvanpelt » Tue Nov 17, 2009 2:49 am

daniel,

is there anyway there can be some sort of auto upgrade feature? i have errors when upgrading from 1.33 to 1.34 and if ind that each time its really difficult to get the next upgrade up and running. maybe an autoupgrade could solve the problem, kinda like how windows or mac updates in some sort of way, something we could possibly click from the admin screen.

New member

Posts

Joined
Wed Nov 04, 2009 5:38 am

Post by lucyvanpelt » Tue Nov 17, 2009 4:07 pm

i just did a fresh install with a new database and when my new cart is loaded and i go to ad a product to the cart and a message pops up where the item was saying "The page you requested cannot be found!"

i think there still might be a few bugs with this new version...

New member

Posts

Joined
Wed Nov 04, 2009 5:38 am

Post by i2Paq » Tue Nov 17, 2009 4:46 pm

lucyvanpelt wrote:i just did a fresh install with a new database and when my new cart is loaded and i go to ad a product to the cart and a message pops up where the item was saying "The page you requested cannot be found!"

i think there still might be a few bugs with this new version...
I'm running a clean 1.3.4 and can add, delete of anything and it shows no error.
Doe you use SEO urls?

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by lucyvanpelt » Tue Nov 17, 2009 4:48 pm

no i just installed it i didnt setup seo.

New member

Posts

Joined
Wed Nov 04, 2009 5:38 am

Post by i2Paq » Tue Nov 17, 2009 4:55 pm

lucyvanpelt wrote:no i just installed it i didnt setup seo.
Can you check what your server-logs are saying?

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by lucyvanpelt » Tue Nov 17, 2009 4:58 pm

when i go to the admin > error logs section. there are none listed.

New member

Posts

Joined
Wed Nov 04, 2009 5:38 am

Post by i2Paq » Tue Nov 17, 2009 5:00 pm

lucyvanpelt wrote:when i go to the admin > error logs section. there are none listed.
I mean teh server-logs of the apache-server, maybe you have to ask your hoster.

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by lucyvanpelt » Tue Nov 17, 2009 5:07 pm

the host i use never gave me problems before, which makes me believe theres something up with 1.3.4 version. it appears a lot of people have buggyness going on in this thread.

New member

Posts

Joined
Wed Nov 04, 2009 5:38 am

Post by ocon » Tue Nov 17, 2009 5:21 pm

lucyvanpelt wrote:the host i use never gave me problems before, which makes me believe theres something up with 1.3.4 version. it appears a lot of people have buggyness going on in this thread.
Try to see your error log first.
I installed OpenCart 1.3.4 successfully and find no error so far.

Newbie

Posts

Joined
Wed Aug 12, 2009 4:11 am

Post by lucyvanpelt » Tue Nov 17, 2009 5:28 pm

i did. nothing was there. try adding something to your cart. thats where i found the error on mine.

New member

Posts

Joined
Wed Nov 04, 2009 5:38 am

Post by itdude » Tue Nov 17, 2009 5:42 pm

i also had errors on upgrading... i reinstalled(clean install) and seems to be working fine now...

Web Design & Programming?
IT-Dude.com ...LOW COST but SUPERB outcome!

... ... loving OpenCart more everyday =]
Image


User avatar
New member

Posts

Joined
Fri Nov 06, 2009 2:38 pm
Location - Philippines
Who is online

Users browsing this forum: No registered users and 5 guests