Post by henkster » Fri Sep 30, 2011 1:50 pm

i2Paq wrote:
rlec wrote:Was the ability to edit an order not included in this release?
No.
So... will the next release contain it? This is a pretty major functional requirement for quite a few clients of mine, it's a real killer as the rest of the package is superb and I'm having to recommend alternatives (when I'd really just like to work with Opencart).

Thanks for the update though, and your continued hard work!

Newbie

Posts

Joined
Wed Jul 13, 2011 5:34 am

Post by Daniel » Fri Sep 30, 2011 6:08 pm

i'm pretty sure i can get the order editor working this month.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by jonthee » Fri Sep 30, 2011 7:02 pm

I dont understand? Is it OK to use the upgrade patch or is it something wrong with the language-files?

So many of you had errors while upgrading, is it really safe to upgrade?

New member

Posts

Joined
Sun Aug 14, 2011 1:55 am

Post by deejunit » Fri Sep 30, 2011 7:59 pm

Couldn't see anything about it in the release notes, so I am wondering if the functionality to generate the invoice manually (in stead of having this done automatically) was added in this release?

I recall several people had strong opinions on this matter:
http://forum.opencart.com/viewtopic.php?f=161&t=34284

New member

Posts

Joined
Sat Jul 21, 2007 5:40 am

Post by Xsecrets » Fri Sep 30, 2011 8:15 pm

jonthee wrote:I dont understand? Is it OK to use the upgrade patch or is it something wrong with the language-files?

So many of you had errors while upgrading, is it really safe to upgrade?
It has nothing to do with the upgrade script. There is new functionality in the admin. Meaning there is a new page meaning there is a new language file, so no matter upgrade patch whatever you will get the error if you are not using english as your admin language since the releases only come with english language.

OpenCart commercial mods and development http://spotonsolutions.net
Layered Navigation
Shipment Tracking
Vehicle Year/Make/Model Filter


Guru Member

Posts

Joined
Sun Oct 25, 2009 3:51 am
Location - FL US

Post by Daniel » Fri Sep 30, 2011 8:40 pm

deejunit wrote:Couldn't see anything about it in the release notes, so I am wondering if the functionality to generate the invoice manually (in stead of having this done automatically) was added in this release?

I recall several people had strong opinions on this matter:
http://forum.opencart.com/viewtopic.php?f=161&t=34284

yes its done.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by deejunit » Fri Sep 30, 2011 8:46 pm

Daniel wrote:
deejunit wrote:Couldn't see anything about it in the release notes, so I am wondering if the functionality to generate the invoice manually (in stead of having this done automatically) was added in this release?

I recall several people had strong opinions on this matter:
http://forum.opencart.com/viewtopic.php?f=161&t=34284

yes its done.
That's great :)

(now I am only waiting for order edit... ;))

New member

Posts

Joined
Sat Jul 21, 2007 5:40 am

Post by Johnathan » Fri Sep 30, 2011 9:28 pm

Daniel wrote:No Extension Changes! All existing 1.5.1 extensions should work without change on this newer version.
This is not true. Any extension that utilizes $this->tax->getRate() and has a tax class applied to it will cause the store to crash. This includes all Order Total extensions from 1.5.1.2 or lower.

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by Qphoria » Fri Sep 30, 2011 9:30 pm

Johnathan wrote:
Daniel wrote:No Extension Changes! All existing 1.5.1 extensions should work without change on this newer version.
This is not true. Any extension that utilizes $this->tax->getRate() and has a tax class applied to it will cause the store to crash. This includes all Order Total extensions from 1.5.1.2 or lower.
My bad.. I put that in there. I've changed it now. Damn, this should not have been a point release then.
I've updated the second post with some developer notes
http://forum.opencart.com/viewtopic.php ... 99#p202599

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Qphoria » Fri Sep 30, 2011 11:04 pm

For those who couldn't get the patch to work, I hadn't thought about the fact that the install folder needs to have all the files in it since your store wouldn't still have the old one. That was causing this error:
Notice: Error: Could not load controller header! in /system/engine/controller.php on line 48
I've patched it to v2 now and it includes the full install folder so that should resolve it.

There were also some other limitations in the upgrade script that worked fine in a dev environment. The upgrade files in the full version will also have this problem. I've patched them in the 1.5.1.3.1 version and patch only versions to avoid future issues.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by dony_b » Fri Sep 30, 2011 11:20 pm

http://opencart.googlecode.com/svn/trun ... /colorbox/

Whats the deal with colorbox ? Is this going to be on the next version ?

User avatar
Active Member

Posts

Joined
Wed Aug 18, 2010 9:56 pm
Location - Boston, MA

Post by jonthee » Fri Sep 30, 2011 11:45 pm

Where is the new patch-file? Does it include the missing english language-file? Can I just put the english language file in my own language although it is in english? Whats the name of that language-file?

Thanks in advance.

Best regards!

New member

Posts

Joined
Sun Aug 14, 2011 1:55 am

Post by Qphoria » Fri Sep 30, 2011 11:52 pm

jonthee wrote:Where is the new patch-file? Does it include the missing english language-file? Can I just put the english language file in my own language although it is in english? Whats the name of that language-file?

Thanks in advance.

Best regards!
There was no missing english file. The issue you are having is in your other language pack, the language file doesn't exist. You need to copy the language file from
catalog/language/english/payment/web_payment_software.php
to
catalog/language/<YOURLANG>/payment/web_payment_software.php

as the existing language packs don't have this new file and the language fallback was removed. Alternatively you could use this patch to prevent this from happening in the future: http://forum.opencart.com/viewtopic.php ... 81#p183681

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Daniel » Sat Oct 01, 2011 1:49 am

dony_b wrote:http://opencart.googlecode.com/svn/trun ... /colorbox/

Whats the deal with colorbox ? Is this going to be on the next version ?

facybox doe snot work well.

also i'm planning on using color box for the order editor.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by dony_b » Sat Oct 01, 2011 1:55 am

Daniel wrote:
dony_b wrote:http://opencart.googlecode.com/svn/trun ... /colorbox/

Whats the deal with colorbox ? Is this going to be on the next version ?

facybox doe snot work well.

also i'm planning on using color box for the order editor.
Yes I saw that in the svn version. I played with it and it looks like a lot better than fancybox.

Its lighter and most importantly works great with IE versions.

User avatar
Active Member

Posts

Joined
Wed Aug 18, 2010 9:56 pm
Location - Boston, MA

Post by affect » Sun Oct 02, 2011 12:07 am

There should be NO affect on existing 1.5.x extensions or modules.
All existing 1.5.1 extensions should work without change on this newer version.
Actually, I've just noticed that all calls that used to load json library ($this->load->library('json')) got removed. That breaks extensions that use ajax/json for response.

Not really difficult to fix, but would be nice if it was in developer notes.

MultiMerch Marketplace for OpenCart

Image


User avatar
Active Member

Posts

Joined
Sat Aug 13, 2011 5:04 pm


Post by Qphoria » Sun Oct 02, 2011 3:00 am

affect wrote:
There should be NO affect on existing 1.5.x extensions or modules.
All existing 1.5.1 extensions should work without change on this newer version.
Actually, I've just noticed that all calls that used to load json library ($this->load->library('json')) got removed. That breaks extensions that use ajax/json for response.

Not really difficult to fix, but would be nice if it was in developer notes.
LOL how did you quote this? I removed this line early yesterday after Jonathan stated it. I was not aware of this change.. yet another reason this should not have been a point release. ::)

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by henkster » Sun Oct 02, 2011 10:14 am

Daniel wrote:i'm pretty sure i can get the order editor working this month.
That would be epic, I really appreciate your efforts and I'm looking forwards to seeing this appear shortly. Thanks!

Newbie

Posts

Joined
Wed Jul 13, 2011 5:34 am

Post by Hashishim » Sun Oct 02, 2011 6:55 pm

Hi guys sorry for this, I just want to know whether it feasible for me to do the upgrade now or just wait until the order editor is out, and do it one time then. Since my OpenCart is extremely customized and will have to do it from scratch.

I just want to know, what so different in the Tax system now, in terms of functionality and what is the point or what does it do, can you give an example of what it does this time that is different from previous versions

It will help me a lot.

New member

Posts

Joined
Mon Jul 25, 2011 5:44 am

Post by JNeuhoff » Mon Oct 03, 2011 1:23 am

Qphoria wrote: Since this was done in a point release (unfortunately :-[ )
This should have really been labelled 1.5.2 or even 1.6 because there are new features with the tax rates, including changes in the underlying database. Will do some thorough testing for all my Opencart extensions (there are tons of VQmod XML files which we plan to publish, too :) ) and bugfixes.

Anyway, a big thanks to Daniel and Q for all the hard work that went into this software release.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am

Who is online

Users browsing this forum: No registered users and 8 guests