Post by Qphoria » Thu Jul 21, 2011 2:09 am

NEW BETA3 VERSION HERE:
http://forum.opencart.com/viewtopic.php?f=2&t=50292
WITH PRODUCT OPTION SUPPORT




About this script
This script is a collection of all the patches and versions of opencart from version 1.4.0 to version 1.5.1.2.
That means you run this script to bring your store's database to 1.5.1.2
If you want to install a version later than 1.5.1.2, that is fine. Just be sure that after you run this script, you run the installer that comes with the latest version of OpenCart. More info on that below...

This script does NOT convert product options. Things like color, size, etc are not ported over because of a design change for options that was made as of 1.5.0.The option design is so different now that there is currently no way to convert them. If you have products with options, then your products will be converted fine, but your product options will just be removed and you will have to add them manually again after upgrade. If your store has no product options, then you have nothing to worry about and the script should work fine for you.

READ CAREFULLY:
  1. Only use this script if your store is running OpenCart v1.4.x
  2. DO NOT USE THIS SCRIPT TO UPGRADE EXISTING 1.5.x STORES
  3. This script does NOT support product option conversion.
  4. If you have product options, they will have to be added back manually!
  5. This script includes a STEP-BY-STEP readme file. Follow it exactly!
  6. This script will work as far back as OpenCart v1.4.0
  7. This script works! There has never been a confirmed error.
  8. If you see warnings or errors, they are false positives. Just ignore them. This script has been run enough times to know that it has no real errors.
  9. Once you are upgraded, post any functionality bugs in the appropriate thread for your version, not here.
Upgrading to versions later than 1.5.1.2
As I said above, this script will bring your database to version 1.5.1.2
If you are installing straight to a later version, like 1.5.1.3, then you simply need to first follow the upgrade step by step guide from this Beta2, installing the latest version of opencart. Then after you complete this script, you can run the installer that comes with 1.5.1.3 or later.

1. Run this Beta2 Script first by following the step-by-step guide that comes with it
2. After following this Beta2 script, follow the upgrade.txt file that comes with the latest version of OpenCart.
3. Done!

What to Expect after upgrading from 1.4.x to 1.5.x
  1. Your theme will be set to the default opencart 1.5.x theme
  2. You will not see any modules or products on the homepage yet, only the header and footer.
    You need to go into the Admin->Extensions->Modules page and add your modules to see products on the front.
  3. Your products, categories, customers, orders will all be safe and viewable in the admin area
  4. If you had any 3rd party modules from 1.4.x installed, you may see errors like "Document::setTitle". That means the module was not updated yet. You should uninstall it from the modules area and get the latest update from the author of the mod
  5. There are new menus in the admin, so be sure to go through them.
[/s]

Attachments

Last edited by i2Paq on Tue Jan 10, 2012 3:13 am, edited 1 time in total.
Reason: Made Normal

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Qphoria » Wed Oct 12, 2011 12:56 pm

UPDATE

- Made the wording in the first post clearer (hopefully)
- Updated the step-by-step guide in the zip file to be clearer (hopefully)
- Added a Troubleshooting section to the step-by-step guide for common issues
- Deleted the 11 pages of wasted complaints due to people not reading

Hopefully people will find the updated guide more helpful and stop posting the same garbage which have been answered 50 times and is usually caused by their inability to read.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Skyhigh » Wed Oct 12, 2011 8:00 pm

I just wanted to know if I had to start working on the script myself, or whether you were developing one.
(Just checking, as this thread was started some time ago - and things change).

It's perfectly possible to create a script to do the job of porting product options across - although you may not have the time (which is perfectly fine, as you dedicate a lot of time to OC).

I'll get started then :)

LoveMoissanite.com - Moissanite Rings - Proudly Powered by Opencart
[How To] Speed Up Page Content with Opencart - Opencart advocate since 2009


New member

Posts

Joined
Fri Sep 11, 2009 8:12 pm

Post by Qphoria » Wed Oct 12, 2011 8:51 pm

Skyhigh wrote:I just wanted to know if I had to start working on the script myself, or whether you were developing one.
(Just checking, as this thread was started some time ago - and things change).

It's perfectly possible to create a script to do the job of porting product options across - although you may not have the time (which is perfectly fine, as you dedicate a lot of time to OC).

I'll get started then :)
Yes it is possible, but I do not have time. So please if you have the means and time, please feel free to make a sub-script that handles the product option conversion

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Skyhigh » Wed Oct 12, 2011 9:01 pm

No problem, I'll post it over when I've got it done - it might be a while until I get enough time to finish it off.
(but its better than me manually having to re-enter over 400 sets of production options!)

:)

LoveMoissanite.com - Moissanite Rings - Proudly Powered by Opencart
[How To] Speed Up Page Content with Opencart - Opencart advocate since 2009


New member

Posts

Joined
Fri Sep 11, 2009 8:12 pm

Post by Khalid H.S » Thu Oct 13, 2011 11:20 am

you must add this line in SQL

Code: Select all

ALTER TABLE `product_image` ADD `sort_order` INT( 3 ) NOT NULL 

مصمم ومطور متاجر إلكترونية | @Oc_Style
لطلبات التصميم، تعريب القوالب والاضافات، ترقية الإصدار، حماية المتجر قم بمراسلتي من خلال المنتدى


موديل: إشعارات البنوك السعودية

1 | 2 | O :طرق لحماية السكربت


User avatar
Active Member

Posts

Joined
Fri Dec 10, 2010 9:39 pm
Location - Saudi Arabia

Post by Qphoria » Thu Oct 13, 2011 11:32 am

Khalid H.S wrote:you must add this line in SQL

Code: Select all

ALTER TABLE `product_image` ADD `sort_order` INT( 3 ) NOT NULL 
product image doesn't have sort order in the core. Only a mod adds that

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Khalid H.S » Fri Oct 14, 2011 3:11 am

Cheak this file in 1.5.1.3:
catalog\model\catalog\product.php
line 362:

Code: Select all

$query = $this->db->query("SELECT * FROM " . DB_PREFIX . "product_image WHERE product_id = '" . (int)$product_id . "' ORDER BY sort_order ASC");
I'm tested update 1.4.9.5 to 1.5.1.3 and everything good but i can't show the products (error page) because column "sort_order" it's not found in table "product_image".

sory Q i'm not ok with english :/

مصمم ومطور متاجر إلكترونية | @Oc_Style
لطلبات التصميم، تعريب القوالب والاضافات، ترقية الإصدار، حماية المتجر قم بمراسلتي من خلال المنتدى


موديل: إشعارات البنوك السعودية

1 | 2 | O :طرق لحماية السكربت


User avatar
Active Member

Posts

Joined
Fri Dec 10, 2010 9:39 pm
Location - Saudi Arabia

Post by Qphoria » Fri Oct 14, 2011 3:34 am

Khalid H.S wrote:Cheak this file in 1.5.1.3:
catalog\model\catalog\product.php
line 362:

Code: Select all

$query = $this->db->query("SELECT * FROM " . DB_PREFIX . "product_image WHERE product_id = '" . (int)$product_id . "' ORDER BY sort_order ASC");
I'm tested update 1.4.9.5 to 1.5.1.3 and everything good but i can't show the products (error page) because column "sort_order" it's not found in table "product_image".

sory Q i'm not ok with english :/
Well I only write in english.. and I said in the first post it only supports up to 1.5.1.2
You have to run the 1.5.1.3 upgrade after running this script.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by designbuyers » Sun Oct 16, 2011 7:56 am

Got error with MySQL

Code: Select all

OpenCart 1.x Upgrade Script (BETA)
LINE 147: [2] mysql_num_rows(): supplied argument is not a valid MySQL result resource
LINE 147: [2] mysql_num_rows(): supplied argument is not a valid MySQL result resource
LINE 147: [2] mysql_num_rows(): supplied argument is not a valid MySQL result resource
LINE 147: [2] mysql_num_rows(): supplied argument is not a valid MySQL result resource
SUCCESS!!! Click here to goto your store
OpenCart.com
Please help,
thanks and regards,

OpenCart :
The best Open Source Cart for eCommerce


User avatar
Active Member

Posts

Joined
Tue Nov 09, 2010 4:25 pm

Post by mberlant » Sun Oct 16, 2011 3:56 pm

Go back and read the first posting in this thread. Pay close attention to the lines that say that the script works and that errors you may see are false positives.

Then go to your store and confirm that it functions properly. If it does not function properly, you should use the Search button to find a thread that addresses your specific problem or symptom. If you cannot find an existing thread that addresses your specific problem or symptom, you should then create a new thread that clearly describes your environment and your symptoms.

Please use proper English at all times, so that all members may understand you.


User avatar
Active Member

Posts

Joined
Sun Mar 13, 2011 8:33 pm

Post by Qphoria » Sun Oct 16, 2011 11:12 pm

mberlant wrote:Go back and read the first posting in this thread.
That would require reading.. that's no fun

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by number8pie » Wed Oct 19, 2011 9:31 pm

Hi Qphoria,

Firstly thanks for the script, you're a boss on these forums helping us underlings out and generally making out lives easier and less confusing.

Secondly I want to pre-apologize for the possibility that I'm the issue here and give you full permission to be as blunt with me as you need :D

I've followed the instructions in your readme and ran the script, and instead of opencart reverting back to the original theme, its still trying to load my custom theme and producing a few errors which I suspect are my original themes incompatibility with the new version. (this might be a case for the theme thread ;) )

So I went into the admin area to set it to default so I could find out what was causing the errors, but there's something strange going on there too the log in window has cropped itself :o

Here's a URL to the front end:

http://www.corwenforestry.co.uk/opencart/

and heres that strange log in URL

http://www.corwenforestry.co.uk/opencart/admin/

I upgraded from 1.4.9.4 and downloaded 1.5.1.2 and have backed up everything.
I have also replaced the script files on the server with the ones from my PC, and re-ran the script but nothing changed.

If you could help me I'd appreciate it, first things first how can I get the log in section to restore to the original size?

User avatar
New member

Posts

Joined
Tue May 10, 2011 9:35 pm

Post by Qphoria » Wed Oct 19, 2011 9:39 pm

It shows it is trying to load "cfm" theme and it is certainly a 1.4.x theme. You are sure the admin area you are changing is the admin for this store?

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by number8pie » Wed Oct 19, 2011 9:49 pm

Yeah its definitely the admin for the store, its the only one for this company.
The cfm theme is the custom one I've made for this project, hope it doesent take too much tweaking to get it working in 1.5.x

Should I start the process from step 3 again?

[EDIT]
I just got back from my break and hit refresh on the admin area and its back to normal, Q if that was you thanks :D
Now then to finish the readme and look at this theme error.

User avatar
New member

Posts

Joined
Tue May 10, 2011 9:35 pm

Post by hopuphobbies » Tue Oct 25, 2011 3:40 pm

Hi there,

I'm newbie with web designing things.. I'm using 1.4.9.4 right now and planning to upgrade it to 1.5.1.2 (http://forum.opencart.com/viewtopic.php ... &start=160)

I would like to know if i still can use my 1.4.9.4 theme when I'm upgrading it to 1.5.1.2?

Thanks in advance.

Newbie

Posts

Joined
Wed Apr 06, 2011 11:36 am

Post by number8pie » Tue Oct 25, 2011 4:33 pm

hopuphobbies wrote:Hi there,

I'm newbie with web designing things.. I'm using 1.4.9.4 right now and planning to upgrade it to 1.5.1.2 (http://forum.opencart.com/viewtopic.php ... &start=160)

I would like to know if i still can use my 1.4.9.4 theme when I'm upgrading it to 1.5.1.2?

Thanks in advance.
No it didn't work for me because the theme structure has completely changed, so I doubt your theme will work with 1.5.1.2.

If you do want to try it I recommend leaving your existing site alone and installing 1.5.1.2 in a different sub directory as a staging site, and copying your custom theme over to see what happens.

1.5.1.2 chewed my theme up and spat out a few errors, which after fixing I was left with mostly white space on my screen :( I then had to re-install the previous version and everything from a backup I made, wishing I'd tested it in a sub directory first. Learn from my mistake ;)

If you do try it could you please let me know what happens?

Good luck! :)

User avatar
New member

Posts

Joined
Tue May 10, 2011 9:35 pm

Post by hopuphobbies » Tue Oct 25, 2011 5:04 pm

number8pie wrote:
hopuphobbies wrote:Hi there,

I'm newbie with web designing things.. I'm using 1.4.9.4 right now and planning to upgrade it to 1.5.1.2 (http://forum.opencart.com/viewtopic.php ... &start=160)

I would like to know if i still can use my 1.4.9.4 theme when I'm upgrading it to 1.5.1.2?

Thanks in advance.
No it didn't work for me because the theme structure has completely changed, so I doubt your theme will work with 1.5.1.2.

If you do want to try it I recommend leaving your existing site alone and installing 1.5.1.2 in a different sub directory as a staging site, and copying your custom theme over to see what happens.

1.5.1.2 chewed my theme up and spat out a few errors, which after fixing I was left with mostly white space on my screen :( I then had to re-install the previous version and everything from a backup I made, wishing I'd tested it in a sub directory first. Learn from my mistake ;)

If you do try it could you please let me know what happens?

Good luck! :)
Thank you, I will try it out after I'm backing up my files.

Newbie

Posts

Joined
Wed Apr 06, 2011 11:36 am

Post by arturiokas » Wed Oct 26, 2011 12:58 pm

Hi, after an unsuccessful attempt to update the OpenCart framework for restoring the data. When iconecting to admin showing error:

Code: Select all

Error: Unknown column 'o.currency_value' in 'field list'
Error No: 1054
SELECT o.order_id, CONCAT(o.firstname, ' ', o.lastname) AS customer, (SELECT os.name FROM order_status os WHERE os.order_status_id = o.order_status_id AND os.language_id = '2') AS status, o.total, o.currency_code, o.currency_value, o.date_added, o.date_modified FROM `order` o WHERE o.order_status_id > '0' ORDER BY o.date_added DESC LIMIT 0,10

How fix it?
thank you an sorry for my english :)
Last edited by arturiokas on Fri Oct 28, 2011 2:11 pm, edited 1 time in total.

Newbie

Posts

Joined
Sun Aug 07, 2011 12:50 am

Post by Brook » Fri Oct 28, 2011 12:58 am

SkyHigh,

You had posted that you might work on a script to port Product Options from OpenCart v1.4.9.6 to OpenCart 1.5.x...

Any update on your progress from writing a script that will port Product Options from OpenCart v1.4.9.6 to OpenCart v.1.5.x?

Thank you.

Active Member

Posts

Joined
Wed Feb 24, 2010 12:15 am
Who is online

Users browsing this forum: No registered users and 4 guests