Post by Jacob » Sat Jun 18, 2011 11:34 pm

I made a mistake with the upgrade. I ran the upgrade script before completing the steps

Edit:

I tried to continue with the steps but could not login to admin. I will try the whole process again.
Step 5. As there is already an install folder with the new upgrade script uploaded, what of the content is needed from V1.5.0.5?

Any advise?
I looked for the the code that was giving the warning and deleted it. I was then able to get into admin and follow the next rest of the steps ;D

It was line 14 in system/library/cache.php:

Code: Select all

unlink($file);
I tried putting it back after the upgrade was done but it still produced the warnings.

EDIT:

I also had warnings above the admin page:

lines 35 & 36 in system/library/cache.php:

Code: Select all

    	fwrite($handle, serialize($value));
		
    	fclose($handle);
I deleted them and there are no warnings now.

Please advise if what I have done is ok or if not what I should do.
Thanks
:)

Active Member

Posts

Joined
Thu Dec 04, 2008 9:17 pm

Post by MasterG » Sun Jun 19, 2011 5:18 am

Greetings,

I did follow the instructions and I the upgrade from 1.4.9.4 is failing on step 16. This is what I did in prepration:
On my test site, I copied the opencart 1.5.4, then i copied the install folder from this script, then i did all the steps in the .txt file.

I did get warnings on upgrade, but also success. The warning was
mysql_num_rows(): supplied argument is not valid mysql resilt resource in /home/xxx/public_html/t2store/install/upgrade-14xto-15x.no-opt.php on line 77.

I got 4 of those exact warning, under which it said success and go to your store. SEE ATTACHMENT.

I am able to go into admin, and did the step 13, 14 and 15 (made theme default/home and added missing image dimensions as 120x120). But when I go to my site, i get:
Fatal error: Call to a member function isLogged() on a non-object in /home/xxx/public_html/t2store/admin/controller/common/header.php on line 87

the test site is on: http://knob9.com/t2store/

Please advise. Thank you for all that you do.

-G.


UPDATE: I followed the whole process again, except this time I upgraded from a base of 1.4.9.5 and looks like i am making progress. Something to think about....

Featured Module is not working properly.
While trying to add Cart to the main page, when I click edit I get this error: Fatal error: Cannot access private property Document::$title in /home/pahuja/public_html/t2store/admin/controller/module/cart.php on line 8

Attachments

upgrade warning2.jpg

upgrade warning2.jpg (151.22 KiB) Viewed 4449 times

Last edited by MasterG on Sun Jun 19, 2011 7:31 am, edited 3 times in total.

Newbie

Posts

Joined
Sun Jun 19, 2011 5:09 am

Post by Phil » Sun Jun 19, 2011 6:24 am

MasterG wrote:
.........I did get warnings on upgrade, but also success. The warning was
mysql_num_rows(): supplied argument is not valid mysql resilt resource in /home/xxx/public_html/t2store/install/upgrade-14xto-15x.no-opt.php on line 77.

I got 4 of those exact warning, under which it said success and go to your store. SEE ATTACHMENT........
Hi,

I'm also getting the same warning about line 77 (4 times, exactly the same) and have tried the upgrade process a few times now following the instructions to the letter!

I hope this is an easy problem to solve, if not I will just wait for the official upgrade script to be released. :(

New member

Posts

Joined
Fri Feb 18, 2011 6:10 pm


Post by Qphoria » Sun Jun 19, 2011 9:51 pm

kestas wrote: In 1.4.7 was the great function Generate invoice. This is very important.
In version 1.5.x this is missed. Invoice prefix do not printing... why? ???
Invoices are autogenerated in 1.5.x
In 1.4.9 I added auto generation of invoice number based on prefix.
This was added to 1.5.0 but accidentally removed in 1.5.0.3
I thought it was added back in in 1.5.0.4 but haven't checked.
As long as you used the same prefix from 1.4.x, it should keep the next invoice number unless that code is still missing from 1.5.x

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by kestas » Sun Jun 19, 2011 10:48 pm

Qphoria wrote:
kestas wrote: In 1.4.7 was the great function Generate invoice. This is very important.
In version 1.5.x this is missed. Invoice prefix do not printing... why? ???
Invoices are autogenerated in 1.5.x
In 1.4.9 I added auto generation of invoice number based on prefix.
This was added to 1.5.0 but accidentally removed in 1.5.0.3
I thought it was added back in in 1.5.0.4 but haven't checked.
As long as you used the same prefix from 1.4.x, it should keep the next invoice number unless that code is still missing from 1.5.x
Dear Q
I upgraded from1.4.7to1.5.0.5
I have use the same prefix but invoice number start from the first (1). I have try to edit invoice number in Database (through phpmy admin) what I need but nothing... keep going 1,2,3,4,5 ....
Of course I can edit this invoice number through phpmy admin all time... but this is very inconvenient... :( ;)
Second problem I can't use version 1.5.x until I can't generate invoice number manualy.
Why? Some customers canceling the order but want to keep this orders in history. For thoose orders I not need invoice numbers. All invoices must be in sequential order, but not cancelled. So I need generate invoice manualy.
Maybe you can add some setting to choose manualy or automatic generate invoice?

Thank you in advance

Custom OpenCart modules and solutions. You can write PM with additional questions... Extensions you can find here


Active Member

Posts

Joined
Tue Oct 12, 2010 2:23 am

Post by Qphoria » Sun Jun 19, 2011 11:07 pm

kestas wrote: Second problem I can't use version 1.5.x until I can't generate invoice number manualy.
Why? Some customers canceling the order but want to keep this orders in history. For thoose orders I not need invoice numbers. All invoices must be in sequential order, but not cancelled. So I need generate invoice manualy.
Maybe you can add some setting to choose manualy or automatic generate invoice?

Thank you in advance
I'd recommend writing the automatic generation of invoice as a bug in the 1.5.0.5 bug forum so that daniel can see it.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Qphoria » Sun Jun 19, 2011 11:10 pm

MasterG wrote: I did get warnings on upgrade, but also success. The warning was
mysql_num_rows(): supplied argument is not valid mysql resilt resource in /home/xxx/public_html/t2store/install/upgrade-14xto-15x.no-opt.php on line 77.
That's ok.. not really an issue.
But when I go to my site, i get:
Fatal error: Call to a member function isLogged() on a non-object in /home/xxx/public_html/t2store/admin/controller/common/header.php on line 87
This is likely due to an old module that isn't 1.5.x compatible. Uninstall all non-updated 3rd party mods

While trying to add Cart to the main page, when I click edit I get this error: Fatal error: Cannot access private property Document::$title in /home/pahuja/public_html/t2store/admin/controller/module/cart.php on line 8
In 1.5.x, the cart module was removed. I should add this to the step by step. The simple fact is, the cart module was not updated to be 1.5.x compatible so it is non-compatible and should be uninstalled from the extensions->module area. The cart is in the header now so daniel discontinued the cart sidebox module.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by kestas » Sun Jun 19, 2011 11:37 pm

Qphoria wrote:
I'd recommend writing the automatic generation of invoice as a bug in the 1.5.0.5 bug forum so that daniel can see it.


Thank's I'll try...

Custom OpenCart modules and solutions. You can write PM with additional questions... Extensions you can find here


Active Member

Posts

Joined
Tue Oct 12, 2010 2:23 am

Post by MasterG » Mon Jun 20, 2011 1:00 am

Thanks for the feedback!

I can live without the cart module, you are right, that's not an urgency. and I could also play with 3rd party mods (I only have one for abandoned orders) to get it right.

Edited: I got the Featured Module to work, it works differently than how it did in 1.4.9.
I also got links to work for the follow. somehow the https section in config.php did not take my changes.

Thanks Q.

-G.
Last edited by MasterG on Mon Jun 20, 2011 2:12 am, edited 3 times in total.

Newbie

Posts

Joined
Sun Jun 19, 2011 5:09 am

Post by Jacob » Mon Jun 20, 2011 1:28 am

Jacob wrote:
I made a mistake with the upgrade. I ran the upgrade script before completing the steps

Edit:

I tried to continue with the steps but could not login to admin. I will try the whole process again.
Step 5. As there is already an install folder with the new upgrade script uploaded, what of the content is needed from V1.5.0.5?

Any advise?
I looked for the the code that was giving the warning and deleted it. I was then able to get into admin and follow the next rest of the steps ;D

It was line 14 in system/library/cache.php:

Code: Select all

unlink($file);
I tried putting it back after the upgrade was done but it still produced the warnings.

EDIT:

I also had warnings above the admin page:

lines 35 & 36 in system/library/cache.php:

Code: Select all

    	fwrite($handle, serialize($value));
		
    	fclose($handle);
I deleted them and there are no warnings now.

Please advise if what I have done is ok or if not what I should do.
Thanks
:)
Just wondering why there has been no response to my post?

Active Member

Posts

Joined
Thu Dec 04, 2008 9:17 pm

Post by Qphoria » Mon Jun 20, 2011 12:53 pm

Jacob wrote:
Jacob wrote:
I made a mistake with the upgrade. I ran the upgrade script before completing the steps

Edit:

I tried to continue with the steps but could not login to admin. I will try the whole process again.
Step 5. As there is already an install folder with the new upgrade script uploaded, what of the content is needed from V1.5.0.5?

Any advise?
I looked for the the code that was giving the warning and deleted it. I was then able to get into admin and follow the next rest of the steps ;D

It was line 14 in system/library/cache.php:

Code: Select all

unlink($file);
I tried putting it back after the upgrade was done but it still produced the warnings.

EDIT:

I also had warnings above the admin page:

lines 35 & 36 in system/library/cache.php:

Code: Select all

    	fwrite($handle, serialize($value));
		
    	fclose($handle);
I deleted them and there are no warnings now.

Please advise if what I have done is ok or if not what I should do.
Thanks
:)
Just wondering why there has been no response to my post?
Never saw it.. now that i see it.. There is nothing relating to upgrades there so nothing to respond to here. Your errors sounds like simple file permissions on the system/cache folder. Deleting lines of code to get rid of errors is probably the stupidest thing I've heard today.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by ikhlief » Mon Jun 20, 2011 1:42 pm

After the upgrade the Quantity in the Products Purchased Report went wron, the numbers aren't as it was!!!! ???

Active Member

Posts

Joined
Wed Nov 24, 2010 9:15 pm

Post by Jacob » Mon Jun 20, 2011 9:19 pm

Q,
Thanks for your reply

At the bottom of the upgrade script you have written:
This is a beta script and your mileage may vary.
This was tested with a default install so customizations may cause additional problems
I only have a very basic coding level. I ran the upgrade beta upgrade script but am wondering if I should go any further. What options do I have. Should I wait for the completed script, and start the upgrade from scratch with my backed up site? We are only really concerned about our products and categories being saved.

I suppose I could not upload categories/products to phpmyadmin on a fresh install of V1.5?

Thanks again. I hope it is ok to post this here :-\

Active Member

Posts

Joined
Thu Dec 04, 2008 9:17 pm

Post by Qphoria » Mon Jun 20, 2011 9:39 pm

There will not likely be a "full or final script"

The upgrade from 1.4.x to 1.5.x is something that we just need to get through. An upgrade script for 1.5.0 to 1.5.x can be made to be more final, but I really don't want to spend a lot of time on a process that people only need to use once.

I can guarantee the upgrade won't delete your categories, products, customers, etc.. and you always have your backup anyway.

The script works. It looks bad and throws out some strange errors, but it works. There are going to be small quirks that you handle after the upgrade... like the featured products "table" is gone now and has been implemented differently, so you'll have to reconfigure that as if it was a fresh install. There is no way to go from
10:00am - 1.4.x LIVE STORE
10:10am - 1.5.x LIVE STORE

After upgrade you need to basically start your design layouts and module reconfiguration as if you were building a fresh 1.5.x site. The main point of this upgrade script is to ensure your customers, orders, products, etc are carried over so that you don't lose them. But this is a huge upgrade with changes in functionality so it isn't a 10 min process.

The only repeating error shown is:

Code: Select all

mysql_num_rows(): supplied argument is not valid mysql resilt resource in /home/xxx/public_html/t2store/install/upgrade-14xto-15x.no-opt.php on line 77.
and it looks like that is just a false positive based on a line spacing or something and doesn't actually affect the upgrade process. So it is pretty safe to say that if you follow the steps in order, there is a high success rate of upgrade with only minor quirks.

Jacob wrote: I suppose I could not upload categories/products to phpmyadmin on a fresh install of V1.5?
You could, tho some fields have changed and you'd have more trouble than it's worth. The script is designed to alter the tables around your existing data for ease of use.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by deevooneh » Tue Jun 21, 2011 4:01 pm

This is probably a stupid question, but how can I tell what version opencart I have?

I dont have the version number in the footer, but I do have multiple store capabilities. What else can I test for to see what version I have and if this script will work for me.

Newbie

Posts

Joined
Wed Jun 08, 2011 3:34 am

Post by mberlant » Tue Jun 21, 2011 6:07 pm

Look on the bottom of your Admin logon page.

Please use proper English at all times, so that all members may understand you.


User avatar
Active Member

Posts

Joined
Sun Mar 13, 2011 8:33 pm

Post by deevooneh » Tue Jun 21, 2011 6:16 pm

mberlant wrote:Look on the bottom of your Admin logon page.

I dont have the version number in the footer. I think this was added in 1.4.3. I am not sure exactly when multiple stores were added.

Newbie

Posts

Joined
Wed Jun 08, 2011 3:34 am

Post by Qphoria » Tue Jun 21, 2011 9:57 pm

version number was added in 1.4.7 or 1.4.8
Still.. the upgrade script works from 1.4.0 to 1.5.0.x so it doesn't really matter, as long as the admin area is blue and not green.. you have 1.4.x

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Tom52 » Tue Jun 21, 2011 11:46 pm

Hello,

I just want to upload my categories/products from the 1.4.9.5 to 1.5, how can I do that?

Thank you
Tom

v1.5.0.5


New member

Posts

Joined
Thu Oct 07, 2010 7:41 am

Post by deevooneh » Wed Jun 22, 2011 12:17 am

Qphoria wrote:version number was added in 1.4.7 or 1.4.8
Still.. the upgrade script works from 1.4.0 to 1.5.0.x so it doesn't really matter, as long as the admin area is blue and not green.. you have 1.4.x
Oh Perfect mine is blue! Now I just need to wait it out for the options script to be working Q. Thank you for your efforts!

Newbie

Posts

Joined
Wed Jun 08, 2011 3:34 am
Who is online

Users browsing this forum: No registered users and 8 guests