Post by twiggy » Tue Mar 01, 2011 9:07 pm

E-mail system and e-commerce system a whole different ball game. I don't think anyone can answer your question at this stage because the answer really is no one will know. It could all be fine and only a few minor changes/bug fixes will be needed but then again large scale changes might need to be made changing database tables which in your case would cause conflicts. I see your predicament though but I don't think anyway can give you 100% reassurance at this stage :-\

Active Member

Posts

Joined
Fri Aug 14, 2009 4:43 am


Post by Qphoria » Tue Mar 01, 2011 10:17 pm

Well i think he's asking about API continuity throughout the entire major version.

OpenCart has a bad habit of changing major things in between minor versions

Major versions: 1.3.x, 1.4.x, etc
Minor versions: 1.4.1, 1.4.2, 1.4.3, etc

1.3.0 and 1.3.2 were fine, but 1.3.4 changed the the layout system, which broke all mods
1.4.0 was a new theme, but then 1.4.4 removed the url class, changed logger to log, and a bunch of other changes that broke mods.

I had said that our goal was to stop mid-version changes that break backwards compatibility so that most mods for 1.5.0 would work through 1.5.9. This means us developers need to be sure that if we want to add a new design, then we need to allow the old way to properly deprecate for the rest of the version.

For example, If we want to change url.php to href.php at version 1.5.2, then we need to have both url.php and href.php in there until 1.6.0. This may be idealistic but a proper way to handle software management between versions.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by funkyou86 » Tue Mar 01, 2011 11:06 pm

Hey guys.
I'd like to ask, are planing to change the 1.5's SEF urls? Global problem with the previous versions is that they are not supporting multilanguage sef urls.

Thanks for answering. Cheers.

Newbie

Posts

Joined
Tue Mar 01, 2011 11:02 pm

Post by Qphoria » Wed Mar 02, 2011 12:36 am

funkyou86 wrote:Hey guys.
I'd like to ask, are planing to change the 1.5's SEF urls? Global problem with the previous versions is that they are not supporting multilanguage sef urls.

Thanks for answering. Cheers.
This isn't planned for 1.5.0 but perhaps 1.5.1

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by audiomarket » Wed Mar 02, 2011 12:48 am

Qphoria wrote:Well i think he's asking about API continuity throughout the entire major version.

OpenCart has a bad habit of changing major things in between minor versions

Major versions: 1.3.x, 1.4.x, etc
Minor versions: 1.4.1, 1.4.2, 1.4.3, etc

1.3.0 and 1.3.2 were fine, but 1.3.4 changed the the layout system, which broke all mods
1.4.0 was a new theme, but then 1.4.4 removed the url class, changed logger to log, and a bunch of other changes that broke mods.

I had said that our goal was to stop mid-version changes that break backwards compatibility so that most mods for 1.5.0 would work through 1.5.9. This means us developers need to be sure that if we want to add a new design, then we need to allow the old way to properly deprecate for the rest of the version.

For example, If we want to change url.php to href.php at version 1.5.2, then we need to have both url.php and href.php in there until 1.6.0. This may be idealistic but a proper way to handle software management between versions.
I agree.
That's the question that I always paid and that at some point I stopped creating new themes for OpenCart!

I think the engine should be the same for at least six months

Good work

New member

Posts

Joined
Mon Mar 15, 2010 1:55 am

Post by Qphoria » Wed Mar 02, 2011 1:16 am

audiomarket wrote: I agree.
That's the question that I always paid and that at some point I stopped creating new themes for OpenCart!

I think the engine should be the same for at least six months

Good work
I think it should stay for the full major version like all other software scripts do

SMF 2.0.x mods work for 2.0.1, 2.0.2, 2.0.3 etc
Wordpress 2.0.x mods work for 2.0.1, 2.0.2, 2.0.3 etc
and so on

OpenCart just needs to keep the mod and theme makers in mind when we make changes.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by marc_cole » Wed Mar 02, 2011 2:40 am

Will 1.5.0 have the ability to prevent a customer from choosing UPS Next Day Air, 2nd Day Air, etc., if they are within 1 day Ground service from the shipping location?

I posted this question here last week but never got an answer, so I take it that this feature isn't available yet.

OpenCart v1.4.9.4
VQMod | Categories Home | Cleaner By Default - 2 Column | Speak Good English


Active Member

Posts

Joined
Tue Dec 14, 2010 11:26 am
Location - Seattle, WA

Post by Qphoria » Wed Mar 02, 2011 2:47 am

marc_cole wrote:Will 1.5.0 have the ability to prevent a customer from choosing UPS Next Day Air, 2nd Day Air, etc., if they are within 1 day Ground service from the shipping location?

I posted this question here last week but never got an answer, so I take it that this feature isn't available yet.
No, there are no changes to payment/shipping processes for 1.5.0, likely not until 1.6.x

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by marc_cole » Wed Mar 02, 2011 2:51 am

Qphoria wrote:No, there are no changes to payment/shipping processes for 1.5.0, likely not until 1.6.x
Bummer. :-\ If someone could someone post to my other thread how I could accomplish this with 1.4.9.3, I'd really appreciate it.

Thanks,
Marc

OpenCart v1.4.9.4
VQMod | Categories Home | Cleaner By Default - 2 Column | Speak Good English


Active Member

Posts

Joined
Tue Dec 14, 2010 11:26 am
Location - Seattle, WA

Post by funkyou86 » Wed Mar 02, 2011 2:55 am

Qphoria wrote:
funkyou86 wrote:Hey guys.
I'd like to ask, are planing to change the 1.5's SEF urls? Global problem with the previous versions is that they are not supporting multilanguage sef urls.

Thanks for answering. Cheers.
This isn't planned for 1.5.0 but perhaps 1.5.1
Great. Thanks for your reply.

So, honestly, is it worth to install 1.4.9 and migrate my crappy virtuemart to it when 1.5 is comeing soon?!
Thank you,

Alex

Newbie

Posts

Joined
Tue Mar 01, 2011 11:02 pm

Post by Qphoria » Wed Mar 02, 2011 4:22 am

I typically handle the the upgrade script updates. I have not had a chance to play with the latest code yet so I don't know exactly what all the changes for update are. I can tell you that the upgrade from the old individual product options to the new global product options is not going to be easily done and is not an initial priority.

I typically try to do all the db upgrade stuff using only mysql. To do the conversion from individual options to global options would most definitely need to be done with php as I will need a conditional programming language that supports arrays and loops. I've honestly not even tried wrapping my head around it yet.

But from what I can tell, aside from the product options, most of the other stuff is simply adding new tables and columns which is pretty harmless and transparent.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by msmith » Wed Mar 02, 2011 4:32 am

Qphoria wrote:I typically handle the the upgrade script updates. I have not had a chance to play with the latest code yet so I don't know exactly what all the changes for update are. I can tell you that the upgrade from the old individual product options to the new global product options is not going to be easily done and is not an initial priority.

I typically try to do all the db upgrade stuff using only mysql. To do the conversion from individual options to global options would most definitely need to be done with php as I will need a conditional programming language that supports arrays and loops. I've honestly not even tried wrapping my head around it yet.

But from what I can tell, aside from the product options, most of the other stuff is simply adding new tables and columns which is pretty harmless and transparent.
So this means that it's better to wait for 1.5.X ?

Active Member

Posts

Joined
Mon Oct 18, 2010 8:57 pm

Post by funkyou86 » Wed Mar 02, 2011 4:35 am

msmith wrote:
Qphoria wrote:I typically handle the the upgrade script updates. I have not had a chance to play with the latest code yet so I don't know exactly what all the changes for update are. I can tell you that the upgrade from the old individual product options to the new global product options is not going to be easily done and is not an initial priority.

I typically try to do all the db upgrade stuff using only mysql. To do the conversion from individual options to global options would most definitely need to be done with php as I will need a conditional programming language that supports arrays and loops. I've honestly not even tried wrapping my head around it yet.

But from what I can tell, aside from the product options, most of the other stuff is simply adding new tables and columns which is pretty harmless and transparent.
So this means that it's better to wait for 1.5.X ?
Probably yes. Another anoying thing is that we'll have to wait for the 1.5 themes as well :(

Newbie

Posts

Joined
Tue Mar 01, 2011 11:02 pm

Post by msmith » Wed Mar 02, 2011 4:38 am

funkyou86 wrote:
msmith wrote:
Qphoria wrote:I typically handle the the upgrade script updates. I have not had a chance to play with the latest code yet so I don't know exactly what all the changes for update are. I can tell you that the upgrade from the old individual product options to the new global product options is not going to be easily done and is not an initial priority.

I typically try to do all the db upgrade stuff using only mysql. To do the conversion from individual options to global options would most definitely need to be done with php as I will need a conditional programming language that supports arrays and loops. I've honestly not even tried wrapping my head around it yet.

But from what I can tell, aside from the product options, most of the other stuff is simply adding new tables and columns which is pretty harmless and transparent.
So this means that it's better to wait for 1.5.X ?
Probably yes. Another anoying thing is that we'll have to wait for the 1.5 themes as well :(
What I'm worried about is investing time into the first more or less complete 1.5.X version and that some (or all) of my work will not be compatible with future 1.5.X versions...

Active Member

Posts

Joined
Mon Oct 18, 2010 8:57 pm

Post by Xsecrets » Wed Mar 02, 2011 5:56 am

msmith wrote: What I'm worried about is investing time into the first more or less complete 1.5.X version and that some (or all) of my work will not be compatible with future 1.5.X versions...
well if you create your theme's properly only changing the files you absolutely need too and letting the rest fall back (should be easier with 1.5 no inline styles) and you use vqmod to make any changes to the core files upgrades should be fairly painless throughout the 1.5 series.

OpenCart commercial mods and development http://spotonsolutions.net
Layered Navigation
Shipment Tracking
Vehicle Year/Make/Model Filter


Guru Member

Posts

Joined
Sun Oct 25, 2009 3:51 am
Location - FL US

Post by audiomarket » Wed Mar 02, 2011 4:38 pm

Xsecrets wrote:
msmith wrote: What I'm worried about is investing time into the first more or less complete 1.5.X version and that some (or all) of my work will not be compatible with future 1.5.X versions...
well if you create your theme's properly only changing the files you absolutely need too and letting the rest fall back (should be easier with 1.5 no inline styles) and you use vqmod to make any changes to the core files upgrades should be fairly painless throughout the 1.5 series.
That's right, eliminate the line styles. This makes it possible to adapt any kind of theme with each release.
.... is a real shame to work on a new theme that does not work after a month on a later version.
Greating, Marco

New member

Posts

Joined
Mon Mar 15, 2010 1:55 am

Post by audiomarket » Wed Mar 02, 2011 4:42 pm

I believe that a stable engine must be used for a long time to make it possible for developers of themes and mod's to make a profit on their work.

New member

Posts

Joined
Mon Mar 15, 2010 1:55 am

Post by msmith » Wed Mar 02, 2011 6:39 pm

Xsecrets wrote:
msmith wrote: What I'm worried about is investing time into the first more or less complete 1.5.X version and that some (or all) of my work will not be compatible with future 1.5.X versions...
well if you create your theme's properly only changing the files you absolutely need too and letting the rest fall back (should be easier with 1.5 no inline styles) and you use vqmod to make any changes to the core files upgrades should be fairly painless throughout the 1.5 series.
And the data contained inside the DB?

Active Member

Posts

Joined
Mon Oct 18, 2010 8:57 pm

Post by Qphoria » Wed Mar 02, 2011 9:08 pm

msmith wrote:
Xsecrets wrote:
msmith wrote: What I'm worried about is investing time into the first more or less complete 1.5.X version and that some (or all) of my work will not be compatible with future 1.5.X versions...
well if you create your theme's properly only changing the files you absolutely need too and letting the rest fall back (should be easier with 1.5 no inline styles) and you use vqmod to make any changes to the core files upgrades should be fairly painless throughout the 1.5 series.
And the data contained inside the DB?
DB content doesn't get overridden with upgrades tho

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Daniel » Thu Mar 03, 2011 2:20 am

one of the chanegs to the templates is that all the inline styles are gone. all css changes are done with stylesheets. also io have used a better nming convention. instead if div1 there are names like product-info and category-list, etc..

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm
Who is online

Users browsing this forum: No registered users and 8 guests