Post by OSWorX » Sun Jan 16, 2022 2:00 pm

More and more user are reporting troubles and problems after an update made automatically by Installatron.
This tool is used at some providers (e.g. GoDaddy).

If OpenCart was installed by it, an update is maded automatically (somewhere).
But OpenCart - especially when modified - will not work afterwards as expected!
That update can lead to a suddenly stopped webshop.


See for example:
viewtopic.php?f=199&t=226982&p=835622#p835622
viewtopic.php?f=202&t=226962&p=835524#p835524
viewtopic.php?f=202&t=226958&p=835493#p835493

How can this be avoided?
1. Never (!!) use Installatron to install OpenCart
2. Use always the official page to download the desired version: https://www.opencart.com/index.php?rout ... ad/history
3. Install OpenCart manual, howto see (e.g.): https://www.opencart.com/blog/how-to-in ... -beginners

Can I update my OpenCart webshop?
Of course - at any time (if you know how).
But beware, updating means also to check BEFORE if the installed extensions and addons are compatible with the new version.
Also if the used theme (if not the default) is also compatible.

Updates within a branch (e.g. 1.5.x, 2.x or 3.x) will almost work (e.g. using the integrated updater) - IF NOT MODIFIED!
Updates from one branch to a higher (1.5.x > 2.x or 3.x | 2.x > 3.x) will not work without manual editing - especially if you have additional extensions installed, and/or using a custom theme and/or have modifications!
Of course you can spend a lot of money for such a service, but not needed - all what they do you are able to do by yourself.

Again: DO NOT USE INSTALLATRON!

This tool to install and update looks good and easy, but at the end it is NOT!

Full Stack Web Developer :: Dedicated OpenCart Development & Support DACH Region
Contact for Custom Work / Fast Support.


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by cjfranca » Wed Jan 19, 2022 9:20 pm

Great recomandations, But this problem show in all host with automatic upgrade.
I never enable thi soption.
Yesterday I have a problem with a autentication ´s module becouse php version was 8.0. Not recomend. Better user 7.4

New member

Posts

Joined
Tue Jun 30, 2020 5:05 am
Location - São Paulo- BR

Post by StormDesigner » Tue Jan 25, 2022 10:14 pm

I definitely experienced this after Installatron ran a sub version update to 3.0.8. I was able to use Installatrons backup to revert it to 3.0.6 which appeared to solve the problem and the site ran again. My followup question then is whether the failure to run properly was simply that installatron ran the update and how IT does so or is there something not compatible with the update and my stack?
After reversing to a saved backup I'm now seeing some odd (scary) issues where updating products is failing in two peculiar ways
1.) The page displaying after the update is producing informatted error codes, not a page.
2.) The product updates but it truncates options to only 4 options on some items which should have as many as 8 or 9 + option selectors. That isn't going to work at all. Is that also from Installatron or perhaps some other aspect of the update?

StormDesigns, Inc. Website Design and Web Application Development - plus graphic design and print media.

www.StormDesigns.com


User avatar
New member

Posts

Joined
Wed Feb 01, 2012 1:53 am


Post by OSWorX » Tue Jan 25, 2022 11:18 pm

One week ago (17th January) one person contacted me.
Told me, that he is one of the founders.

One statement was this:
To stop this behavior, we\'ve immediately updated our OpenCart package to block the Installatron update process with a warning that prompts the customer to verify compatibility of installed themes, extensions, and custom edits. In these cases, we strongly recommend a manual update.
I answered him in very long email - since then .. nothing.
Wondering how serious they really take this issues?!

Generally, it does not make sense to offer a "update" for OpenCart - the more if it is done in an "automatic" way.
Nearly every OpenCart instance is modified, either by extensions or "hard coded" (the latter should be avoided in every circumstances!).
Even an update from 3.0.3.7 to 3.0.3.8 will make troubles this way, the more an update from e.g. 3.0.2.x to 3.0.3.x

As long as OpenCart's core is not build the same way like Joomla (for example), updates make really absolutely no sense.
Or the update checks prior for modified files and summarize them - then the store owner can decide by himself if he wants to continue (and live with the result).

Full Stack Web Developer :: Dedicated OpenCart Development & Support DACH Region
Contact for Custom Work / Fast Support.


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by StormDesigner » Wed Jan 26, 2022 6:58 am

Disabling Updates?

Would it be ok though to use it to install the cart and write backups but disable the automated updates and also don't run any updates through installatron (unless this bad behavior can be addressed) I'm a little spoiled to how installatron can simplify and create UI's for technical services. I have a couple of OC's using it that seem fine, other than update related behavior, which brings me to another thing but should probably be a separate thread.

Is the issue isolated to running updates through Installatron or does even the initial install perhaps corrupt the installation?

StormDesigns, Inc. Website Design and Web Application Development - plus graphic design and print media.

www.StormDesigns.com


User avatar
New member

Posts

Joined
Wed Feb 01, 2012 1:53 am


Post by OSWorX » Wed Jan 26, 2022 10:18 pm

StormDesigner wrote:
Wed Jan 26, 2022 6:58 am
Disabling Updates?
While I never use third party scripts to install anything, when there is a possibility to disable updates, then yes.

StormDesigner wrote:
Wed Jan 26, 2022 6:58 am
Would it be ok though to use it to install the cart and write backups but disable the automated updates and also don't run any updates through installatron (unless this bad behavior can be addressed) ..
As said before, installing OpenCart (or any other system) the "normal" way, is always better.
What is the normal way?
As example OpenCart:
1. get the package from here: https://www.opencart.com/index.php?route=cms/download
2. follow the install instructions, e.g. this here: http://docs.opencart.com/en-gb/installation/
StormDesigner wrote:
Wed Jan 26, 2022 6:58 am
Is the issue isolated to running updates through Installatron or does even the initial install perhaps corrupt the installation?
The person who contacted me (and told me to be one of the co-founders) wrote, that they have already or will change their procedere to check (or at least highlight) for modifications.
Don't know if they have done that.

The only change I can see, is on their website:
WARNING: Incompatible OpenCart themes, modifications, and/or extensions will result in a broken website. If this website uses any themes, modifications, or extensions, it's very important to get confirmation each are compatible with the new OpeCart version prior to proceeding. Following the manual upgrade procedure outlined in the OpenCart documentation at http://docs.opencart.com/ is recommended in these cases, and creating a backup prior to attempting any upgrade is always recommended.
But how many are reading this .. ?!

Full Stack Web Developer :: Dedicated OpenCart Development & Support DACH Region
Contact for Custom Work / Fast Support.


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by StormDesigner » Thu Jan 27, 2022 2:34 am

Thank you OSWorx. Prior to using Installatron I did all manual installs and was familiar with and capable of doing so. I love that Installatron has a nice method for creating scheduled backups in case of something going wrong. When set up correctly it backs up 1x per month and 1x per week. So if there was ever a reason to revert I can go back to last week or a month back if the issue started before last week. I may have to see what options are available on cpanel to handle backup scheduling. If you have any suggestions on that feel free to share of course. - thank you.

StormDesigns, Inc. Website Design and Web Application Development - plus graphic design and print media.

www.StormDesigns.com


User avatar
New member

Posts

Joined
Wed Feb 01, 2012 1:53 am


Post by OSWorX » Thu Jan 27, 2022 4:38 am

StormDesigner wrote:
Thu Jan 27, 2022 2:34 am
I love that Installatron has a nice method for creating scheduled backups in case of something going wrong.
Every provider/hoster should offer backups.
The user can define how often they are made - the "problem" with backups are, that they are always a "snapshot" only at the time of creating.
If not, change your provider - as soon as possible!

Which means, a full backup (which makes sense and should be done regular!) will contain "old" data only.
While this may not so important with the files, the database tables contain only old data!
Which means, importing such an update means also, loosing data (the data between the import and the time the backup was made).

And it means, modifications - made due some reasons - are lost (have to be made again).

Making regular backups is always a very important task for webshop owners!
How many of you are doing them?

But to concluse: having an account which offers backups does not need installatron.
Not that I'm against them, but the way it is done currently, is not the way it should be done!

Full Stack Web Developer :: Dedicated OpenCart Development & Support DACH Region
Contact for Custom Work / Fast Support.


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by Marianne7 » Tue Apr 05, 2022 8:00 pm

I am getting alot of undefined text and even when i save something i get the dialog box with undefined all the time. I have read alot of posts but as a novice not sure if i understand them. I have used the 1 click install in godaddy for installation so i am guessing this has done this correctly.
MyFamilyMobile
Last edited by Marianne7 on Thu Apr 21, 2022 1:27 pm, edited 1 time in total.

Newbie

Posts

Joined
Mon Apr 04, 2022 5:41 pm

Post by JNeuhoff » Wed Apr 20, 2022 6:11 pm

Don't use GoDaddy if you are serious about running an ecommerce site. And don't use Installatron.

Use the current stable version 3.0.3.8 from https://www.opencart.com/index.php?route=cms/download and follow its installation instructions.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Guru Member

Posts

Joined
Wed Dec 05, 2007 3:38 am

Who is online

Users browsing this forum: No registered users and 17 guests