Post by Qphoria » Tue Aug 31, 2010 8:00 pm

Topher wrote: I have two accounts attached to paypal, one is my private address the other is the business one. I have made my account a business account. On the Paypal page I typed in the business email address,which has been attached to paypal.

Could that be the reason it is appearing?
So your receiver_email shows up different than your business.. That's a strange one. You have 2 email accounts listed on your paypal account?
I used my parents paypal account to run a mock test, since people had said that the sandbox version doesn't really work that well.
Sandbox should be all fixed now, but testing with a live account is easier anyway.

The email is from opencart when you set debug to "Yes". There is nothing to bother your host with.

Based on the information, I see what the issue is. Your business is showing up different than the receiver_email. Another moronic paypal "feature" I assume.

So when you removed the emails in the debug email you pasted, I assume "receiver_email" was your "personal" email
and business was your "business" email? and that is the same email you have set in your paypal account?

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Topher » Tue Aug 31, 2010 8:28 pm

Qphoria wrote: So your receiver_email shows up different than your business.. That's a strange one. You have 2 email accounts listed on your paypal account?
I used my parents paypal account to run a mock test, since people had said that the sandbox version doesn't really work that well.
Sandbox should be all fixed now, but testing with a live account is easier anyway.

The email is from opencart when you set debug to "Yes". There is nothing to bother your host with.

Based on the information, I see what the issue is. Your business is showing up different than the receiver_email. Another moronic paypal "feature" I assume.

So when you removed the emails in the debug email you pasted, I assume "receiver_email" was your "personal" email
and business was your "business" email? and that is the same email you have set in your paypal account?
yes I do, I originally signed up with a personal email account at gmail. I was using this for about a year. I started a business (just a private sole trader one) and rather then signing up with a new account, I just attached another email account to the paypal account. The personal one is still the default.
Yes I removed both the email but left a reference, so yeah they are two different email addresses.

I looked in the payment modules, under paypal. I looked at this setting
Debug Mode:Logs additional information to the system log.
It was set to disabled, I switched it to see if it will make any difference. Is this the setting you were talking about, or is it another setting in opencart that I am missing, that talks about debug?

Thanks for your help :)

Newbie

Posts

Joined
Sun Aug 29, 2010 7:14 pm
Location - brisbane, Australia

Post by Qphoria » Thu Sep 02, 2010 12:11 am

Ok i've updated the attached file with the fix mentioned here:
http://forum.opencart.com/viewtopic.php?p=95595#p95595

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Topher » Thu Sep 02, 2010 7:32 pm

Qphoria wrote:Ok i've updated the attached file with the fix mentioned here:
http://forum.opencart.com/viewtopic.php?p=95595#p95595
Thank you very much :) I really appreciate it :D I will apply the update in a couple of hours.

Newbie

Posts

Joined
Sun Aug 29, 2010 7:14 pm
Location - brisbane, Australia

Post by Topher » Sat Sep 04, 2010 8:08 pm

Qphoria wrote:Ok i've updated the attached file with the fix mentioned here:
http://forum.opencart.com/viewtopic.php?p=95595#p95595
I am still getting the error, it is possible that the reason is because the case doesn't match like someone said in that post.

Could that have anything to do with it?

Thanks in advanced for your help.

Newbie

Posts

Joined
Sun Aug 29, 2010 7:14 pm
Location - brisbane, Australia

Post by Qphoria » Thu Sep 09, 2010 3:22 am

updated with the fixes from the version in 1.4.9.1

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by superdooper » Mon Sep 13, 2010 9:12 pm

Any ideas why i am getting this?

Code: Select all

2010-09-07 8:13:07 - PP_STANDARD :: VALIDATION FAILED : PP_Standard - Possible Scam: IPN Price "" does not match OpenCart Total "8.9700". Order needs manual verification
2010-09-07 8:13:08 - PP_STANDARD :: VALIDATION FAILED : PP_Standard - Possible Scam: IPN Price "" does not match OpenCart Total "8.9700". Order needs manual verification

Newbie

Posts

Joined
Wed Aug 04, 2010 3:51 am

Post by Qphoria » Mon Sep 13, 2010 10:41 pm

superdooper wrote:Any ideas why i am getting this?

Code: Select all

2010-09-07 8:13:07 - PP_STANDARD :: VALIDATION FAILED : PP_Standard - Possible Scam: IPN Price "" does not match OpenCart Total "8.9700". Order needs manual verification
2010-09-07 8:13:08 - PP_STANDARD :: VALIDATION FAILED : PP_Standard - Possible Scam: IPN Price "" does not match OpenCart Total "8.9700". Order needs manual verification
IPN may not be returning to you. Enable debug and see what the IPN response is

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by greymatters » Fri Sep 17, 2010 8:55 pm

Hi Q

Earlier i downloaded "new_pp_standard_149RC4.zip" and it was working fine with 1.4.8b

When i tried coupon and used PayPal it add huge amount as shipping but not deducting the coupon discount so i came here to download the updates.

I cant see any link here and at your site, please show me the latest download link.

Thanks in Advance.

Image
( support@hostingmatters.in )


User avatar
New member

Posts

Joined
Mon Nov 16, 2009 12:28 am


Post by Qphoria » Fri Sep 17, 2010 9:31 pm

First post has link and has the fix for the issue you are describing

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by greymatters » Fri Sep 17, 2010 11:04 pm

Thanks Q,

Sorry i missed the link earlier.

Downloaded the files and replaced 7files at store v1.4.8b, the following error shown by PayPal...

"Unable to process payment. Please contact the merchant as the postal address provided by the merchant is invalid, and the merchant has requested that your order must be delivered to that address."

Image
( support@hostingmatters.in )


User avatar
New member

Posts

Joined
Mon Nov 16, 2009 12:28 am


Post by Qphoria » Sat Sep 18, 2010 1:49 am

Can I see a link?
This error is likely due to your custom theme for an earlier version has the old pp_standard.tpl in it. Delete that file from the custom theme and let it fallback to the default one

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by greymatters » Sat Sep 18, 2010 5:11 pm

Ya sure Q... check it at www.freecart.in

I am using the default theme, your earlier PayPal standard 1.4.9RC files was working fine if used without coupon.

Its my demo store, i can give the admin ID Password if you required.

Thanks for your help.

Image
( support@hostingmatters.in )


User avatar
New member

Posts

Joined
Mon Nov 16, 2009 12:28 am


Post by Qphoria » Sat Sep 18, 2010 10:44 pm

OK.. the error is due to the new address_override field that I added. That tells paypal to disallow changing the shipping address from within the paypal checkout process. Paypal does an address verification on the address. If the address that was typed in during the registration process is fake or invalid, it throws that error.

It is an unfortunately stupid error and paypal should have done better and been more clearer. The only fix is to always be sure the address is valid or remove the address_override line from the catalog/controller/payment/pp_standard.php file

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by speedingorange » Mon Sep 27, 2010 5:56 am

just got this error message as an email through from my cart.

( did not have PDT set up as I did not realise when i upgraded to 1.9 that there was a new paypal module included)

The order that it was placed with was set to cancelled in the cart, but the customer had not pulled the payment.

Code: Select all

error_verify

DEBUG POST VARS::invoice=2062 - ***CUSTOMER NAME*** CUSTOMER PRODUCT DETAILS***

***CUSTOMER DELIVERY DETAILS****

DEBUG GET VARS::route=payment/pp_standard/callback&

I have since set up the paypal account fully inc PDT, should this fix this problem? this is the only order in the last week since upgrading that this has occurred on.

Active Member

Posts

Joined
Tue Feb 23, 2010 7:33 pm

Post by starofriches » Thu Oct 14, 2010 7:39 am

Apologies if this is a very basic question but I can't seem to find a clear answer on the forum. I'm trying to set up my Paypal Standard module and I don't know what I should enter in the "Return URL" field at Paypal in order to receive PDT token.

Can someone please give me guidance on this? Do I need to generate a page in OpenCart or is there a URL that I should be using?

Thanks very much for any info on this or for pointing me in the right direction!

Newbie

Posts

Joined
Sat Aug 07, 2010 10:10 pm

Post by greymatters » Tue Oct 26, 2010 9:57 pm

Qphoria wrote:OK.. the error is due to the new address_override field that I added. That tells paypal to disallow changing the shipping address from within the paypal checkout process. Paypal does an address verification on the address. If the address that was typed in during the registration process is fake or invalid, it throws that error.

It is an unfortunately stupid error and paypal should have done better and been more clearer. The only fix is to always be sure the address is valid or remove the address_override line from the catalog/controller/payment/pp_standard.php file
Thanks Q for the solution, sorry for the late reply.

Image
( support@hostingmatters.in )


User avatar
New member

Posts

Joined
Mon Nov 16, 2009 12:28 am


Post by chirameto » Sun Nov 07, 2010 1:59 am

I couldn't identify customer choice of shipping method in Paypal.

How can i make "shipping method" to show in Paypal (in postage detail section)?

Thanks!

Newbie

Posts

Joined
Thu Jun 24, 2010 12:00 pm

User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Qphoria » Thu Nov 11, 2010 12:09 am

I've updated the first post with a new version. Due to issues here:
http://forum.opencart.com/viewtopic.php ... 57#p111173

This is the latest version of the code and is newer than the v1.4.9.2 version, so all 1.4.8.x and 1.4.9.x users should get this version.

2 files changed:
catalog/controller/payment/pp_standard.php
catalog/language/english/payment/pp_standard.php


Changes:
- If the discount is greater than or equal to the item-only subtotal, paypal will not accept the discount field. To trick paypal, the tax and shipping get passed in as line items when the discount is greater than the subtotal. It uses the normal tax and shipping fields if there is no discount or it is less than the subtotal.
- added text_tax to the pp_standard langauge file so that it can be passed in as the name in the correct language when the discount is greater than the subtotal.
- I also fixed a bug with the discount amount to proper convert to the correct currency when checking out with a non-default currency.

This is how it looks when the discount is greater than the subtotal now:
http://screencast.com/t/dm1DRtfGfU1

This is how it looks normally:
http://screencast.com/t/CGahCrsXP

Post here if there are any problems

Q

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am
Who is online

Users browsing this forum: No registered users and 14 guests