Post by JNeuhoff » Fri May 26, 2017 6:06 pm

bull5-i wrote:
Sun May 07, 2017 3:00 pm
A proper interface would be greatly appreciated here, because some Twig extensions would only be required on certain pages and not all of them.
Regardless of what interface you use, whether it is a class extension, event handler, or whatever plugin mechanism you use, you eventually reach a point where 3rd party extensions still may want to modify the template file, causing potential clashes with each other.

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by ADD Creative » Fri May 26, 2017 7:38 pm

santolla wrote:
Fri May 26, 2017 4:15 pm
I can't get it to install on my local server, I can install on my web server but won't let me log in. The username/password is correct. I've manually changed them i the database 100 times.

Front end I get this error:
Warning: fopen(/sess_426311d16eae73db2ed951d8f1): failed to open stream: Permission denied in /home/eshopa6/public_html/_opencart/3.0/system/library/session.php on line 47Warning: flock() expects parameter 1 to be resource, boolean given in /home/eshopa6/public_html/_opencart/3.0/system/library/session.php on line 49Warning: fwrite() expects parameter 1 to be resource, boolean given in /home/eshopa6/public_html/_opencart/3.0/system/library/session.php on line 51Warning: fflush() expects parameter 1 to be resource, boolean given in /home/eshopa6/public_html/_opencart/3.0/system/library/session.php on line 53Warning: flock() expects parameter 1 to be resource, boolean given in /home/eshopa6/public_html/_opencart/3.0/system/library/session.php on line 55Warning: fclose() expects parameter 1 to be resource, boolean given in /home/eshopa6/public_html/_opencart/3.0/system/library/session.php on line 57

sessions.php doesn't exist.
It could be the session.save-path is not setup correctly in your php.ini or there is a permissions issue. You may need to ask your host.

http://php.net/manual/en/session.config ... .save-path

ADD Creative - Web development and e-commerce development, Milton Keynes or Christchurch, UK
ADD Filtration - HVAC Panel Filters, Bag Filters and HEPA Filters


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am

Post by oc_ms » Sat Jun 10, 2017 3:35 am

Hello!

I have successfully installed version 3.0.0.0 for testing. But when installing an extension within the "Extension Installer" I get the error "The directory system/library is not allowed to be written to!". But the permissions for this directory are set to "777".

I can see the temporary files in the temp upload directory. They are set to "750".

Does anyone has an idea what to do? Thanks in advance!

Best regards,

Holger

Newbie

Posts

Joined
Thu Jun 05, 2014 3:25 am

Post by JNeuhoff » Sat Jun 10, 2017 3:55 am

Does anyone has an idea what to do? Thanks in advance!
Most likely the extension has not yet been upgraded for OpenCart 3.0.0.0

An OpenCart 3.x extension can now only add its files to the following folders:

'admin/controller/extension/',
'admin/language/',
'admin/model/extension/',
'admin/view/image/',
'admin/view/javascript/',
'admin/view/stylesheet/',
'admin/view/template/extension/',
'catalog/controller/extension/',
'catalog/language/',
'catalog/model/extension/',
'catalog/view/javascript/',
'catalog/view/theme/',
'system/config/',
'system/library/',
'image/catalog/'

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by oc_ms » Sat Jun 10, 2017 4:59 am

JNeuhoff wrote:
Sat Jun 10, 2017 3:55 am
Does anyone has an idea what to do? Thanks in advance!
Most likely the extension has not yet been upgraded for OpenCart 3.0.0.0

An OpenCart 3.x extension can now only add its files to the following folders:

'admin/controller/extension/',
'admin/language/',
'admin/model/extension/',
'admin/view/image/',
'admin/view/javascript/',
'admin/view/stylesheet/',
'admin/view/template/extension/',
'catalog/controller/extension/',
'catalog/language/',
'catalog/model/extension/',
'catalog/view/javascript/',
'catalog/view/theme/',
'system/config/',
'system/library/',
'image/catalog/'
Dear JNeuhoff!

Thank you for _your_ reply! I did not wrote which extension I would like to add, but the right one answered! ;-)

The extension I would like add is "opencart-3-x-export-import-multilingual-3-12.ocmod.zip" ... So this shouldn't be a problem.

Any more ideas?

Best regards,

Holger

Newbie

Posts

Joined
Thu Jun 05, 2014 3:25 am

Post by JNeuhoff » Sun Jun 11, 2017 7:03 am

oc_ms wrote:
Sat Jun 10, 2017 4:59 am
Dear JNeuhoff!

Thank you for _your_ reply! I did not wrote which extension I would like to add, but the right one answered! ;-)

The extension I would like add is "opencart-3-x-export-import-multilingual-3-12.ocmod.zip" ... So this shouldn't be a problem.

Any more ideas?

Best regards,

Holger
Please be aware that OpenCart 3.0.0.0 has not yet been officially released, it is still a beta-release, hence doing extensions for this version is like chasing after a moving goal post. Anyway, I adjusted the Export/Import tool to today's 3.0.0.0-beta, it works at the moment.

MHC Web Design
Override Engine * Integrated VQMod * Multilingual SEO * Instant Option Price Calculator * TrustPilot Reviews * Download Options * Free Download Buttons * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by Hackej » Wed Jun 14, 2017 12:21 am

Hi!

The Export/Import tool seems to work now for 3.0 Beta (at the moment).
Some other things that I do not get to work is:

- Cannot install ...ocmod-xml files only ....ocmod.zip files seems to work in Extension Installer (maybe intentionally?).
I get error message:
o PHP Warning: ZipArchive::extractTo(): Invalid or uninitialized Zip object in ....\admin\controller\marketplace\install.php on line 100
o 2017-06-10 17:24:22 - PHP Warning: ZipArchive::close(): Invalid or uninitialized Zip object in ....\admin\controller\marketplace\install.php on line 101

- Some installed zip-file modifications not visible in Modifications although Success message in Installer

- Cannot remove installed extension (in Extension installer/Installed) - get success message but extension is still listed

- Cannot remove edited language rows from Language Editor - no message and edits still listed

BR
/Hackej

New member

Posts

Joined
Fri May 27, 2011 1:47 pm

User avatar
Guru Member

Posts

Joined
Wed Nov 16, 2011 11:53 am
Location - Singapore
Who is online

Users browsing this forum: No registered users and 8 guests