Post by crosland » Fri Sep 13, 2019 9:13 pm

I am fairly new to OC but I did get a working installation on my web hosts server.
Then I decided to work locally on a new shop.
I dropped the server database and deleted all of the OC files.
I then exported the DB form localhost and imported on the server.
Then I copied the OC files from localhost to the server, correcting the paths in config.php.
The shop pages on the server do not display correctly. I can see the "maintenance" mesaage but it looks like all of the styling is missing. All that is displayed is raw text.
Additionally, I cannot login to the admin page.
What am I missing?
Do I need to do an install from scratch of OC on the server and then merge my changes?

New member

Posts

Joined
Fri Sep 13, 2019 9:04 pm

Post by xxvirusxx » Sat Sep 14, 2019 3:16 pm

Post your config's file content without database name, password, username

And provide you store URL.

Active Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - RO

Post by kestas » Sat Sep 14, 2019 3:57 pm

crosland wrote:
Fri Sep 13, 2019 9:13 pm
I am fairly new to OC but I did get a working installation on my web hosts server.
Then I decided to work locally on a new shop.
I dropped the server database and deleted all of the OC files.
I then exported the DB form localhost and imported on the server.
Then I copied the OC files from localhost to the server, correcting the paths in config.php.
The shop pages on the server do not display correctly. I can see the "maintenance" mesaage but it looks like all of the styling is missing. All that is displayed is raw text.
Additionally, I cannot login to the admin page.
What am I missing?
Do I need to do an install from scratch of OC on the server and then merge my changes?
You must correctly edit config.php and admin/config.php . And if your instalation not in the root, you must edit also .htaccess. So yes, if your do not know how to edit this files you can install on the server from scratch your version of OC and copy just new created config.php and admin/config.php files. Do not forget the database, the new installed on the server you must delete and upload DB from your localhost.

Custom OpenCart modules and solutions. You can write PM with additional questions... Extensions you can find here


Active Member

Posts

Joined
Tue Oct 12, 2010 2:23 am

Post by crosland » Sun Sep 15, 2019 5:16 pm

Thanks for the suggestions. I had a "light-bulb" moment and managed to fix it myself :)

Since last playing with a live site I have enabled ssl on my website. I had to fix this in the OC config files and it's now all working as expected.

New member

Posts

Joined
Fri Sep 13, 2019 9:04 pm
Who is online

Users browsing this forum: No registered users and 14 guests