Page 1 of 1

Upgrade Erros

Posted: Tue Jan 15, 2019 12:38 am
by KazDesigns
Hi

HELP! I have just upgraded to the latest version of OpenCart and get a ton of errors. Below are just a few of them, but they all seem to relate to the storage directory

Can anyone help me fix this? I'm not sure what went wrong. I uploaded the new files via FTP (excluding the config files) and then ran the upgrade installer. It was already running OpenCart 3.x installed last year.

2019-01-14 16:03:37 - PHP Warning: Missing argument 3 for Template\Twig::render(), called in /home/*/public_html/www.*.com/system/library/template.php on line 51 and defined in /home/*/public_html/storage/*/modification/system/library/template/twig.php on line 18
2019-01-14 16:03:37 - PHP Notice: Undefined variable: template_name in /home/*/public_html/storage/*/modification/system/library/template/twig.php on line 21
2019-01-14 16:03:37 - PHP Warning: Missing argument 3 for Template\Twig::render(), called in /home/*/public_html/www.*.com/system/library/template.php on line 51 and defined in /home/*/public_html/storage/*/modification/system/library/template/twig.php on line 18
2019-01-14 16:03:37 - PHP Notice: Undefined variable: template_name in /home/*/public_html/storage/*/modification/system/library/template/twig.php on line 21
2019-01-14 16:03:37 - PHP Warning: Missing argument 3 for Template\Twig::render(), called in /home/*/public_html/www.*.com/system/library/template.php on line 51 and defined in /home/*/public_html/storage/*/modification/system/library/template/twig.php on line 18
2019-01-14 16:03:37 - PHP Notice: Undefined variable: template_name in /home/*/public_html/storage/*/modification/system/library/template/twig.php on line 21
2019-01-14 16:03:37 - PHP Warning: Missing argument 3 for Template\Twig::render(), called in /home/*/public_html/www.*.com/system/library/template.php on line 51 and defined in /home/*/public_html/storage/*/modification/system/library/template/twig.php on line 18

Re: Upgrade Erros

Posted: Tue Jan 15, 2019 6:43 pm
by straightlight
Restore backups. Then, create a new service request in the Commercial Support section of the forum to get this done as a custom job.