Post by chrisgwynne » Wed May 23, 2018 10:51 pm

Hi

I've just upgraded from 2.3.0.2 to the latest release of OC3. I've enabled SEO urls in Settings and the following is my .htaccess file however I can't get SEO urls to turn on...

Code: Select all

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled.

# 2. In your opencart directory rename htaccess.txt to .htaccess.

# For any support issues please visit: http://www.opencart.com

Options +SymLinksIfOwnerMatch

# Prevent Directoy listing
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "(?i)((\.tpl|.twig|\.ini|\.log|(?<!robots)\.txt))">
 Require all denied
## For apache 2.2 and older, replace "Require all denied" with these two lines :
# Order deny,allow
# Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On

# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/
RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=extension/feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=extension/feed/google_base [L]
RewriteRule ^system/storage/(.*) index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

### Additional Settings that may need to be enabled for some servers
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.

# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
# php_flag register_globals off

# 2. If your cart has magic quotes enabled, This may work to disable it:
# php_flag magic_quotes_gpc Off

# 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
# php_value upload_max_filesize 999M

# 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value post_max_size 999M

# 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_execution_time 200

# 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_input_time 200

# 7. disable open_basedir limitations
# php_admin_value open_basedir none
Is there something else in OC3 I need to do to enable this?

Thanks,

New member

Posts

Joined
Fri Nov 11, 2016 7:33 am

Post by Qphoria » Wed May 23, 2018 11:22 pm

Yes. In the system settings on the Server tab.. you have to set "Use SEO Urls" to YES

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by chrisgwynne » Thu May 24, 2018 6:51 pm

Qphoria wrote:
Wed May 23, 2018 11:22 pm
Yes. In the system settings on the Server tab.. you have to set "Use SEO Urls" to YES
This has been done already. :(

New member

Posts

Joined
Fri Nov 11, 2016 7:33 am

Post by Qphoria » Fri May 25, 2018 4:15 am

You also need to update your config.php and admin/config.php files for the HTTPS_SERVER and HTTPS_CATALOG settings to have the "https://"

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by graze » Tue Jul 31, 2018 11:16 pm

Did you ever get this fixed if so how?

New member

Posts

Joined
Wed Jun 24, 2015 5:28 pm
Who is online

Users browsing this forum: No registered users and 2 guests