Post by EV-soft » Wed Jan 17, 2018 3:41 am

Installation conditions: PHP version 7.0x
When I get to Step 3, I get the following messages:

Warning: mysqli::__construct() [mysqli.construct]: (HY000/2002): Connection refused in /var/www/xxx.com/public_html/OpenCart/system/library/db/mysqli.php on line 7
Warning: DB\MySQLi::__construct() [db\mysqli.construct]: Couldn't fetch mysqli in /var/www/xxx.com/public_html/OpenCart/system/library/db/mysqli.php on line 10
Warning: DB\MySQLi::__construct() [db\mysqli.construct]: Couldn't fetch mysqli in /var/www/xxx.com/public_html/OpenCart/system/library/db/mysqli.php on line 10
Notice: Undefined variable: mysql in /var/www/xxx.com/public_html/OpenCart/install/controller/install/step_3.php on line 280
Notice: Trying to get property of non-object in /var/www/xxx.com/public_html/OpenCart/install/controller/install/step_3.php on line 280

What can my problem be like?

Newbie

Posts

Joined
Wed Jan 17, 2018 3:02 am

Post by straightlight » Thu Jan 18, 2018 5:53 am

EV-soft wrote:
Wed Jan 17, 2018 3:41 am
Installation conditions: PHP version 7.0x
When I get to Step 3, I get the following messages:

Warning: mysqli::__construct() [mysqli.construct]: (HY000/2002): Connection refused in /var/www/xxx.com/public_html/OpenCart/system/library/db/mysqli.php on line 7
Warning: DB\MySQLi::__construct() [db\mysqli.construct]: Couldn't fetch mysqli in /var/www/xxx.com/public_html/OpenCart/system/library/db/mysqli.php on line 10
Warning: DB\MySQLi::__construct() [db\mysqli.construct]: Couldn't fetch mysqli in /var/www/xxx.com/public_html/OpenCart/system/library/db/mysqli.php on line 10
Notice: Undefined variable: mysql in /var/www/xxx.com/public_html/OpenCart/install/controller/install/step_3.php on line 280
Notice: Trying to get property of non-object in /var/www/xxx.com/public_html/OpenCart/install/controller/install/step_3.php on line 280

What can my problem be like?
Ensure to have set the proper credentials in your config.php and admin/config.php files. If you do not know your database credentials, contact your host and / or check your host database console.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by EV-soft » Thu Jan 18, 2018 7:49 pm

The 2 config files are empty because the error occurs before they are initiated!
I have double checked both the password and the admin name
I have also tried installation on 2 different servers.
I suspect mysql should be mysqli in the message:
Notice: Undefined variable: mysql
Is it for sure it's not a bug?

Newbie

Posts

Joined
Wed Jan 17, 2018 3:02 am

Post by straightlight » Fri Jan 19, 2018 7:31 am

The 2 config files are empty
Both config.php files should not be empty.
I suspect mysql should be mysqli in the message:
Notice: Undefined variable: mysql
Correct. In both config.php files, your DB_DRIVER should be set to: mysqli

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by AlexChanHK » Fri Jan 19, 2018 4:40 pm

Hi EV-soft,
Firstly, we suggest to install the Opencart system in hosting area with PHP5.6, please try to change it.
Second, if you download the system from official way, it should not be a bug.
However, the message show that the database access is incorrect, we think you should double check.
Otherwise, please send a support ticket in the contact us form of Opencart.com, we will help you in there. ;)
Hi straightlight,
We think you have a big misunderstand, EV-soft's config.php are empty should be due he/she even did not install yet. :-[

__________________________________________________________________
New web developer in Opencart ;)
Please mention we work at 9:30 am to 18:30 pm in every Monday to Friday.(UTC+8)


New member

Posts

Joined
Thu Mar 16, 2017 4:34 pm

Post by EV-soft » Fri Jan 19, 2018 6:47 pm

Thank you for clarification.
PHP5.6 is not possible. Active Support for this version has ended.
My download is retrieved here:
https://www.opencart.com/index.php?rout ... load_id=55
I give up for the moment.
Maybe I try again when an update has been published.

Newbie

Posts

Joined
Wed Jan 17, 2018 3:02 am

Post by straightlight » Sat Jan 20, 2018 6:05 am

EV-soft wrote:
Fri Jan 19, 2018 6:47 pm
Thank you for clarification.
PHP5.6 is not possible. Active Support for this version has ended.
My download is retrieved here:
https://www.opencart.com/index.php?rout ... load_id=55
I give up for the moment.
Maybe I try again when an update has been published.
If PHP v5.6 support has ended, use PHP 7.2 or above. It has been proved to work by other posts on the forum.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 10 guests