Post by oz457 » Tue Jan 16, 2018 12:33 am

I'm sorry if this question has been asked many times before, but I cannot find a clear answer in previous posts.
I currently run version 2.0.3.1 and I have a test environment to test upgrades, etc.
Can version 2.0.3.1 be upgraded easily to version 3.0.2.0. Will the upgrade script of 3.0.2.0 be able to handle the database upgrade?
I tried to do this upgrade, but I get following error when running http://www.myshop.com/install
---paste starts here-->
Notice: Use of undefined constant DB_DRIVER - assumed 'DB_DRIVER' in /myshop/install/controller/startup/database.php on line 19
<--paste stops here--

I have been able to do upgrades in the past, but I have the feeling that there are so many things that have changed, I'll never be able to upgrade my opencart.
In the meantime, I'd like to also ask a question on who is willing to help out to do the upgrade so I can hire a professional.
Please note my opencart is running on my own ubuntu server.
Any help is welcome. You can also contact me via email on kurt.vlaminck@proximus.be

New member

Posts

Joined
Wed Oct 28, 2009 5:33 am

Post by straightlight » Tue Jan 16, 2018 6:07 am

Ensure to configure your DB_DRIVER within your config.php and admin/config.php files.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 5 guests