Post by Nordikota » Sun Dec 17, 2017 5:30 pm

I'm trying to install a fresh version of 3.2, but when I try to run the install I get a message saying "PHP5.4+ Required". My host is running PHP 5.6.
Any ideas what I need to do?

Active Member

Posts

Joined
Tue Feb 11, 2014 8:04 pm

Post by straightlight » Sun Dec 17, 2017 11:23 pm

Upgrade issues with Apache. Contact your host to resolve this problem and provide the error message that you are noticing from the Opencart installation.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by swguy » Tue Dec 19, 2017 8:59 am

An issue with Apache seems *really* unlikely. I would guess that for some reason, in the subdir you are running opencart in (or at least the installer in), you are running an older version of php. If you can just run a small script like this:

Code: Select all

<?php
echo   phpversion(); 
you can figure out what version you are actually running. Remember php.ini and .htaccess files can wind up changing your php version in a single directory.

Better Together: Buy one product, get another at a discount.
Discount Chooser: Buy a group of products, get another group at a discount.


User avatar
New member

Posts

Joined
Mon Apr 15, 2013 4:13 am

Post by straightlight » Tue Dec 19, 2017 9:03 am

Even though the phpversion() can be ran, it does not cure against the fact that two different versions are running on the same environment. The first post is about using a higher version already while Opencart claims to detect a lower version of PHP which Opencart requires a minimum PHP version of 5.4.

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Nordikota » Wed Dec 20, 2017 2:02 am

I'm definitely running PHP v5.6. I don't get an error message, just a white screen that says "PHP5.4+ Required" in the top left hand corner, when I try to go to the install. I am on a sub domain though - is that the problem?

Active Member

Posts

Joined
Tue Feb 11, 2014 8:04 pm

Post by straightlight » Wed Dec 20, 2017 2:04 am

Nordikota wrote:
Wed Dec 20, 2017 2:02 am
I'm definitely running PHP v5.6. I don't get an error message, just a white screen that says "PHP5.4+ Required" in the top left hand corner, when I try to go to the install. I am on a sub domain though - is that the problem?
What does the access logs indicates on this recent event from your host console - > error logs?

The most generated errors being found on Opencart forum originates from contributed programming.

Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Nordikota » Wed Dec 20, 2017 4:39 am

I think I've fixed it. the sub domain needed a .htaccess file that stated PHP version. Not sure if this is Host related or OC related. But it fixed the issue.

Active Member

Posts

Joined
Tue Feb 11, 2014 8:04 pm
Who is online

Users browsing this forum: No registered users and 8 guests