Page 2 of 2

Re: Signature hash does not match - marketplace API

Posted: Mon Apr 02, 2018 1:18 pm
by giancarlo64
Ok,
it works if I download the extension locally to my PC and after I install it uploading it to my OC.

Re: Signature hash does not match - marketplace API

Posted: Wed Sep 26, 2018 5:55 am
by Dsignjewlry
I had an issue with the API settings saving after i input them. This is apparently a permissions issue where the web server does have the ability to write the string to wherever it was stored. To solve this issue i changed the owner of the entire installation to the user that apache is running as.
For ubuntu this would be
sudo chown -R www-data:www-data /var/www/html

for fedora based servers it would be
sudo chown -R apache:apache /var/www/html (or wherever your opencart install is)

Re: Signature hash does not match - marketplace API

Posted: Wed Sep 26, 2018 11:06 pm
by rj-10x
Hello.

Guys I have SOLUTION:
Step 1. Go to www.opencart.com and sign up. After that you will have a username or login: http://prntscr.com/kz05mk
Step 2. Make a password. Go to your account, click the "Your Stores -- Register your store to access the marketplace API" http://prntscr.com/kz07u7 Add your store by typing only URL without any http or https or www only the domain name. After that you will have a password: http://prntscr.com/kz0a1j

Re: Signature hash does not match - marketplace API

Posted: Wed May 15, 2019 5:47 am
by MasterCATZ
Tired adding store does not provide any user / password for api ?

Re: Signature hash does not match - marketplace API

Posted: Sat Aug 24, 2019 2:08 am
by benli
Not a bug!!!
Press the settings button in the marketplace page (top right).
Fill in opencart.com username. In your opencart.com account go to "your stores".
Press "add store"
Fill in domain or ip.
save
view
copy key and paste in the marketplace popup.

Good luck

Re: Signature hash does not match - marketplace API

Posted: Fri Sep 27, 2019 9:21 pm
by islam store
Hello
I have the same problem and found the solution
In your OpenCart account
Add the URL as it appears on your site
If it's with www
Write it completely like this www.yoursite.com
And if not with www
Type it as yoursite.com

Good luck